summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:15 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:50 +0100
commit8c417c6b639a14eca61c7efbff872a643b667d83 (patch)
tree84804d991c1edc5624062e43b871a56a7c78fe50
parentdev-haskell/mtl: Raise lower bounds on GHC (diff)
downloadgentoo-8c417c6b639a14eca61c7efbff872a643b667d83.tar.gz
gentoo-8c417c6b639a14eca61c7efbff872a643b667d83.tar.bz2
gentoo-8c417c6b639a14eca61c7efbff872a643b667d83.zip
dev-haskell/exceptions: Raise lower bounds on GHC
Update CABAL_CORE_LIB_GHC_PV Hackage revision bump Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/exceptions/Manifest1
-rw-r--r--dev-haskell/exceptions/exceptions-0.10.4-r1.ebuild39
-rw-r--r--dev-haskell/exceptions/exceptions-0.10.4-r3.ebuild37
-rw-r--r--dev-haskell/exceptions/metadata.xml1
4 files changed, 39 insertions, 39 deletions
diff --git a/dev-haskell/exceptions/Manifest b/dev-haskell/exceptions/Manifest
index 149802f810fb..d1987ad1ac87 100644
--- a/dev-haskell/exceptions/Manifest
+++ b/dev-haskell/exceptions/Manifest
@@ -1 +1,2 @@
+DIST exceptions-0.10.4-rev3.cabal 2796 BLAKE2B c6c3acf942b522666d88467a0b90940d5272568a1eea114c2ac7711b5ebea832e8e5ad3bf220b5270e2898230a890fe598878314e543b2c5d7d59c5abbf1206e SHA512 b49eb865b4f3f12afe0b8b4fb41f50d2f03b47f6a704f026cf34bbe513e7b31510aeec7948e224cef37a2f5261cc27973b920e58201a4a2de8e62ea137828f30
DIST exceptions-0.10.4.tar.gz 20819 BLAKE2B 16873edfeb540ddf5b950f81772c7d162e3fc37d286dcf6608c4c3017516a4255fb7cad247025aa9b0970508613038a3d0b42eccf22e74a0c4efffdfa22be5d3 SHA512 3df1edb4abab8e2e2dbd7387809d9768efca36c6840225ce33bee8679a4efdcf86d28beafb54a9a40e512163e4d088f94e788341bf614869bbdbd9d701bca4a2
diff --git a/dev-haskell/exceptions/exceptions-0.10.4-r1.ebuild b/dev-haskell/exceptions/exceptions-0.10.4-r1.ebuild
deleted file mode 100644
index cb46322c8199..000000000000
--- a/dev-haskell/exceptions/exceptions-0.10.4-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.6.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Extensible optionally-pure exceptions"
-HOMEPAGE="https://github.com/ekmett/exceptions/"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
- >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-3:=[profile?]
- >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.7:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.15
- >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
- >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
- >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
-"
-
-CABAL_CORE_LIB_GHC_PV="8.10.6 9.0.2"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'QuickCheck >= 2.5 && < 2.14' 'QuickCheck >= 2.5'
-}
diff --git a/dev-haskell/exceptions/exceptions-0.10.4-r3.ebuild b/dev-haskell/exceptions/exceptions-0.10.4-r3.ebuild
new file mode 100644
index 000000000000..a86f8a666f65
--- /dev/null
+++ b/dev-haskell/exceptions/exceptions-0.10.4-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_HACKAGE_REVISION=3
+
+# Disable test suite on bundled packages (haskell-cabal.eclass won't allow them
+# to be rebuilt because of CABAL_CORE_LIB_GHC_PV)
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+inherit haskell-cabal
+RESTRICT="test"
+
+DESCRIPTION="Extensible optionally-pure exceptions"
+HOMEPAGE="https://github.com/ekmett/exceptions/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+# test? (
+# >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.15
+# >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+# >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+# >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4
+# )
+
+CABAL_CORE_LIB_GHC_PV="8.10.6 8.10.7 9.0.2 9.2.4 9.2.5 9.2.6 9.2.7 9.2.8"
diff --git a/dev-haskell/exceptions/metadata.xml b/dev-haskell/exceptions/metadata.xml
index 0143342131b7..ae412adc8134 100644
--- a/dev-haskell/exceptions/metadata.xml
+++ b/dev-haskell/exceptions/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
+ <remote-id type="hackage">exceptions</remote-id>
<remote-id type="github">ekmett/exceptions</remote-id>
</upstream>
</pkgmetadata>