summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-09-27 01:13:09 +0530
committerZac Medico <zmedico@gentoo.org>2023-09-26 22:58:49 -0700
commit8c6eab345ef49bc684e162612a3aa9281beba13c (patch)
tree3fe997dfc8623a200af95c8bf2452365a6202725
parentdev-python/tifffile: Bump to 2023.9.26 (diff)
downloadgentoo-8c6eab345ef49bc684e162612a3aa9281beba13c.tar.gz
gentoo-8c6eab345ef49bc684e162612a3aa9281beba13c.tar.bz2
gentoo-8c6eab345ef49bc684e162612a3aa9281beba13c.zip
app-containers/catatonit: add live & fix symlink
Closes: https://github.com/gentoo/gentoo/pull/33075 Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-containers/catatonit/catatonit-0.1.7-r1.ebuild31
-rw-r--r--app-containers/catatonit/catatonit-9999.ebuild30
-rw-r--r--app-containers/catatonit/metadata.xml10
3 files changed, 71 insertions, 0 deletions
diff --git a/app-containers/catatonit/catatonit-0.1.7-r1.ebuild b/app-containers/catatonit/catatonit-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..ed448c4f8b05
--- /dev/null
+++ b/app-containers/catatonit/catatonit-0.1.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A container init that is so simple it's effectively brain-dead"
+HOMEPAGE="https://github.com/openSUSE/catatonit"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openSUSE/catatonit.git"
+else
+ SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ sed -i -e 's|^AM_INIT_AUTOMAKE$||;' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ dosym -r /usr/bin/"${PN}" /usr/libexec/podman/"${PN}"
+}
diff --git a/app-containers/catatonit/catatonit-9999.ebuild b/app-containers/catatonit/catatonit-9999.ebuild
new file mode 100644
index 000000000000..1531acd41b04
--- /dev/null
+++ b/app-containers/catatonit/catatonit-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A container init that is so simple it's effectively brain-dead"
+HOMEPAGE="https://github.com/openSUSE/catatonit"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openSUSE/catatonit.git"
+else
+ SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ dosym -r /usr/bin/"${PN}" /usr/libexec/podman/"${PN}"
+}
diff --git a/app-containers/catatonit/metadata.xml b/app-containers/catatonit/metadata.xml
index dd80ca2b54fb..e709b5447a7e 100644
--- a/app-containers/catatonit/metadata.xml
+++ b/app-containers/catatonit/metadata.xml
@@ -4,7 +4,17 @@
<maintainer type="person">
<email>zmedico@gentoo.org</email>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">openSUSE/catatonit</remote-id>
+ <bugs-to>https://github.com/openSUSE/catatonit/issues</bugs-to>
+ <doc>https://github.com/openSUSE/catatonit/blob/main/README.md</doc>
</upstream>
</pkgmetadata>