summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-07-21 22:14:06 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-10 09:56:38 +0300
commit8c8ab49d518512a5636b4688afc11dbe8ceb639e (patch)
tree1cbf674880563b1b33df08ac0fffbc8c41cebdfc
parentnet-irc/quasselgrep: Added upstream bug address (diff)
downloadgentoo-8c8ab49d518512a5636b4688afc11dbe8ceb639e.tar.gz
gentoo-8c8ab49d518512a5636b4688afc11dbe8ceb639e.tar.bz2
gentoo-8c8ab49d518512a5636b4688afc11dbe8ceb639e.zip
sys-apps/smc-sum: make sys-apps/smc-sum-driver optional
Since sys-apps/smc-sum can be also used remote, make the installation of the kernel module optional. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-apps/smc-sum/metadata.xml3
-rw-r--r--sys-apps/smc-sum/smc-sum-2.2.0.20190220-r1.ebuild39
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/smc-sum/metadata.xml b/sys-apps/smc-sum/metadata.xml
index f51d8926c17f..f8c11efe2d37 100644
--- a/sys-apps/smc-sum/metadata.xml
+++ b/sys-apps/smc-sum/metadata.xml
@@ -20,4 +20,7 @@
of the OS on the managed system and even before the system OS is installed.
Licensing: SFT-OOB-LIC or SFT-DCMS-Single required for each monitor node.
</longdescription>
+ <use>
+ <flag name="module">Install Supermicro's kernel module.</flag>
+ </use>
</pkgmetadata>
diff --git a/sys-apps/smc-sum/smc-sum-2.2.0.20190220-r1.ebuild b/sys-apps/smc-sum/smc-sum-2.2.0.20190220-r1.ebuild
new file mode 100644
index 000000000000..aa3d81c05b4c
--- /dev/null
+++ b/sys-apps/smc-sum/smc-sum-2.2.0.20190220-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN/smc-/}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Updates the BIOS and IPMI firmware and system settings on Supermicro mainboards"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_Linux_x86_64_${MY_DATE}.tar.gz"
+
+LICENSE="supermicro"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="module"
+
+RDEPEND="module? ( sys-apps/smc-sum-driver )"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_Linux_x86_64"
+
+DOCS=( "ReleaseNote.txt" "SUM_UserGuide.pdf" "sumrc.sample" "ExternalData/SMCIPID.txt" "ExternalData/VENID.txt" )
+
+QA_PREBUILT="usr/bin/smc-sum"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SUM"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ newbin sum smc-sum
+
+ einstalldocs
+}