summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-10 03:39:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-10 03:46:49 +0200
commit8d19263ea7beb23f7e17ac823da425e7c8a5ea25 (patch)
tree99b7cb6b361367b908fc09da3b083645b4676ed0
parentsys-boot/grub: mention grub-mkconfig in upgrade warning (diff)
downloadgentoo-8d19263ea7beb23f7e17ac823da425e7c8a5ea25.tar.gz
gentoo-8d19263ea7beb23f7e17ac823da425e7c8a5ea25.tar.bz2
gentoo-8d19263ea7beb23f7e17ac823da425e7c8a5ea25.zip
dev-python/pytest-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.10.0.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 10602264b9d9..fc86437af047 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,2 +1 @@
-DIST pytest-mock-3.10.0.tar.gz 28384 BLAKE2B 2f51f8be34094054b8f7864eb083dde00800adb73af668444d21c95d8f159594bed0f68694e7ffb0e24da402a4865f37c07d85622ad00f130ccdb4e3d189bf9a SHA512 2ad6866d581a2999899e399ef5516d478a6172f52923f03703e3e3708229fb3b1178c91225b5cc90734c96abcb48fea517b11e0fc193da6fb592295395c14cd3
DIST pytest-mock-3.11.1.tar.gz 31251 BLAKE2B 26655487947d614483f082f17c9f3a9fc2688c016d07c6d4c4e34c369f87f3d914cf82d966a655e1eee501088d27d711f1b65f0c777678254dcfffa5c8c7585f SHA512 f52147498657d35f4616ea788b500a68ffcf1c2c066047fb973308b54e11bd7fe5a3961115bab99ae6858000ebb68b35cc489e81221a0bd26afae8426092ff6b
diff --git a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
deleted file mode 100644
index a72e71fb4369..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-mock/
- https://pypi.org/project/pytest-mock/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # obsolete, upst. e2016928db1147a2a46de6ee9fa878ca0e9d8fc8
- sed -i -e '/import py\.code/d' tests/test_pytest_mock.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
- local EPYTEST_DESELECT=()
-
- if has_version dev-python/mock; then
- EPYTEST_DESELECT+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- epytest --assert=plain
-}