summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-21 21:44:35 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-21 21:51:52 +0200
commit8ecec2e2b2039a1e6f95fa87c7aabd5e369f6733 (patch)
treec164811f72fd2b691c9c9a254bb3c79056fde503
parentdev-cpp/gtkmm: bump to 3.24.1 (diff)
downloadgentoo-8ecec2e2b2039a1e6f95fa87c7aabd5e369f6733.tar.gz
gentoo-8ecec2e2b2039a1e6f95fa87c7aabd5e369f6733.tar.bz2
gentoo-8ecec2e2b2039a1e6f95fa87c7aabd5e369f6733.zip
x11-libs/gtksourceview: bump to 3.24.10
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-libs/gtksourceview/Manifest1
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.24.10.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index dc4775acebba..8de32b575b7f 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -1,4 +1,5 @@
DIST gtksourceview-2.10.5.tar.bz2 1253321 BLAKE2B 810a3eeca69bab4356b21c64129bb852e00d02c7937ad4a2ce3af9e48700da943d8d6834efcce9810dd49a54f39d4a074dc086a557128da51a593b2f23e58d48 SHA512 6f64acef6196bfc5953e0b148d7e460d366073b5e21367c01b01fc4d1c86ffe8aca71ecd77cf0814e47d8fc3085495f25bbbdc69e746987b02fd02fcda64886d
+DIST gtksourceview-3.24.10.tar.xz 1422888 BLAKE2B df344049095a354d49474d0ff0ae9d875d1b523452d19f894a3e4615889ab402bf20c4870f4aea7665ea89fd219dc7d441b8b40576e331f90a2d218d4815a45f SHA512 990935ed7c3b10a1659cf22bd36eb71e76088768f7b70234b50465f542592720bb6b206746e0606c96ab99ba0208535fc6073b4f6c0f3427acd0ab5a43420d46
DIST gtksourceview-3.24.8.tar.xz 1408964 BLAKE2B e406aa9f776821abfcc87333fc955b4f3ae334f73a8b1dfa0b123067df24bd4f473e326347c99df7dc6c97adbdde8739cb301e45ca70324f6e8de2ce9e1ea973 SHA512 84a02278344f9fe3c1b8f2440c6179feaea53df93061c63023d92bcaa1ec7ff8e95e1f3a463c23d8487c74492469f3dc367bcca3975ef169bf03925ecee7f7ff
DIST gtksourceview-3.24.9.tar.xz 1414444 BLAKE2B 9d148fba03339c7dccca70822f498aea6423125af1a954e0c9f8ff9735141fc9e4f845c7172be5faf97e694445dc95d41d5d903ef5b5da3dd0ce7fe58b524ca7 SHA512 29b58afba1c0b473205cf7070997139d2ca07cf68d40185aa76fa59c900ad21c03ccb79dec9970e5f96743cfdb5a7d926b21a9947244bc8cf8cbd1033467cd01
DIST gtksourceview-4.0.3.tar.xz 1396640 BLAKE2B 5e5f84597c1f75a732ac487c2107eb54be2740eb2cabd177aec76cb4b2504a32969c4918e2a1294e9d486660090985a4f588dbde49f241fbb1493eaa3daa335b SHA512 d3f7512bddf247166c12dc38bc66d55e44c1830f9b8d62758f06cb7117e33f8908f4d8186b9d7e77514623a58f3a973cc75e3fd6a09c5f891f8b948012a76955
diff --git a/x11-libs/gtksourceview/gtksourceview-3.24.10.ebuild b/x11-libs/gtksourceview/gtksourceview-3.24.10.ebuild
new file mode 100644
index 000000000000..0fd73d20f6c1
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.24.10.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+
+IUSE="glade +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.48:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}