summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaymon MARNADI <darwinskernel@gmail.com>2021-10-06 13:49:45 -0400
committerFlorian Schmaus <flow@gentoo.org>2021-11-29 16:41:56 +0100
commit90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e (patch)
tree796ac29abaca2cc620f36506ffa044de95242765
parentmail-client/roundcube: 1.5.1 version bump (diff)
downloadgentoo-90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e.tar.gz
gentoo-90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e.tar.bz2
gentoo-90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e.zip
app-admin/mkosi: add mkosi
... in anticipation of the PR for gentoo support [upstream-pr] getting closer to being merged. [upstream-pr] https://github.com/systemd/mkosi/pull/717 Signed-off-by: Paymon MARANDI <darwinskernel@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22509 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--app-admin/mkosi/Manifest1
-rw-r--r--app-admin/mkosi/metadata.xml12
-rw-r--r--app-admin/mkosi/mkosi-11.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/mkosi/Manifest b/app-admin/mkosi/Manifest
new file mode 100644
index 000000000000..24196fede00d
--- /dev/null
+++ b/app-admin/mkosi/Manifest
@@ -0,0 +1 @@
+DIST mkosi-11.tar.gz 165064 BLAKE2B 19a140fa355dff946dfd46369ccdcce369d97e5ef5c8a0917f21d1f5876c302e54b1e8e509d3cfa54d72a2b4d5b1d97abe74ff2232e3a8ca84005358ed6a99fa SHA512 c07b092e38e663100cfa00ce58c2b61d306292f69429835915310f9736e11ea1431ae2667e8fca02c2a145aa4f21bd199f956d2882913474c4cee394bb15a8f2
diff --git a/app-admin/mkosi/metadata.xml b/app-admin/mkosi/metadata.xml
new file mode 100644
index 000000000000..88b16f016f27
--- /dev/null
+++ b/app-admin/mkosi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>darwinskernel@gmail.com</email>
+ <name>Paymon MARANDI</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/mkosi/mkosi-11.ebuild b/app-admin/mkosi/mkosi-11.ebuild
new file mode 100644
index 000000000000..2c90bec35ee1
--- /dev/null
+++ b/app-admin/mkosi/mkosi-11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Build Bespoke OS Images"
+HOMEPAGE="https://github.com/systemd/mkosi"
+SRC_URI="https://github.com/systemd/mkosi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="
+ sys-apps/portage
+ sys-apps/systemd
+ dev-vcs/git
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "For debian support: " dev-util/debootstrap
+}