summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-01 05:01:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-01 05:13:13 +0100
commit90fddcaa71144b46d617d1537bc171651f420322 (patch)
tree4ee0a6a74101a002703d71bdc66653aa573d7565
parentkde-frameworks/kirigami: don't default-enable USE=openmp (diff)
downloadgentoo-90fddcaa71144b46d617d1537bc171651f420322.tar.gz
gentoo-90fddcaa71144b46d617d1537bc171651f420322.tar.bz2
gentoo-90fddcaa71144b46d617d1537bc171651f420322.zip
dev-python/seaborn: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/seaborn/Manifest1
-rw-r--r--dev-python/seaborn/seaborn-0.13.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index 893779dfa24f..5ccda5dd6c2a 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1 +1,2 @@
DIST seaborn-0.13.0.tar.gz 1455480 BLAKE2B 9f7383715366889ffd80788f901c574d9330285da2098e5695e944f1c6b92d4e417163a82378dd75c03233fc6485158401a1aaa461f2fa8e71a4cbc3ebf957cb SHA512 d603e880c29e05ab68f86d285c5c5ee9cf2da1d45265ed609f7bc87650fe20e80c026af487f63f9492a268f51ba5bab0cae4fd8fdeaf28125d16d317f9c937c8
+DIST seaborn-0.13.1.tar.gz 1457600 BLAKE2B 73296257f1d7525cebb90bf6f97fa6e5f91e3e9df653e0b9ab81eb6d04a1eb957a9c623aa8b4a715162175a501f55dd7e787335175503cab451bb03318e822cf SHA512 b90483bffd3435cc058143dccc854eb175ec7d7a095b8ce8261fbcad3f97f5e9b035a790a04dc2c64c35dda5b0ab8562f0b4a99e09a5e2fc9c4ee8323a153910
diff --git a/dev-python/seaborn/seaborn-0.13.1.ebuild b/dev-python/seaborn/seaborn-0.13.1.ebuild
new file mode 100644
index 000000000000..c377b54e8c4a
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.13.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="
+ https://seaborn.pydata.org/
+ https://github.com/mwaskom/seaborn/
+ https://pypi.org/project/seaborn/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/matplotlib-3.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.2[${PYTHON_USEDEP}]
+ >=dev-python/statsmodels-0.12[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.7[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ cat > matplotlibrc <<- EOF || die
+ backend : Agg
+ EOF
+
+ distutils-r1_src_test
+}