summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2021-11-29 05:12:45 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-12-01 20:02:18 +0200
commit92bc07bb4bb4afe89c8447736c630cc0c8273a42 (patch)
tree6d1c3edcd2d257956be2533c498eecc47107ad0d
parentdev-ruby/ruby-feedparser: add 0.10.0 (diff)
downloadgentoo-92bc07bb4bb4afe89c8447736c630cc0c8273a42.tar.gz
gentoo-92bc07bb4bb4afe89c8447736c630cc0c8273a42.tar.bz2
gentoo-92bc07bb4bb4afe89c8447736c630cc0c8273a42.zip
app-emulation/crun: add 1.3
Closes: https://bugs.gentoo.org/827821 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alexey Zapparov <alexey@zapparov.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-emulation/crun/Manifest1
-rw-r--r--app-emulation/crun/crun-1.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index 91b667a3ed95..e4bf92580755 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1,2 +1,3 @@
DIST crun-0.19.1.tar.gz 1870594 BLAKE2B 1780a2936ff39ec80836c4c9ae072e2fc30703a31a79786337290c62dd433b5a35dcfa953be370703d1baab3de93fdb376c99ab76dff1470883c61726c313144 SHA512 f93f79d1d63d6749bcf92d48542d9555f3ad47657c959c7c06701861d7a5a4171969f00f6dff3878286970a48aba3314c25e35c005463e606533b0ff7843d994
DIST crun-1.2.tar.gz 1879836 BLAKE2B 45370e3206a13c963d694f338dc0a00de24253025d31ec893353905235b239b8e7f626ddd4ee0cc32da2b3f5676b42f59f3214a1eb9c3af4612483cd6fd14693 SHA512 5cadaf0eb0e9bcf53726e7f6ffb664c8327f0f4e7cdbf75ae8a0cd4759f7c8a8a2611df65ca1436a50d7af5d37505aac861d7db4d46a93c3832362228cb37cbc
+DIST crun-1.3.tar.gz 1889283 BLAKE2B d7e7f676ca5db8322b9da2110c9a9e8eb11b13b5e9f1432ccc6ef12bf6ae7db3a28e3227fac86091589a215394ec577e91ccbffec532dabf44be746cb8a5d404 SHA512 9600bdacf5fd2defa542230b6e134920eb80e9d4c49598167b9d58887719765c174f1ac8559c0092dc1b5435274124e0b29c3d0830df86d1cfd690d67c746016
diff --git a/app-emulation/crun/crun-1.3.ebuild b/app-emulation/crun/crun-1.3.ebuild
new file mode 100644
index 000000000000..29ed772f9849
--- /dev/null
+++ b/app-emulation/crun/crun-1.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="+bpf +caps criu +seccomp systemd static-libs"
+
+DEPEND="
+ dev-libs/yajl:=
+ sys-kernel/linux-headers
+ caps? ( sys-libs/libcap )
+ criu? ( >=sys-process/criu-3.15 )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable bpf)
+ $(use_enable caps)
+ $(use_enable criu)
+ $(use_enable seccomp)
+ $(use_enable systemd)
+ $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C libocispec
+ emake crun
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install-exec
+ doman crun.1
+ einstalldocs
+}