summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-04-14 09:35:02 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-04-15 08:02:30 -0700
commit92d715d96d8618e6f5538e1ca6739ef584bd5a2d (patch)
tree72a386f715cfdb738eaef2680d72f472d0c351bd
parentdev-python/pygccxml: Add python@ as co-maintainer (diff)
downloadgentoo-92d715d96d8618e6f5538e1ca6739ef584bd5a2d.tar.gz
gentoo-92d715d96d8618e6f5538e1ca6739ef584bd5a2d.tar.bz2
gentoo-92d715d96d8618e6f5538e1ca6739ef584bd5a2d.zip
sys-apps/clrngd: cleanup init
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/484696
-rw-r--r--sys-apps/clrngd/clrngd-1.0.3-r2.ebuild35
-rw-r--r--sys-apps/clrngd/files/clrngd-init.d-r214
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/clrngd/clrngd-1.0.3-r2.ebuild b/sys-apps/clrngd/clrngd-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..8f8098302781
--- /dev/null
+++ b/sys-apps/clrngd/clrngd-1.0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Clock randomness gathering daemon"
+HOMEPAGE="http://echelon.pl/pubs/"
+SRC_URI="http://echelon.pl/pubs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-implicit-func-declaration.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --bindir="${EPREFIX}"/usr/sbin
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r2 ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+}
diff --git a/sys-apps/clrngd/files/clrngd-init.d-r2 b/sys-apps/clrngd/files/clrngd-init.d-r2
new file mode 100644
index 000000000000..5a7bc5be924d
--- /dev/null
+++ b/sys-apps/clrngd/files/clrngd-init.d-r2
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name='clrngd'
+command='/usr/sbin/clrngd'
+command_args="${clrngd_opts:-${DELAYTIME}}"
+description="Clock entropy for RNG"
+
+depend() {
+ after random
+ before net
+ provide entropy
+}