summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-21 14:12:32 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-21 14:12:40 +0200
commit932f2e108a05f22f39ebccf1edbbbc20a50f4e07 (patch)
tree5414d4e6acbf7dd9fc11aa57921b44d0592d20a0
parentapp-admin/rsyslog: bump to 8.2306.0 (diff)
downloadgentoo-932f2e108a05f22f39ebccf1edbbbc20a50f4e07.tar.gz
gentoo-932f2e108a05f22f39ebccf1edbbbc20a50f4e07.tar.bz2
gentoo-932f2e108a05f22f39ebccf1edbbbc20a50f4e07.zip
dev-python/python-mpv: enable py3.12
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/python-mpv/python-mpv-1.0.3.ebuild10
1 files changed, 1 insertions, 9 deletions
diff --git a/dev-python/python-mpv/python-mpv-1.0.3.ebuild b/dev-python/python-mpv/python-mpv-1.0.3.ebuild
index 194d0f3edd53..9b0cc7cec67b 100644
--- a/dev-python/python-mpv/python-mpv-1.0.3.ebuild
+++ b/dev-python/python-mpv/python-mpv-1.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 virtualx
@@ -25,13 +25,5 @@ BDEPEND="test? ( dev-python/xvfbwrapper[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
python_test() {
- # https://github.com/jaseg/python-mpv/issues/209
- EPYTEST_DESELECT=(
- tests/test_mpv.py::TestLifecycle::test_wait_for_property_negative
- tests/test_mpv.py::TestLifecycle::test_wait_for_property_positive
- tests/test_mpv.py::TestLifecycle::test_wait_for_property_shutdown
- tests/test_mpv.py::TestLifecycle::test_wait_for_prooperty_event_overflow
- tests/test_mpv.py::TestLifecycle::test_event_callback
- )
virtx epytest
}