summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-25 23:44:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-26 08:05:38 +0200
commit93f51e4eda6d4af869cb55345f57ada6c574382d (patch)
tree652c8d604f445769d2b5c118c1f745589252fc46
parentdev-python/pip: Fix PYTHON_REQ_USE (diff)
downloadgentoo-93f51e4eda6d4af869cb55345f57ada6c574382d.tar.gz
gentoo-93f51e4eda6d4af869cb55345f57ada6c574382d.tar.bz2
gentoo-93f51e4eda6d4af869cb55345f57ada6c574382d.zip
profiles: Remove last-rited dev-util/automoc, media-libs/phonon-qt7
-rw-r--r--dev-util/automoc/Manifest1
-rw-r--r--dev-util/automoc/automoc-0.9.88-r1.ebuild34
-rw-r--r--dev-util/automoc/files/automoc-0.9.88-objc++.patch48
-rw-r--r--dev-util/automoc/metadata.xml8
-rw-r--r--media-libs/phonon-qt7/Manifest1
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch28
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch29
-rw-r--r--media-libs/phonon-qt7/files/phonon-qt7-noshow.patch17
-rw-r--r--media-libs/phonon-qt7/metadata.xml12
-rw-r--r--media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild40
-rw-r--r--profiles/package.mask5
11 files changed, 0 insertions, 223 deletions
diff --git a/dev-util/automoc/Manifest b/dev-util/automoc/Manifest
deleted file mode 100644
index 248f11b12795..000000000000
--- a/dev-util/automoc/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST automoc4-0.9.88.tar.bz2 9153 BLAKE2B 4fbe9a5e07a0ef964b0a4fc4efa898cedeb239129de3f9e83b6081ad6c54469019118f613c9d4fff2a22227e62b374be5541898abf047254806fcfcd63e709a4 SHA512 96dfa096a3793f93f6a4acf98c051c871c0285124bff09b12914a17e08a1f26cd63f0bb1c22fdf2c5c29550a1727a087b5de86bfa8a555c562e96052b4a2d820
diff --git a/dev-util/automoc/automoc-0.9.88-r1.ebuild b/dev-util/automoc/automoc-0.9.88-r1.ebuild
deleted file mode 100644
index 60198cf0b581..000000000000
--- a/dev-util/automoc/automoc-0.9.88-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_PN="automoc4"
-MY_P="${MY_PN}-${PV}"
-inherit cmake-utils flag-o-matic
-
-DESCRIPTION="KDE Meta Object Compiler"
-HOMEPAGE="https://www.kde.org"
-SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="
- dev-qt/qtcore:4
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/${PN}-0.9.88-objc++.patch" )
-
-src_prepare() {
- cmake-utils_src_prepare
-
- if [[ ${ELIBC} = uclibc ]]; then
- append-flags -pthread
- fi
-}
diff --git a/dev-util/automoc/files/automoc-0.9.88-objc++.patch b/dev-util/automoc/files/automoc-0.9.88-objc++.patch
deleted file mode 100644
index 1f4dacdc06eb..000000000000
--- a/dev-util/automoc/files/automoc-0.9.88-objc++.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Please refer to
- http://websvn.kde.org/?view=revision&revision=934696
-
-Adds support for objc++ in automoc, so that running moc on .mm-files will work.
-
---- trunk/kdesupport/automoc/Automoc4Config.cmake 2009/03/03 15:40:57 934695
-+++ trunk/kdesupport/automoc/Automoc4Config.cmake 2009/03/03 15:42:18 934696
-@@ -105,9 +105,9 @@
- if(NOT _generated AND NOT _skip)
- get_filename_component(_suffix "${_current_FILE}" EXT)
- # skip every source file that's not C++
-- if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
-+ if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
- list(APPEND _moc_files ${_abs_current_FILE})
-- endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
-+ endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
- endif(NOT _generated AND NOT _skip)
- endforeach (_current_FILE)
-
-@@ -156,7 +156,7 @@
- if(NOT _generated AND NOT _skip)
- get_filename_component(_suffix "${_current_FILE}" EXT)
- # skip every source file that's not C++
-- if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
-+ if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
- get_filename_component(_basename "${_current_FILE}" NAME_WE)
- get_filename_component(_abs_path "${_abs_current_FILE}" PATH)
- set(_header "${_abs_path}/${_basename}.h")
-@@ -168,7 +168,7 @@
- list(APPEND _moc_headers ${_pheader})
- endif(EXISTS "${_pheader}")
- list(APPEND _moc_files ${_abs_current_FILE})
-- endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
-+ endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
- endif(NOT _generated AND NOT _skip)
- endforeach (_current_FILE)
-
---- trunk/kdesupport/automoc/kde4automoc.cpp 2009/03/03 15:40:57 934695
-+++ trunk/kdesupport/automoc/kde4automoc.cpp 2009/03/03 15:42:18 934696
-@@ -326,7 +326,7 @@
- foreach (const QString &absFilename, sourceFiles) {
- //qDebug() << absFilename;
- const QFileInfo sourceFileInfo(absFilename);
-- if (absFilename.endsWith(".cpp") || absFilename.endsWith(".cc") ||
-+ if (absFilename.endsWith(".cpp") || absFilename.endsWith(".cc") || absFilename.endsWith(".mm") ||
- absFilename.endsWith(".cxx") || absFilename.endsWith(".C")) {
- //qDebug() << "check .cpp file";
- QFile sourceFile(absFilename);
diff --git a/dev-util/automoc/metadata.xml b/dev-util/automoc/metadata.xml
deleted file mode 100644
index 2fdbf33d963d..000000000000
--- a/dev-util/automoc/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/media-libs/phonon-qt7/Manifest b/media-libs/phonon-qt7/Manifest
deleted file mode 100644
index d3a385ce8e7e..000000000000
--- a/media-libs/phonon-qt7/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST phonon-qt7-0_pre20110424.tar.bz2 54610 BLAKE2B 1323e2ca8f34a4b278435df17a2e22c8f4b8ef38abc3dc9fdcc03733cbefcec66d7892a95adf63189317d4f3117a550b084a5573d6cc00ed9088af51beac7508 SHA512 9e694c2effdf2b044118e4afb101e098d479bfc4c97f8f8069dcadbaa44f4dc6371ad15c1487bb1786e1096cbc93b660c0edde87e61f6a9483fce5a7587df2b9
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
deleted file mode 100644
index ae222027b892..000000000000
--- a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-QWidget-cast-dynamic.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Revert commit:
-
-commit b22b86f6940d2605e78398eca4ae05c3ea44a92c
-Author: Ritt Konstantin <ritt.ks@gmail.com>
-Date: Thu Jun 10 07:38:14 2010 +0400
-
- fix build with -fno-rtti
-
- m_renderDrawWidget object inherits QWidget and can be safely static_cast-ed
-
-as it yields in:
-
-error: invalid static_cast from type ‘Phonon::QT7::IVideoRenderDrawWidget*’ to type ‘QWidget*’
-
-
-diff --git a/qt7/videowidget.mm b/qt7/videowidget.mm
-index 736dcdf..e471140 100644
---- a/qt7/videowidget.mm
-+++ b/qt7/videowidget.mm
-@@ -578,7 +578,7 @@ public:
- PhononAutoReleasePool pool;
- updateDrawFrameRect();
- if (m_renderDrawWidget)
-- static_cast<QWidget *>(m_renderDrawWidget)->resize(size());
-+ dynamic_cast<QWidget *>(m_renderDrawWidget)->resize(size());
- break; }
- case QEvent::Paint:{
- PhononAutoReleasePool pool;
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch b/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch
deleted file mode 100644
index 6d1a5626a207..000000000000
--- a/media-libs/phonon-qt7/files/phonon-qt7-0_pre20110424-darwin11.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-disable AUGraphAddNode, it needs an AudioComponent iso Component
-need a definition for gnuOrtho2D
-
---- phonon-qt7/qt7/audionode.mm
-+++ phonon-qt7/qt7/audionode.mm
-@@ -69,9 +69,9 @@
-
- OSStatus err = noErr;
- #if MAC_OS_X_VERSION_MAX_ALLOWED >= MAC_OS_X_VERSION_10_5
-- if (QSysInfo::MacintoshVersion >= QSysInfo::MV_10_5)
-- err = AUGraphAddNode(m_audioGraph->audioGraphRef(), &description, &m_auNode);
-- else
-+// if (QSysInfo::MacintoshVersion >= QSysInfo::MV_10_5)
-+// err = AUGraphAddNode(m_audioGraph->audioGraphRef(), &description, &m_auNode);
-+// else
- #endif
- err = AUGraphNewNode(m_audioGraph->audioGraphRef(), &description, 0, 0, &m_auNode);
-
---- phonon-qt7/qt7/videowidget.mm
-+++ phonon-qt7/qt7/videowidget.mm
-@@ -35,6 +35,8 @@
- #import <AppKit/NSImage.h>
- #import <QTKit/QTMovieView.h>
-
-+#import <OpenGL/glu.h>
-+
- /////////////////////////////////////////////////////////////////////////////////////////
-
- #ifdef QT_MAC_USE_COCOA // Rendering to a QTMovieView can only be done in Cocoa
diff --git a/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch b/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch
deleted file mode 100644
index e05c2c4d9957..000000000000
--- a/media-libs/phonon-qt7/files/phonon-qt7-noshow.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -ruN phonon-qt7.orig/CMakeLists.txt phonon-qt7/CMakeLists.txt
---- phonon-qt7.orig/CMakeLists.txt 2011-04-24 20:22:59.000000000 +0200
-+++ phonon-qt7/CMakeLists.txt 2011-04-24 20:42:15.000000000 +0200
-@@ -2,6 +2,8 @@
-
- cmake_minimum_required(VERSION 2.6.2 FATAL_ERROR)
-
-+set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
-+
- find_package(Phonon REQUIRED)
- find_package(OpenGL REQUIRED)
-
-@@ -17,4 +19,3 @@
- add_subdirectory(qt7)
- endif (Q_WS_MAC)
-
--macro_display_feature_log()
diff --git a/media-libs/phonon-qt7/metadata.xml b/media-libs/phonon-qt7/metadata.xml
deleted file mode 100644
index 465cd64145b1..000000000000
--- a/media-libs/phonon-qt7/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
- </maintainer>
- <maintainer type="project">
- <email>prefix@gentoo.org</email>
- <name>Gentoo Prefix</name>
- </maintainer>
-</pkgmetadata>
diff --git a/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild b/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild
deleted file mode 100644
index e844131a519a..000000000000
--- a/media-libs/phonon-qt7/phonon-qt7-0_pre20110424.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Phonon QuickTime7 backend"
-HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon/phonon-quicktime"
-SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="~ppc-macos ~x64-macos"
-SLOT="0"
-IUSE="debug"
-
-RDEPEND=">=media-libs/phonon-4.5"
-DEPEND="${RDEPEND}
- >=dev-util/automoc-0.9.87
- media-libs/opengl-apple
- sys-devel/gcc-apple[objc]
- virtual/pkgconfig
-"
-
-# needs OpenGL, how do I specify this properly?
-# I just depended on opengl-apple, hope this is what you meant -- grobian
-
-S="${WORKDIR}/${PN}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-noshow.patch"
- "${FILESDIR}"/${P}-QWidget-cast-dynamic.patch
- "${FILESDIR}"/${P}-darwin11.patch
-)
-
-src_prepare() {
- cmake-utils_src_prepare # for PATCHES
- sed -i -e "/^include_directories/s:): ${EPREFIX}/usr/include):" \
- CMakeLists.txt || die
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 95f188ec8366..3779ecbc229c 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -335,11 +335,6 @@ app-crypt/openpgp-keys-gentoo-mirror
# Masked for removal in 30 days. Bug #646118
net-misc/urlview
-# Andreas Sturmlechner <asturm@gentoo.org> (27 May 2018)
-# Depends on dead Qt4. No more revdeps. Masked for removal in 30 days.
-dev-util/automoc
-media-libs/phonon-qt7
-
# Kent Fredric <kentnl@gentoo.org> (27 May 2018)
# Subject to Man-in-the-middle security bypass vulnerability.
# Retained in tree only for users who need older versions