summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-01-21 23:07:04 +0100
committerDavide Pesavento <pesa@gentoo.org>2017-01-21 23:07:36 +0100
commit94c379bcbe5c40707197f209da31547e4e3702eb (patch)
tree5ccfae52fad6b6e10529bc7d56e43401868fd825
parentdev-tex/tex4ht: x86 stable wrt bug #432144 (diff)
downloadgentoo-94c379bcbe5c40707197f209da31547e4e3702eb.tar.gz
gentoo-94c379bcbe5c40707197f209da31547e4e3702eb.tar.bz2
gentoo-94c379bcbe5c40707197f209da31547e4e3702eb.zip
dev-python/qscintilla-python: support building against Qt5/PyQt5
Gentoo-Bug: 541604 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.9.2-r1.ebuild2
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.9.4-r1.ebuild85
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.9.4.ebuild2
-rw-r--r--dev-util/eric/eric-16.12.ebuild4
-rw-r--r--dev-util/eric/eric-17.01.ebuild2
-rw-r--r--dev-vcs/hgview/hgview-1.9.0.ebuild4
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-3.8.4.ebuild2
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-3.9.2.ebuild4
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-4.0.1.ebuild4
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-4.0.ebuild4
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild4
-rw-r--r--net-analyzer/linkchecker/linkchecker-9.3-r1.ebuild4
-rw-r--r--net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild2
-rw-r--r--net-analyzer/linkchecker/linkchecker-9999.ebuild4
-rw-r--r--sci-geosciences/qgis/qgis-2.14.5-r1.ebuild4
-rw-r--r--sci-geosciences/qgis/qgis-2.18.2-r1.ebuild4
-rw-r--r--sci-geosciences/qgis/qgis-2.18.2-r2.ebuild2
-rw-r--r--sci-geosciences/qgis/qgis-2.18.2-r3.ebuild2
-rw-r--r--sci-geosciences/qgis/qgis-2.18.3.ebuild2
19 files changed, 113 insertions, 28 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.9.2-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.9.2-r1.ebuild
index b1671d7ae8ce..02e93095fa1e 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.9.2-r1.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.9.2-r1.ebuild
@@ -53,7 +53,7 @@ src_configure() {
"${myconf[@]}" || die
# Run eqmake4 to respect toolchain, build flags, and prevent stripping
- eqmake4
+ eqmake4 -recursive
}
python_foreach_impl run_in_build_dir configuration
}
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.9.4-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.9.4-r1.ebuild
new file mode 100644
index 000000000000..8c6671955d30
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.9.4-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit python-r1 qmake-utils
+
+MY_P=QScintilla_gpl-${PV}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="debug +qt4 qt5"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ^^ ( qt4 qt5 )
+"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+ ~x11-libs/qscintilla-${PV}:=[qt4(-)?,qt5(+)?]
+ qt4? (
+ >=dev-python/PyQt4-4.11.3[X,${PYTHON_USEDEP}]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_prepare() {
+ default
+ python_copy_sources
+}
+
+src_configure() {
+ local my_qt_ver=$(usex qt5 5 4)
+
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ configure.py
+ --qmake="$(qt${my_qt_ver}_get_bindir)"/qmake
+ --destdir="$(python_get_sitedir)"/PyQt${my_qt_ver}
+ --sip-incdir="$(python_get_includedir)"
+ --pyqt=PyQt${my_qt_ver}
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake to respect toolchain, build flags, and prevent stripping
+ eqmake${my_qt_ver} -recursive
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.9.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.9.4.ebuild
index 444c5883c0da..6174d4c0a67b 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.9.4.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.9.4.ebuild
@@ -53,7 +53,7 @@ src_configure() {
"${myconf[@]}" || die
# Run eqmake4 to respect toolchain, build flags, and prevent stripping
- eqmake4
+ eqmake4 -recursive
}
python_foreach_impl run_in_build_dir configuration
}
diff --git a/dev-util/eric/eric-16.12.ebuild b/dev-util/eric/eric-16.12.ebuild
index 691a9c118ee7..ca9846fcc020 100644
--- a/dev-util/eric/eric-16.12.ebuild
+++ b/dev-util/eric/eric-16.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,7 +23,7 @@ DEPEND="
${PYTHON_DEPS}
>=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
>=dev-python/PyQt4-4.10[${PYTHON_USEDEP},X,help,sql,svg,webkit]
- >=dev-python/qscintilla-python-2.8[${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.8[qt4(+),${PYTHON_USEDEP}]
"
RDEPEND="${DEPEND}
>=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
diff --git a/dev-util/eric/eric-17.01.ebuild b/dev-util/eric/eric-17.01.ebuild
index eb2727e65c90..ca9846fcc020 100644
--- a/dev-util/eric/eric-17.01.ebuild
+++ b/dev-util/eric/eric-17.01.ebuild
@@ -23,7 +23,7 @@ DEPEND="
${PYTHON_DEPS}
>=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
>=dev-python/PyQt4-4.10[${PYTHON_USEDEP},X,help,sql,svg,webkit]
- >=dev-python/qscintilla-python-2.8[${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.8[qt4(+),${PYTHON_USEDEP}]
"
RDEPEND="${DEPEND}
>=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
diff --git a/dev-vcs/hgview/hgview-1.9.0.ebuild b/dev-vcs/hgview/hgview-1.9.0.ebuild
index 7f380288c942..f1c9417d45ff 100644
--- a/dev-vcs/hgview/hgview-1.9.0.ebuild
+++ b/dev-vcs/hgview/hgview-1.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,7 +26,7 @@ RDEPEND="dev-vcs/mercurial[${PYTHON_USEDEP}]
qt4? (
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/PyQt4[X,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}
doc? (
diff --git a/dev-vcs/tortoisehg/tortoisehg-3.8.4.ebuild b/dev-vcs/tortoisehg/tortoisehg-3.8.4.ebuild
index add524291eed..0d40ccc454a9 100644
--- a/dev-vcs/tortoisehg/tortoisehg-3.8.4.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-3.8.4.ebuild
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt4[svg,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
diff --git a/dev-vcs/tortoisehg/tortoisehg-3.9.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-3.9.2.ebuild
index d6b86c8f9a81..51aa692c7b6d 100644
--- a/dev-vcs/tortoisehg/tortoisehg-3.9.2.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-3.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt4[svg,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.0.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.0.1.ebuild
index ae3a7bde3b80..fbb9a0eb51e2 100644
--- a/dev-vcs/tortoisehg/tortoisehg-4.0.1.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-4.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt4[svg,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.0.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.0.ebuild
index ae3a7bde3b80..fbb9a0eb51e2 100644
--- a/dev-vcs/tortoisehg/tortoisehg-4.0.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt4[svg,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 3b0a0c0fca0c..9225a6dbffa4 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt4[svg,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
diff --git a/net-analyzer/linkchecker/linkchecker-9.3-r1.ebuild b/net-analyzer/linkchecker/linkchecker-9.3-r1.ebuild
index ecd8b4e399ab..5a4f929df0fb 100644
--- a/net-analyzer/linkchecker/linkchecker-9.3-r1.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,7 +27,7 @@ RDEPEND="
gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
X? (
dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
)"
DEPEND="
X? (
diff --git a/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild b/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild
index c6022519ee2d..16e55e2ff5f9 100644
--- a/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild
@@ -27,7 +27,7 @@ RDEPEND="
gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
X? (
dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
)"
DEPEND="
X? (
diff --git a/net-analyzer/linkchecker/linkchecker-9999.ebuild b/net-analyzer/linkchecker/linkchecker-9999.ebuild
index 01653b19b942..ad27a47b546a 100644
--- a/net-analyzer/linkchecker/linkchecker-9999.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,7 +26,7 @@ RDEPEND="
gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
X? (
dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
)"
DEPEND="
X? (
diff --git a/sci-geosciences/qgis/qgis-2.14.5-r1.ebuild b/sci-geosciences/qgis/qgis-2.14.5-r1.ebuild
index 3416afd9cc5e..f4fa4774431a 100644
--- a/sci-geosciences/qgis/qgis-2.14.5-r1.ebuild
+++ b/sci-geosciences/qgis/qgis-2.14.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -51,7 +51,7 @@ RDEPEND="
python? (
dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
diff --git a/sci-geosciences/qgis/qgis-2.18.2-r1.ebuild b/sci-geosciences/qgis/qgis-2.18.2-r1.ebuild
index dec2e4df2e0f..9e687a8dcd27 100644
--- a/sci-geosciences/qgis/qgis-2.18.2-r1.ebuild
+++ b/sci-geosciences/qgis/qgis-2.18.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -52,7 +52,7 @@ RDEPEND="
python? (
dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
diff --git a/sci-geosciences/qgis/qgis-2.18.2-r2.ebuild b/sci-geosciences/qgis/qgis-2.18.2-r2.ebuild
index 2dddf93f3f5e..7dc1b69a3e25 100644
--- a/sci-geosciences/qgis/qgis-2.18.2-r2.ebuild
+++ b/sci-geosciences/qgis/qgis-2.18.2-r2.ebuild
@@ -52,7 +52,7 @@ RDEPEND="
python? (
dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
<dev-python/sip-4.19:=[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
diff --git a/sci-geosciences/qgis/qgis-2.18.2-r3.ebuild b/sci-geosciences/qgis/qgis-2.18.2-r3.ebuild
index 084b5553bba8..96193db8c9dd 100644
--- a/sci-geosciences/qgis/qgis-2.18.2-r3.ebuild
+++ b/sci-geosciences/qgis/qgis-2.18.2-r3.ebuild
@@ -53,7 +53,7 @@ RDEPEND="
python? (
dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
<dev-python/sip-4.19:=[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
diff --git a/sci-geosciences/qgis/qgis-2.18.3.ebuild b/sci-geosciences/qgis/qgis-2.18.3.ebuild
index b631f4b20f11..6afa49f4292c 100644
--- a/sci-geosciences/qgis/qgis-2.18.3.ebuild
+++ b/sci-geosciences/qgis/qgis-2.18.3.ebuild
@@ -61,7 +61,7 @@ COMMON_DEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
<dev-python/sip-4.19:=[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]