summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-15 04:16:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-15 04:39:25 +0200
commit94d9f3f394e9b14f74f6e9cda37447fa1446e061 (patch)
treebb9d40133f7c8025fab3faf0d344afa7aed37e71
parentdev-python/sphinxcontrib-serializinghtml: Bump to 1.1.8 (diff)
downloadgentoo-94d9f3f394e9b14f74f6e9cda37447fa1446e061.tar.gz
gentoo-94d9f3f394e9b14f74f6e9cda37447fa1446e061.tar.bz2
gentoo-94d9f3f394e9b14f74f6e9cda37447fa1446e061.zip
dev-python/sphinxcontrib-qthelp: Bump to 1.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
index 654bebda84ad..a26cf261a6d5 100644
--- a/dev-python/sphinxcontrib-qthelp/Manifest
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-qthelp-1.0.3.tar.gz 21658 BLAKE2B 7a82e8941d49836cf3e64aabe05ba65b34596f7ba0287b4dc7ed2c5940f6944d1853790d1d52637b03d934effbba8fc5094089e2924322cf1b373432c60bce6a SHA512 29f77e4b3f1a4868c2a34dbd853415e5d813f482cd23b982aeed42d53acba09b896d77ba930c34cce8af043bb7d64a19acff610430e942038d95a410b6e0b5fa
DIST sphinxcontrib_qthelp-1.0.5.tar.gz 16505 BLAKE2B fb72e9a1149a021a2ed73fb67380c7a715d687742f7713d1471c7b372848f85f1c075a4f2a16683d1e738e885d680a77b506100eb3a687e370b460c52ed82402 SHA512 b4de2913a6f4d5d29cc69bd4e43f40761fcc9cf0c68a4f0102fe1750e319c9ed9d28962f6eabb4812c01f092428dcd5831c14f01350bf3de7b532f6ebed7a326
+DIST sphinxcontrib_qthelp-1.0.6.tar.gz 16555 BLAKE2B 7fabbd35f5ccf5895f16fd17e335268445e32ee0cb8c596c68e537169d4ad0aa3dc102ee2474c136c62676cff6ab639288c5fff4892d78a257a85a7ab963fe9d SHA512 783cd757bf262ce63f54019a5ccf1d7e6fb59e8fde07e7cfa0610bf0cd49e6e51cada9c35bf11cc5ff351904da6a69569be1d4db58d450a96375aee7bf1f34ff
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild
new file mode 100644
index 000000000000..cc2082f368ba
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-qthelp/
+ https://pypi.org/project/sphinxcontrib-qthelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest