summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:38:45 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:56 +0100
commit957bf1d08184717dd056ef1588f53c7bddea5b48 (patch)
tree9d246942d09b2ff9b49521d65da866be59845d0c
parentgnustep-base/mknfonts: respect ${PKG_CONFIG}, depend on pkgconfig (diff)
downloadgentoo-957bf1d08184717dd056ef1588f53c7bddea5b48.tar.gz
gentoo-957bf1d08184717dd056ef1588f53c7bddea5b48.tar.bz2
gentoo-957bf1d08184717dd056ef1588f53c7bddea5b48.zip
media-gfx/xzgv: port to EAPI 7, respect ${PKG_CONFIG}
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch12
-rw-r--r--media-gfx/xzgv/xzgv-0.9.1.ebuild20
2 files changed, 18 insertions, 14 deletions
diff --git a/media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch b/media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch
index 8b3c671dbf8a..344f283d7663 100644
--- a/media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch
+++ b/media-gfx/xzgv/files/xzgv-0.9-asneeded-and-cflags.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/500692
---- config.mk
-+++ config.mk
+--- a/config.mk
++++ b/config.mk
@@ -7,7 +7,7 @@
# This is likely to be what you'll want for most systems:
#
@@ -11,16 +11,16 @@ http://bugs.gentoo.org/500692
# Set the awk interpreter to use for a script used while compiling.
# (This should be a `new' awk, such as gawk or mawk.)
---- src/Makefile
-+++ src/Makefile
+--- a/src/Makefile
++++ b/src/Makefile
@@ -9,8 +9,8 @@
# This gets definitions for CC, CFLAGS, BINDIR etc.
include ../config.mk
-CFLAGS+=`pkg-config --cflags gtk+-2.0` `pkg-config --cflags gdk-pixbuf-2.0`
-LDFLAGS+=`pkg-config --libs gtk+-2.0` `pkg-config --libs gdk-pixbuf-2.0`
-+CFLAGS+=`pkg-config --cflags gtk+-2.0` `pkg-config --cflags gdk-pixbuf-2.0` `pkg-config --cflags x11`
-+LIBS=`pkg-config --libs gtk+-2.0` `pkg-config --libs gdk-pixbuf-2.0` `pkg-config --libs x11` -lm
++CFLAGS+=`${PKG_CONFIG} --cflags gtk+-2.0` `${PKG_CONFIG} --cflags gdk-pixbuf-2.0` `${PKG_CONFIG} --cflags x11`
++LIBS=`${PKG_CONFIG} --libs gtk+-2.0` `${PKG_CONFIG} --libs gdk-pixbuf-2.0` `${PKG_CONFIG} --libs x11` -lm
all: xzgv
diff --git a/media-gfx/xzgv/xzgv-0.9.1.ebuild b/media-gfx/xzgv/xzgv-0.9.1.ebuild
index f3ecce214fce..912f0a805616 100644
--- a/media-gfx/xzgv/xzgv-0.9.1.ebuild
+++ b/media-gfx/xzgv/xzgv-0.9.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit epatch toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Fast and simple GTK+ image viewer"
HOMEPAGE="https://sourceforge.net/projects/xzgv"
@@ -11,18 +12,21 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
-IUSE=""
RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-apps/texinfo
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
-src_prepare() {
- epatch "${FILESDIR}"/${P/.1}-asneeded-and-cflags.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P/.1}-asneeded-and-cflags.patch
+)
src_compile() {
+ tc-export PKG_CONFIG
+
emake CC="$(tc-getCC)"
emake -C doc CC="$(tc-getCC)"
}