summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-28 09:55:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-30 17:19:08 +0100
commit95ba46e4f667b31003463109f424cb9995d75435 (patch)
tree0c18e75d6be8900deebfca9c84520633f542fe3d
parentprofiles/use.desc: Add global USE=modules-compress (diff)
downloadgentoo-95ba46e4f667b31003463109f424cb9995d75435.tar.gz
gentoo-95ba46e4f667b31003463109f424cb9995d75435.tar.bz2
gentoo-95ba46e4f667b31003463109f424cb9995d75435.zip
kernel-{build,install}.eclass: Rename flag to modules-compress
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--eclass/kernel-build.eclass4
-rw-r--r--eclass/kernel-install.eclass6
2 files changed, 5 insertions, 5 deletions
diff --git a/eclass/kernel-build.eclass b/eclass/kernel-build.eclass
index 29ee9f86e7e2..28f111ec998b 100644
--- a/eclass/kernel-build.eclass
+++ b/eclass/kernel-build.eclass
@@ -284,7 +284,7 @@ kernel-build_src_install() {
dostrip -x /lib/modules
local compress=()
- if [[ ${KERNEL_IUSE_GENERIC_UKI} ]] && ! use module-compress; then
+ if [[ ${KERNEL_IUSE_GENERIC_UKI} ]] && ! use modules-compress; then
compress+=(
# force installing uncompressed modules even if compression
# is enabled via config
@@ -560,7 +560,7 @@ kernel-build_merge_configs() {
# Only semi-related but let's use that to avoid changing stable ebuilds.
if [[ ${KERNEL_IUSE_GENERIC_UKI} ]]; then
- # NB: we enable this even with USE=-module-compress, in order
+ # NB: we enable this even with USE=-modules-compress, in order
# to support both uncompressed and compressed modules in prebuilt
# kernels
cat <<-EOF > "${WORKDIR}/module-compress.config" || die
diff --git a/eclass/kernel-install.eclass b/eclass/kernel-install.eclass
index 8c4d5c14fc03..af4f5d839b0e 100644
--- a/eclass/kernel-install.eclass
+++ b/eclass/kernel-install.eclass
@@ -79,7 +79,7 @@ _IDEPEND_BASE="
LICENSE="GPL-2"
if [[ ${KERNEL_IUSE_GENERIC_UKI} ]]; then
- IUSE+=" generic-uki module-compress"
+ IUSE+=" generic-uki modules-compress"
# https://github.com/AndrewAmmerlaan/dist-kernel-log-to-licenses
# This script can help with generating the array below, keep in mind
# that it is not a fully automatic solution, i.e. use flags will
@@ -762,11 +762,11 @@ kernel-install_pkg_config() {
# @FUNCTION: kernel-install_compress_modules
# @DESCRIPTION:
-# Compress modules installed in ED, if USE=module-compress is enabled.
+# Compress modules installed in ED, if USE=modules-compress is enabled.
kernel-install_compress_modules() {
debug-print-function ${FUNCNAME} "${@}"
- if use module-compress; then
+ if use modules-compress; then
einfo "Compressing kernel modules ..."
# taken from scripts/Makefile.modinst
find "${ED}/lib" -name '*.ko' -exec \