summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-15 10:33:17 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-15 10:35:28 +0100
commit96af924862032f6a2da72dcc5f3bf6b0ce3d3373 (patch)
treee98aea670f2bfb44c3e30196e39ec3bfa8e1d2d7
parentdev-python/mockldap: Remove 0.2.6 (diff)
downloadgentoo-96af924862032f6a2da72dcc5f3bf6b0ce3d3373.tar.gz
gentoo-96af924862032f6a2da72dcc5f3bf6b0ce3d3373.tar.bz2
gentoo-96af924862032f6a2da72dcc5f3bf6b0ce3d3373.zip
sys-auth/ssh-ldap-pubkey: Remove old revisions
Remove old revisions as part of dev-python/pyldap cleanup. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild71
-rw-r--r--sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0.ebuild66
2 files changed, 0 insertions, 137 deletions
diff --git a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild
deleted file mode 100644
index fb9c5709b98d..000000000000
--- a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="Utility to manage SSH public keys stored in LDAP"
-HOMEPAGE="https://github.com/jirutka/ssh-ldap-pubkey"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/jirutka/${PN}/${PN}.git"
-
- inherit git-r3
-else
- SRC_URI="https://github.com/jirutka/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="schema test"
-RESTRICT="!test? ( test )"
-
-MY_CDEPEND="
- dev-python/docopt[${PYTHON_USEDEP}]
- >=dev-python/python-ldap-3.0[${PYTHON_USEDEP}]
- virtual/logger"
-
-DEPEND="
- ${MY_CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-describe[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-# We need to block previous net-misc/openssh packages
-# to avoid file collision on "/etc/openldap/schema/openssh-lpk.schema"
-RDEPEND="${MY_CDEPEND}
- schema? ( !net-misc/openssh[ldap] )"
-
-DOCS=( README.md CHANGELOG.adoc )
-
-src_prepare() {
- sed -i -e 's/pyldap/python-ldap >= 3.0/' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use schema; then
- insinto /etc/openldap/schema
- doins etc/openssh-lpk.schema
- fi
-
- local MY_DOCDIR="/usr/share/doc/${PF}/examples"
- insinto "${MY_DOCDIR}"
- doins etc/ldap.conf
-
- # We don't want to compress this small file to allow user
- # to diff configuration against upstream's default
- docompress -x "${MY_DOCDIR}"
-}
diff --git a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0.ebuild b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0.ebuild
deleted file mode 100644
index 7d04c5fd3009..000000000000
--- a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="Utility to manage SSH public keys stored in LDAP"
-HOMEPAGE="https://github.com/jirutka/ssh-ldap-pubkey"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/jirutka/${PN}/${PN}.git"
-
- inherit git-r3
-else
- SRC_URI="https://github.com/jirutka/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~ppc64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="schema test"
-RESTRICT="!test? ( test )"
-
-MY_CDEPEND="
- dev-python/docopt[${PYTHON_USEDEP}]
- dev-python/pyldap[${PYTHON_USEDEP}]
- virtual/logger"
-
-DEPEND="
- ${MY_CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-describe[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-# We need to block previous net-misc/openssh packages
-# to avoid file collision on "/etc/openldap/schema/openssh-lpk.schema"
-RDEPEND="${MY_CDEPEND}
- schema? ( !net-misc/openssh[ldap] )"
-
-DOCS=( README.md CHANGELOG.adoc )
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use schema; then
- insinto /etc/openldap/schema
- doins etc/openssh-lpk.schema
- fi
-
- local MY_DOCDIR="/usr/share/doc/${PF}/examples"
- insinto "${MY_DOCDIR}"
- doins etc/ldap.conf
-
- # We don't want to compress this small file to allow user
- # to diff configuration against upstream's default
- docompress -x "${MY_DOCDIR}"
-}