summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-08-02 21:50:24 +1200
committerKent Fredric <kentnl@gentoo.org>2016-08-02 21:52:04 +1200
commit9716505b5f5519e31b1f4629aafda292530ca830 (patch)
tree3aa82579094025233b2c75393ef8d0895368adf7
parentsys-auth/munge: Prefix support. (diff)
downloadgentoo-9716505b5f5519e31b1f4629aafda292530ca830.tar.gz
gentoo-9716505b5f5519e31b1f4629aafda292530ca830.tar.bz2
gentoo-9716505b5f5519e31b1f4629aafda292530ca830.zip
dev-perl/Test-Tester: Fix ~ vs * dependency on virtual/perl-Test-Simple
~ rule was too narrow and didn't allow for _p522, where it should. However, anyone who installs dev-perl/Test-Tester on ~arch should actually skip installing this package, and instead blanket-uninstall dev-perl/Test-Tester in favour of >=virtual/perl-Test-Simple-1.1.14 Hence, einfo messages recommending its removal, and we're going to kill this package as soon as humanly possible, it just requires Test-Simple 1.1.14 and perl-5.22 stabilized to do so. Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
-rw-r--r--dev-perl/Test-Tester/Test-Tester-0.114.0-r1.ebuild (renamed from dev-perl/Test-Tester/Test-Tester-0.114.0.ebuild)19
1 files changed, 17 insertions, 2 deletions
diff --git a/dev-perl/Test-Tester/Test-Tester-0.114.0.ebuild b/dev-perl/Test-Tester/Test-Tester-0.114.0-r1.ebuild
index d8e82cbbb6a6..d59bde092a57 100644
--- a/dev-perl/Test-Tester/Test-Tester-0.114.0.ebuild
+++ b/dev-perl/Test-Tester/Test-Tester-0.114.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,4 +14,19 @@ LICENSE="GPL-2"
# this is just a dummy ebuild to help with portage dependency resolution on
# Perl 5.22 upgrade - it does not install any files
-RDEPEND="~virtual/perl-Test-Simple-1.1.14"
+RDEPEND="=virtual/perl-Test-Simple-1.1.14*"
+
+removal_message() {
+ einfo "This package is only a stub for upgrade purposes and can now be removed"
+ einfo "Equivalent modules now should be supported by either"
+ einfo " a) virtual/perl-Test-Simple installing >=perl-core/Test-Simple-1.1.14"
+ einfo " b) virtual/perl-Test-Simple installing >=dev-lang/perl-5.22.0"
+}
+
+pkg_postinst() {
+ removal_message
+}
+
+pkg_info() {
+ removal_message
+}