summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-02 07:26:35 +0000
committerSam James <sam@gentoo.org>2024-01-02 07:26:57 +0000
commit989bc6ca15f19d62f0271dff3c276242ddae63d4 (patch)
tree9485d8c15d49c377ab4cf375d13cecc8190c07b6
parentdev-ruby/sequel: drop 5.71.0, 5.72.0, 5.73.0 (diff)
downloadgentoo-989bc6ca15f19d62f0271dff3c276242ddae63d4.tar.gz
gentoo-989bc6ca15f19d62f0271dff3c276242ddae63d4.tar.bz2
gentoo-989bc6ca15f19d62f0271dff3c276242ddae63d4.zip
app-shells/fzf: add 0.45.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.45.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 1624cae2838f..4bbdceb74a49 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -4,3 +4,5 @@ DIST fzf-0.43.0-deps.tar.xz 16866976 BLAKE2B 98d0412e7035f244d14c33e76a11d788a30
DIST fzf-0.43.0.tar.gz 247080 BLAKE2B 63a0c446e93c753c7699e0575dfa0090d4f74d06e57e7d1c94f244638c21afd268c9da1b6a4b5dc85faa68e227f3c2c6755fa7af562d7f1ca5eec60e6e9141c1 SHA512 84e01d2f852e0d90b2a30342f7ad9a30e4e287688f6063efc2a0f602eab5ec064819efecd2041f46869bb1956b3d3eb50e98084deeaa26272c3bbafd000648f7
DIST fzf-0.44.0-deps.tar.xz 16844060 BLAKE2B 33f85423868719cf86664a0fd7691c42c6ed94d0c5f83f9a296b430335cf142dd6d1f48b516bb9eceba98ca9e5ead9a99794279dcb79798c91e34db694b22c76 SHA512 e1824added348c7aa851c438384ebf2d585d44e634474144e5f444a41562b361574ecccff54c07ca046941ced8adec0596e52d540fe7d7ac786c85eccf683bfd
DIST fzf-0.44.0.tar.gz 250927 BLAKE2B 3689d8843a4b008abc7b77e7b0fe7b681891c5f397ac7460c26ea303e04e7bb7dcb03af4012cfea12dd8c771c012a656e8bc65684941d66ebbb6533796d09ec2 SHA512 62084284a2329250e87f107900ffaddf94043274b1d9ede1dacdeed2e8ef87722c80708addd7907c35035e742645f5168776e5f0295d5695e9512acdbb43936c
+DIST fzf-0.45.0-deps.tar.xz 21803876 BLAKE2B 3a32d3da26a469f51c319627971b4f9efa193671fe039d617fa19cb73ff4589dfa015220d6e684af8bba9ff89eac466b825e58ccf1c8b9e3a481808aaa045bd6 SHA512 e79651d570050a6e7f398860a944010378be1f7bbdb0286ea2ab3c3f9656c6d6cc1a372099a42262d1a45e1fbd0192e6b9708ff645058dc573f6d46b9c333145
+DIST fzf-0.45.0.tar.gz 255930 BLAKE2B 57fdc7920eb371b68ed46fce4c786c84effb8f7937340daf12c511d55ebfef5280db22330e4ee9b8cd6571ca6a6b805b35e00870cc34db30ed9c3a35ce2b6a97 SHA512 f0671cf9764ed6f7375de41865635cfac47831eed1e22dc43cec346f26aee7b6c17510a6c96b8913b5f9595de9c1511f835a43bf00dd2ac38e6dded6e8fb7998
diff --git a/app-shells/fzf/fzf-0.45.0.ebuild b/app-shells/fzf/fzf-0.45.0.ebuild
new file mode 100644
index 000000000000..0c58b5e58bf5
--- /dev/null
+++ b/app-shells/fzf/fzf-0.45.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=20240101197348a78db5a1dac945a2dff6a4e654
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}