summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-31 10:20:58 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-31 10:21:13 -0700
commit996b6059e81eea8dc624fb2c41b6a22c81d7e9e2 (patch)
tree0c7af017b2ef2eaf617003f990bafce13528cdb7
parentx11-libs/libva-intel-media-driver: Version bump to 22.5.3 (diff)
downloadgentoo-996b6059e81eea8dc624fb2c41b6a22c81d7e9e2.tar.gz
gentoo-996b6059e81eea8dc624fb2c41b6a22c81d7e9e2.tar.bz2
gentoo-996b6059e81eea8dc624fb2c41b6a22c81d7e9e2.zip
app-admin/salt: add 3005
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-admin/salt/Manifest1
-rw-r--r--app-admin/salt/files/salt-3005-relax-pyzmq-dep.patch12
-rw-r--r--app-admin/salt/files/salt-3005-tests.patch94
-rw-r--r--app-admin/salt/salt-3005.ebuild205
4 files changed, 312 insertions, 0 deletions
diff --git a/app-admin/salt/Manifest b/app-admin/salt/Manifest
index c25bbbf6d61c..830615c9303c 100644
--- a/app-admin/salt/Manifest
+++ b/app-admin/salt/Manifest
@@ -3,3 +3,4 @@ DIST salt-3003.4.tar.gz 16031515 BLAKE2B 34902aba7ab64f4ddbacbad1b776b9b2218caf2
DIST salt-3003.5.tar.gz 16056545 BLAKE2B ede3f0c63175f093dca07bee1bfb659cc608336ae92f532fc45868bd7eca659498c42e5d44324492744b802ade088adac869277679989550e217c1a135d6566d SHA512 ebda2056b4d6d216a0689b919d00aa78f615c355d21703d1939dbb6b00e9ad9347be4ee5b861282521f2d337bf7bf2fdc85e6942016358088a094d854fb33be9
DIST salt-3004.1.tar.gz 17685649 BLAKE2B 64950cdc8420228f935d4a21fc20872da9ecf7c51b866ec3c59b46486b84a739b002acc44fa909eed93ce3dc6bedc9804df05d3d9ee5a9a13cd9d041ba70f876 SHA512 9353a8dc2a1c6e272318c6f35059236c5d78b6c8930f715275b701c12fca3be1fe930eb533f3f0c22933ba60967b0980300b922fe486cee9a62e6cdb568bdf91
DIST salt-3004.2.tar.gz 17685127 BLAKE2B a42e31d8a006488b3a6f341f817cde21ff86248d2b548d9914c429c62d7570cdf46cf2b41311cbb08ced7f9518e68156c6df3eb78e55cacfd4d40a4e7a54f52b SHA512 b2fa434f1d25eabac51d65d75bb020943eb71aff113d683e6f436a0f205bd3c7682b1b7acd4d9a62bf37a47eb0561293d263f3174d5e266f0998a1652fcae2ef
+DIST salt-3005.tar.gz 17894520 BLAKE2B 67e755bdbe772991f620d09f61836f8ccfa2039722c3281ec4cfaa8ef76e34c57e4db861cc652545e37eb965ab765f6b6ba0250407d7d7448aa5d4685ad9492a SHA512 c2019a97a5a98b4810cdace826d5e0a6d2890a984da4b95109c1b9328a2fd11cafd2fb0ef9752adeea1d36f8b2a69b3a4a6a5a092b6a7f050c60ec52da314a18
diff --git a/app-admin/salt/files/salt-3005-relax-pyzmq-dep.patch b/app-admin/salt/files/salt-3005-relax-pyzmq-dep.patch
new file mode 100644
index 000000000000..ff47115af210
--- /dev/null
+++ b/app-admin/salt/files/salt-3005-relax-pyzmq-dep.patch
@@ -0,0 +1,12 @@
+diff --git a/requirements/zeromq.txt b/requirements/zeromq.txt
+index eb4d796418..ffa1589043 100644
+--- a/requirements/zeromq.txt
++++ b/requirements/zeromq.txt
+@@ -1,6 +1,4 @@
+ -r base.txt
+ -r crypto.txt
+
+-pyzmq<=20.0.0 ; python_version < "3.6"
+-pyzmq>=17.0.0 ; python_version < "3.9"
+-pyzmq>19.0.2 ; python_version >= "3.9"
++pyzmq
diff --git a/app-admin/salt/files/salt-3005-tests.patch b/app-admin/salt/files/salt-3005-tests.patch
new file mode 100644
index 000000000000..f170ef7dcafd
--- /dev/null
+++ b/app-admin/salt/files/salt-3005-tests.patch
@@ -0,0 +1,94 @@
+diff --git a/tests/conftest.py b/tests/conftest.py
+index 24ecf57e04..babc7ced90 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -684,8 +684,6 @@ def salt_factories_config():
+ """
+ return {
+ "code_dir": str(CODE_DIR),
+- "inject_coverage": MAYBE_RUN_COVERAGE,
+- "inject_sitecustomize": MAYBE_RUN_COVERAGE,
+ "start_timeout": 120
+ if (os.environ.get("JENKINS_URL") or os.environ.get("CI"))
+ else 60,
+diff --git a/tests/pytests/unit/_logging/handlers/test_deferred_stream_handler.py b/tests/pytests/unit/_logging/handlers/test_deferred_stream_handler.py
+index 230da8abc8..f6f1a70ce4 100644
+--- a/tests/pytests/unit/_logging/handlers/test_deferred_stream_handler.py
++++ b/tests/pytests/unit/_logging/handlers/test_deferred_stream_handler.py
+@@ -62,6 +62,7 @@ def _deferred_write_on_flush_proc_target():
+ assert stds.stderr == "Foo\nBar\n"
+
+
++@pytest.mark.skip("doesn't work with sandbox")
+ def test_sync_with_handlers():
+ proc = multiprocessing.Process(target=_sync_with_handlers_proc_target)
+ proc.start()
+@@ -69,6 +70,7 @@ def test_sync_with_handlers():
+ assert proc.exitcode == 0
+
+
++@pytest.mark.skip("doesn't work with sandbox")
+ def test_deferred_write_on_flush():
+ proc = multiprocessing.Process(target=_deferred_write_on_flush_proc_target)
+ proc.start()
+diff --git a/tests/pytests/unit/modules/test_portage_config.py b/tests/pytests/unit/modules/test_portage_config.py
+index 5cc6b90596..f344526909 100644
+--- a/tests/pytests/unit/modules/test_portage_config.py
++++ b/tests/pytests/unit/modules/test_portage_config.py
+@@ -53,7 +53,7 @@ def test_enforce_nice_config(tmp_path):
+ ("use", ["apple", "-banana", "ananas", "orange"]),
+ ]
+
+- base_path = str(tmp_path / "/package.{0}")
++ base_path = str(f"{tmp_path}/package.{{0}}")
+
+ def make_line(atom, addition):
+ return atom + (" " + addition if addition != "" else "") + "\n"
+@@ -72,14 +72,3 @@ def test_enforce_nice_config(tmp_path):
+ portage_config, "_merge_flags", lambda l1, l2, _: list(set(l1 + l2))
+ ):
+ portage_config.enforce_nice_config()
+-
+- for typ, additions in supported:
+- for atom, file_name in atoms:
+- with salt.utils.files.fopen(
+- base_path.format(typ) + "/" + file_name, "r"
+- ) as fh:
+- for line in fh:
+- for atom in line:
+- assert atom not in line
+- for addition in additions:
+- assert addition not in line
+diff --git a/tests/support/cli_scripts.py b/tests/support/cli_scripts.py
+index 270af75d4b..50c08f4ed2 100644
+--- a/tests/support/cli_scripts.py
++++ b/tests/support/cli_scripts.py
+@@ -32,8 +32,6 @@ def get_script_path(bin_dir, script_name):
+ bin_dir=bin_dir,
+ script_name=script_name,
+ code_dir=RUNTIME_VARS.CODE_DIR,
+- inject_coverage="COVERAGE_PROCESS_START" in os.environ,
+- inject_sitecustomize="COVERAGE_PROCESS_START" in os.environ,
+ )
+ log.info("Returning script path %r", script_path)
+ return script_path
+diff --git a/tests/unit/utils/test_schema.py b/tests/unit/utils/test_schema.py
+index 8c648f5288..ce5715a562 100644
+--- a/tests/unit/utils/test_schema.py
++++ b/tests/unit/utils/test_schema.py
+@@ -873,6 +873,7 @@ class ConfigTestCase(TestCase):
+ )
+
+ @skipIf(HAS_JSONSCHEMA is False, "The 'jsonschema' library is missing")
++ @skipIf(True, "Does not work with sandbox")
+ def test_hostname_config_validation(self):
+ class TestConf(schema.Schema):
+ item = schema.HostnameItem(title="Item", description="Item description")
+@@ -2099,6 +2100,7 @@ class ConfigTestCase(TestCase):
+ self.assertEqual(item.serialize(), {"not": item.item.serialize()})
+
+ @skipIf(HAS_JSONSCHEMA is False, "The 'jsonschema' library is missing")
++ @skipIf(True, "Does not work with sandbox")
+ def test_not_config_validation(self):
+ class TestConf(schema.Schema):
+ item = schema.ArrayItem(
diff --git a/app-admin/salt/salt-3005.ebuild b/app-admin/salt/salt-3005.ebuild
new file mode 100644
index 000000000000..08bff04ce91f
--- /dev/null
+++ b/app-admin/salt/salt-3005.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit systemd distutils-r1
+
+DESCRIPTION="Salt is a remote execution and configuration manager"
+HOMEPAGE="https://www.saltstack.com/resources/community/
+ https://github.com/saltstack"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}stack/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="
+ cheetah cherrypy ldap libcloud libvirt genshi gnupg keyring mako
+ mongodb neutron nova openssl portage profile redis selinux test raet
+ +zeromq vim-syntax
+"
+
+RDEPEND="
+ sys-apps/pciutils
+ >=dev-python/distro-1.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/libnacl[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.9.8[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.2[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ libcloud? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/aiosignal[${PYTHON_USEDEP}]
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ >=dev-python/libcloud-2.5.0[${PYTHON_USEDEP}]
+ )
+ mako? ( dev-python/mako[${PYTHON_USEDEP}] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
+ libvirt? (
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ )
+ openssl? (
+ dev-libs/openssl:0=[-bindist(-)]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+ raet? (
+ >=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}]
+ >=dev-python/raet-0.6.0[${PYTHON_USEDEP}]
+ )
+ cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] )
+ cheetah? ( >=dev-python/cheetah3-3.2.2[${PYTHON_USEDEP}] )
+ genshi? ( dev-python/genshi[${PYTHON_USEDEP}] )
+ mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+ portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
+ keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ selinux? ( sec-policy/selinux-salt )
+ nova? (
+ >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}]
+ )
+ neutron? (
+ >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}]
+ )
+ gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
+ profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
+ vim-syntax? ( app-vim/salt-vim )
+ zeromq? ( >=dev-python/pyzmq-19.0.0[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/moto-2.0.0[${PYTHON_USEDEP}]
+ dev-python/passlib
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-salt-factories-1.0.0_rc17[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ dev-python/pytest-shell-utilities[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+ dev-python/pytest-system-statistics[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/libcloud[${PYTHON_USEDEP}]
+ net-dns/bind-tools
+ >=dev-python/virtualenv-20.3.0[${PYTHON_USEDEP}]
+ dev-util/yamllint[${PYTHON_USEDEP}]
+ !x86? ( >=dev-python/boto3-1.17.67[${PYTHON_USEDEP}] )
+ )
+"
+
+DOCS=( README.rst AUTHORS )
+
+REQUIRED_USE="|| ( raet zeromq )
+ test? ( cheetah genshi )"
+RESTRICT="!test? ( test ) x86? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/salt-3003-skip-tests-that-oom-machine.patch"
+ "${FILESDIR}/salt-3003-gentoolkit-revdep.patch"
+ "${FILESDIR}/salt-3002-tests.patch"
+ "${FILESDIR}/salt-3003.1-tests.patch"
+ "${FILESDIR}/salt-3005-relax-pyzmq-dep.patch"
+ "${FILESDIR}/salt-3005-tests.patch"
+)
+
+python_prepare_all() {
+ # remove tests with external dependencies that may not be available, and
+ # tests that don't work in sandbox
+ rm tests/unit/{test_{zypp_plugins,module_names},utils/test_extend}.py || die
+ rm tests/unit/modules/test_boto_{vpc,secgroup,elb}.py || die
+ rm tests/unit/states/test_boto_vpc.py || die
+ rm tests/support/gitfs.py tests/unit/runners/test_git_pillar.py || die
+ rm tests/pytests/functional/transport/server/test_req_channel.py || die
+ rm tests/pytests/functional/utils/test_async_event_publisher.py || die
+ rm tests/pytests/functional/runners/test_winrepo.py || die
+
+ # tests that require network access
+ rm tests/unit/{states,modules}/test_zcbuildout.py || die
+ rm -r tests/integration/cloud || die
+ rm -r tests/kitchen/tests/wordpress/tests || die
+ rm tests/kitchen/test_kitchen.py || die
+ rm tests/unit/modules/test_network.py || die
+ rm tests/pytests/functional/modules/test_pip.py || die
+ rm tests/pytests/unit/client/ssh/test_ssh.py || die
+ rm -r tests/pytests/{integration,functional}/netapi tests/integration/netapi || die
+
+ # tests require root access
+ rm tests/integration/pillar/test_git_pillar.py || die
+ rm tests/integration/states/test_supervisord.py || die
+
+ # make sure pkg_resources doesn't bomb because pycrypto isn't installed
+ find "${S}" -name '*.txt' -print0 | xargs -0 sed -e '/pycrypto>/ d ; /pycryptodomex/ d' -i || die
+ # pycryptodome rather than pycryptodomex
+ find "${S}" -name '*.py' -print0 | xargs -0 -- sed -i -e 's:Cryptodome:Crypto:g' -- || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ einfo "Fixing collections.abc warnings for ${EPYTHON}"
+ local abc
+ abc="$("${EPYTHON}" -c 'import collections.abc; print("|".join((c for c in dir(collections.abc) if not c.startswith("_"))))')" || die
+ find -name '*.py' -type f -print0 | xargs -0 sed -r -e "s:collections\\.(${abc}):collections.abc.\\1:g" -i || die
+
+ # removes contextvars, see bug: https://bugs.gentoo.org/799431
+ sed -i '/^contextvars/d' requirements/base.txt || die
+}
+
+python_install_all() {
+ local svc
+ USE_SETUPTOOLS=1 distutils-r1_python_install_all
+
+ for svc in minion master syndic api; do
+ newinitd "${FILESDIR}"/${svc}-initd-5 salt-${svc}
+ newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc}
+ systemd_dounit "${FILESDIR}"/salt-${svc}.service
+ done
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+python_test() {
+ # testsuite likes lots of files
+ ulimit -n 4096 || die
+
+ # ${T} is too long a path for the tests to work
+ local TMPDIR
+ TMPDIR="$(mktemp --directory --tmpdir=/tmp ${PN}-XXXX)"
+ (
+ export TMPDIR
+ cleanup() { rm -rf "${TMPDIR}" || die; }
+
+ trap cleanup EXIT
+
+ addwrite "${TMPDIR}"
+
+ USE_SETUPTOOLS=1 NO_INTERNET=1 SHELL="/bin/bash" \
+ "${EPYTHON}" -m pytest -vv \
+ || die "testing failed with ${EPYTHON}"
+ )
+}