summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-15 22:31:48 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-15 22:32:07 +0200
commit997da50f27cf83168aadb0f7ce1205fd4190b76a (patch)
treeb7c3f754ebd2d69e8928f32cf969ddec681f30f6
parentsys-devel/autoconf-archive: stable 2017.03.21 for ia64, bug #634274 (diff)
downloadgentoo-997da50f27cf83168aadb0f7ce1205fd4190b76a.tar.gz
gentoo-997da50f27cf83168aadb0f7ce1205fd4190b76a.tar.bz2
gentoo-997da50f27cf83168aadb0f7ce1205fd4190b76a.zip
x11-misc/rofi: Version bump.
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.4.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index c68a588a4892..63623f418611 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,2 +1,3 @@
DIST rofi-1.3.1.tar.xz 211732 SHA256 b52cf1170f5c7c38f6399ee44f23ebbd87ac349d6a34f32f5d169966765c87e8 SHA512 a96c53ad268883277c4ff0ee3267ff7fab4d4a93a982019ce19ea82771b65c32d56216d777494853bffd18481400af72ed777f88cce4b26d7d1b8980a997f6c6 WHIRLPOOL 47ca4050853888fda4ae9dc203c3d4a47284780d8d1506b12f4bb14cb947a8a7e96b3674203b518ada6b9bbd0e5718d49a42f89a2ecbdf26b3fdacce9d9fee6f
DIST rofi-1.4.1.tar.xz 337988 SHA256 90fbca9b4b4bc4eaf55a8d5115e880611137faaa44b0d929694cb40ef9face76 SHA512 3db3642819761bcfc99e7e8c6f09dde0c85d34be84541ac376ce09032a5c20aa7d64d6e12c9e21bfbee7d2db2611d24a12539548b662df6fb061d91cca1eb808 WHIRLPOOL 09bbb4d2fe1d9b046b7684636f296fcbf4c77c4ffc3bb04c54d949886b29d7c6d9632d6132677a35575671fec7e234df096f15a4d36892e8ffea5924d01335b0
+DIST rofi-1.4.2.tar.xz 339316 SHA256 1a8df8c84316ac0c2b1e9985b346875d8ae4142cbec83f9961a63c73de624984 SHA512 9f6cdde4b169c9f5471eb40cca9ce65ee2e87f541b0a9e48ce5ccc61d65930befbf152af667436a9142b36ba40c2be17c1aacc90deeff70e7f40dcaa1f9a9c8f WHIRLPOOL 00eba890897623ab2392f4c53f4e41e4c0374d755fb98d40a00efcbb35451346c8c0d96f85f36c86049117e0c83555bebe02b9c82789dbe44aaf5a605d74ac14
diff --git a/x11-misc/rofi/rofi-1.4.2.ebuild b/x11-misc/rofi/rofi-1.4.2.ebuild
new file mode 100644
index 000000000000..97565c1283c0
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+)
+
+src_prepare() {
+ if use test; then
+ sed -i -e 's|"/tmp/rofi-test.pid"|"'"$T"'/rofi-test.pid"|g' test/helper-pidfile.c || die
+ fi
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}