summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-04-05 07:22:31 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-04-05 07:22:31 +0200
commit9ad6193d595e5984c6dc751c67c9dd1d2bc34bc9 (patch)
tree4c452d021cf3bba822d49d7e8856badcc37c438f
parentmedia-sound/drumstick: bump to 2.6.0 (diff)
downloadgentoo-9ad6193d595e5984c6dc751c67c9dd1d2bc34bc9.tar.gz
gentoo-9ad6193d595e5984c6dc751c67c9dd1d2bc34bc9.tar.bz2
gentoo-9ad6193d595e5984c6dc751c67c9dd1d2bc34bc9.zip
media-sound/vmpk: bump to 0.8.7
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/vmpk/Manifest1
-rw-r--r--media-sound/vmpk/vmpk-0.8.7.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/vmpk/Manifest b/media-sound/vmpk/Manifest
index 96cbde9c9087..4f1f02d06ae0 100644
--- a/media-sound/vmpk/Manifest
+++ b/media-sound/vmpk/Manifest
@@ -1 +1,2 @@
DIST vmpk-0.8.6.tar.bz2 483376 BLAKE2B a2145394a9ad90f567e292e23bd9b7f62e26160b6375a48cea2a84818139865a65fdde172f6a8b6e42015e0ce14127c1f97558e00b56ebc288fa1e3d3bd11eab SHA512 0b77aabf1dda99c9149a5353fc9d0363469de2678e6089fc7dc13dc349587fd1b1630cf511c4d9ef384a7523b8f023e451d6c543a805dcda0bf5cf9d7a4b4277
+DIST vmpk-0.8.7.tar.bz2 483742 BLAKE2B 788c70034fcfb53edfb4c6b0faf80c06e2ae096c06819bc727359d4597cb217ca60efc9ebbbb19b223dc0d7106ddd9083abbce881f175b98203f3b6acc9b44e2 SHA512 83867aed8be8e620e18070d5eba9f5e4026b1f39ff9d7fe55e342d4a040c96e2353844296191c0efb46483254b1d2d30824894077562a165f7474d02a882cfc6
diff --git a/media-sound/vmpk/vmpk-0.8.7.ebuild b/media-sound/vmpk/vmpk-0.8.7.ebuild
new file mode 100644
index 000000000000..11fb028cd522
--- /dev/null
+++ b/media-sound/vmpk/vmpk-0.8.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Virtual MIDI Piano Keyboard"
+HOMEPAGE="https://vmpk.sourceforge.io/"
+SRC_URI="mirror://sourceforge/vmpk/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=media-sound/drumstick-2.6.0
+ x11-libs/libxcb
+ dbus? ( dev-qt/qtdbus:5 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DBUS=$(usex dbus)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/vmpk/*.html "${D}"/usr/share/doc/${PF}/html/ || die
+}