summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-13 07:06:13 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-13 08:10:22 -0500
commit9c1d344f958aa76fc55537ce46834f5aa7434c65 (patch)
tree71b0cb1fb74e6196a7eccfa12c2b2ae7933168f2
parentx11-terms/kitty: adjust go dep to match eclass (diff)
downloadgentoo-9c1d344f958aa76fc55537ce46834f5aa7434c65.tar.gz
gentoo-9c1d344f958aa76fc55537ce46834f5aa7434c65.tar.bz2
gentoo-9c1d344f958aa76fc55537ce46834f5aa7434c65.zip
app-emulation/wine-vanilla: adjust style
Not touching 8.x (except 8.0.2) given 9.0 is soon, and these will be dropped once new 9.1 development cycle starts. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild27
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild24
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild23
3 files changed, 49 insertions, 25 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
index a4d883c1152c..c0595c8ef846 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,7 +23,8 @@ fi
DESCRIPTION="Free implementation of Windows(tm) on Unix, without external patchsets"
HOMEPAGE="
https://www.winehq.org/
- https://gitlab.winehq.org/wine/wine/"
+ https://gitlab.winehq.org/wine/wine/
+"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
@@ -33,10 +34,13 @@ IUSE="
+gstreamer kerberos ldap +mingw +mono netapi nls odbc openal
opencl +opengl osmesa pcap perl pulseaudio samba scanner +sdl
selinux +ssl +truetype udev udisks +unwind usb v4l +vkd3d +vulkan
- +xcomposite xinerama"
+ +xcomposite xinerama
+"
+# bug #551124 for truetype
REQUIRED_USE="
X? ( truetype )
- crossdev-mingw? ( mingw )" # bug #551124 for truetype
+ crossdev-mingw? ( mingw )
+"
# tests are non-trivial to run, can hang easily, don't play well with
# sandbox, and several need real opengl/vulkan or network access
@@ -68,7 +72,8 @@ WINE_DLOPEN_DEPEND="
truetype? ( media-libs/freetype[${MULTILIB_USEDEP}] )
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
- vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )"
+ vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )
+"
WINE_COMMON_DEPEND="
${WINE_DLOPEN_DEPEND}
X? (
@@ -95,7 +100,8 @@ WINE_COMMON_DEPEND="
!llvm-libunwind? ( sys-libs/libunwind:=[${MULTILIB_USEDEP}] )
)
usb? ( dev-libs/libusb:1[${MULTILIB_USEDEP}] )
- vkd3d? ( >=app-emulation/vkd3d-1.2[${MULTILIB_USEDEP}] )"
+ vkd3d? ( >=app-emulation/vkd3d-1.2[${MULTILIB_USEDEP}] )
+"
RDEPEND="
${WINE_COMMON_DEPEND}
app-emulation/wine-desktop-common
@@ -114,11 +120,13 @@ RDEPEND="
)
samba? ( net-fs/samba[winbind] )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
+ udisks? ( sys-fs/udisks:2 )
+"
DEPEND="
${WINE_COMMON_DEPEND}
sys-kernel/linux-headers
- X? ( x11-base/xorg-proto )"
+ X? ( x11-base/xorg-proto )
+"
BDEPEND="
dev-lang/perl
sys-devel/binutils
@@ -126,7 +134,8 @@ BDEPEND="
sys-devel/flex
virtual/pkgconfig
mingw? ( !crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] ) )
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
IDEPEND=">=app-eselect/eselect-wine-2"
QA_CONFIG_IMPL_DECL_SKIP=(
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
index d669f1bf277a..73082cc5aa7b 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,10 +32,13 @@ IUSE="
llvm-libunwind custom-cflags +fontconfig +gecko gphoto2 +gstreamer
kerberos +mingw +mono netapi nls odbc opencl +opengl osmesa pcap
perl pulseaudio samba scanner +sdl selinux +ssl +strip +truetype
- udev udisks +unwind usb v4l +vulkan +xcomposite xinerama"
+ udev udisks +unwind usb v4l +vulkan +xcomposite xinerama
+"
+# bug #551124 for truetype
REQUIRED_USE="
X? ( truetype )
- crossdev-mingw? ( mingw )" # bug #551124 for truetype
+ crossdev-mingw? ( mingw )
+"
# tests are non-trivial to run, can hang easily, don't play well with
# sandbox, and several need real opengl/vulkan or network access
@@ -67,7 +70,8 @@ WINE_DLOPEN_DEPEND="
truetype? ( media-libs/freetype[${MULTILIB_USEDEP}] )
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
- vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )"
+ vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )
+"
WINE_COMMON_DEPEND="
${WINE_DLOPEN_DEPEND}
X? (
@@ -91,7 +95,8 @@ WINE_COMMON_DEPEND="
llvm-libunwind? ( sys-libs/llvm-libunwind[${MULTILIB_USEDEP}] )
!llvm-libunwind? ( sys-libs/libunwind:=[${MULTILIB_USEDEP}] )
)
- usb? ( dev-libs/libusb:1[${MULTILIB_USEDEP}] )"
+ usb? ( dev-libs/libusb:1[${MULTILIB_USEDEP}] )
+"
RDEPEND="
${WINE_COMMON_DEPEND}
app-emulation/wine-desktop-common
@@ -110,11 +115,13 @@ RDEPEND="
)
samba? ( net-fs/samba[winbind] )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
+ udisks? ( sys-fs/udisks:2 )
+"
DEPEND="
${WINE_COMMON_DEPEND}
sys-kernel/linux-headers
- X? ( x11-base/xorg-proto )"
+ X? ( x11-base/xorg-proto )
+"
BDEPEND="
dev-lang/perl
sys-devel/binutils
@@ -124,7 +131,8 @@ BDEPEND="
mingw? ( !crossdev-mingw? (
>=dev-util/mingw64-toolchain-10.0.0_p1-r2[${MULTILIB_USEDEP}]
) )
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
IDEPEND=">=app-eselect/eselect-wine-2"
QA_CONFIG_IMPL_DECL_SKIP=(
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 82e4101c491a..7109f7104bbe 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -23,7 +23,8 @@ fi
DESCRIPTION="Free implementation of Windows(tm) on Unix, without external patchsets"
HOMEPAGE="
https://www.winehq.org/
- https://gitlab.winehq.org/wine/wine/"
+ https://gitlab.winehq.org/wine/wine/
+"
LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
@@ -35,11 +36,12 @@ IUSE="
+truetype udev udisks +unwind usb v4l +vulkan wayland wow64
+xcomposite xinerama"
# bug #551124 for truetype
-# TODO: wow64 can be done without mingw if using clang (needs bug #912237)
+# TODO?: wow64 can be done without mingw if using clang (needs bug #912237)
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )
- wow64? ( abi_x86_64 !abi_x86_32 mingw )"
+ wow64? ( abi_x86_64 !abi_x86_32 mingw )
+"
# tests are non-trivial to run, can hang easily, don't play well with
# sandbox, and several need real opengl/vulkan or network access
@@ -71,7 +73,8 @@ WINE_DLOPEN_DEPEND="
truetype? ( media-libs/freetype[${MULTILIB_USEDEP}] )
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
- vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )"
+ vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )
+"
WINE_COMMON_DEPEND="
${WINE_DLOPEN_DEPEND}
X? (
@@ -100,7 +103,8 @@ WINE_COMMON_DEPEND="
wayland? (
dev-libs/wayland[${MULTILIB_USEDEP}]
x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
- )"
+ )
+"
RDEPEND="
${WINE_COMMON_DEPEND}
app-emulation/wine-desktop-common
@@ -122,11 +126,13 @@ RDEPEND="
)
samba? ( net-fs/samba[winbind] )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
+ udisks? ( sys-fs/udisks:2 )
+"
DEPEND="
${WINE_COMMON_DEPEND}
sys-kernel/linux-headers
- X? ( x11-base/xorg-proto )"
+ X? ( x11-base/xorg-proto )
+"
BDEPEND="
|| (
sys-devel/binutils
@@ -141,7 +147,8 @@ BDEPEND="
wow64? ( dev-util/mingw64-toolchain[abi_x86_32] )
) )
nls? ( sys-devel/gettext )
- wayland? ( dev-util/wayland-scanner )"
+ wayland? ( dev-util/wayland-scanner )
+"
IDEPEND=">=app-eselect/eselect-wine-2"
QA_CONFIG_IMPL_DECL_SKIP=(