summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 19:17:19 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 20:40:05 +0100
commit9ca1336a3f865c237f67b7ce91c4cc2a97f7ac8e (patch)
treee35984f01fbf1ceaf677bfc45cd44a602f7956e1
parentapp-text/libebook: Always build in C++14 mode (diff)
downloadgentoo-9ca1336a3f865c237f67b7ce91c4cc2a97f7ac8e.tar.gz
gentoo-9ca1336a3f865c237f67b7ce91c4cc2a97f7ac8e.tar.bz2
gentoo-9ca1336a3f865c237f67b7ce91c4cc2a97f7ac8e.zip
app-text/libmspub: Always build in C++14 mode
Closes: https://bugs.gentoo.org/619044 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--app-text/libmspub/libmspub-0.1.2.ebuild7
-rw-r--r--app-text/libmspub/libmspub-0.1.3.ebuild5
-rw-r--r--app-text/libmspub/libmspub-9999.ebuild5
3 files changed, 16 insertions, 1 deletions
diff --git a/app-text/libmspub/libmspub-0.1.2.ebuild b/app-text/libmspub/libmspub-0.1.2.ebuild
index 4cd06c1e06a3..a7a301490ef3 100644
--- a/app-text/libmspub/libmspub-0.1.2.ebuild
+++ b/app-text/libmspub/libmspub-0.1.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit flag-o-matic
+
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
@@ -38,6 +40,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619044
+ append-cxxflags -std=c++14
+
econf \
--disable-werror \
$(use_with doc docs) \
diff --git a/app-text/libmspub/libmspub-0.1.3.ebuild b/app-text/libmspub/libmspub-0.1.3.ebuild
index 221a09a70251..c627cd0bee6f 100644
--- a/app-text/libmspub/libmspub-0.1.3.ebuild
+++ b/app-text/libmspub/libmspub-0.1.3.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit flag-o-matic
+
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
@@ -38,6 +40,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619044
+ append-cxxflags -std=c++14
+
econf \
--disable-werror \
$(use_with doc docs) \
diff --git a/app-text/libmspub/libmspub-9999.ebuild b/app-text/libmspub/libmspub-9999.ebuild
index 221a09a70251..c627cd0bee6f 100644
--- a/app-text/libmspub/libmspub-9999.ebuild
+++ b/app-text/libmspub/libmspub-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit flag-o-matic
+
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
@@ -38,6 +40,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619044
+ append-cxxflags -std=c++14
+
econf \
--disable-werror \
$(use_with doc docs) \