summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-01-12 12:43:00 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-01-12 12:45:25 -0600
commit9ccd620b9620d7b59effe6e3335d91caf4572949 (patch)
tree519c43fe97e0bd8f33a72d382b4e547b265a2678
parentgnustep-apps/preview: drop 0.9 (diff)
downloadgentoo-9ccd620b9620d7b59effe6e3335d91caf4572949.tar.gz
gentoo-9ccd620b9620d7b59effe6e3335d91caf4572949.tar.bz2
gentoo-9ccd620b9620d7b59effe6e3335d91caf4572949.zip
dev-go/go-md2man: add 2.0.3
Closes: https://bugs.gentoo.org/921726 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-go/go-md2man/Manifest1
-rw-r--r--dev-go/go-md2man/go-md2man-2.0.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-go/go-md2man/Manifest b/dev-go/go-md2man/Manifest
index ac3ef5d418e9..6a3a3a63a429 100644
--- a/dev-go/go-md2man/Manifest
+++ b/dev-go/go-md2man/Manifest
@@ -1 +1,2 @@
DIST go-md2man-2.0.2.tar.gz 64353 BLAKE2B cc9ce9d14b61e600cf5179b72e08bc7e6ae5fcf31d3e00d6e5f7e5e77a26dd2b2b8a938e168e0053b2a9f9aab734d9beb02f7d95549fbf073125ad42b03cf478 SHA512 c81edfdc0b6647ef699cc908a1a7038d98da34df6d48b223b83a0699de91a7e322e70d67645acf1fc848918f4c1ea310160c7ccb75e6f97b53af7103c7aa18b3
+DIST go-md2man-2.0.3.tar.gz 64961 BLAKE2B 790fe7c247e0f934a397d7389be589c6e4d75be3cd533da13ae4e46c927604c3249e3a2f0c975320bac0f21f3040059202434f6fd4b2ea6dd50d6b772fa01842 SHA512 237e8039beea11b4efb7d0c75fb5826c17dea50057b0149b9533e72e2a5198811f9a3a5b264ea3788922d2f03b07cb57914448b2d4325d54d0f946fb42c42f40
diff --git a/dev-go/go-md2man/go-md2man-2.0.3.ebuild b/dev-go/go-md2man/go-md2man-2.0.3.ebuild
new file mode 100644
index 000000000000..84427b8c616f
--- /dev/null
+++ b/dev-go/go-md2man/go-md2man-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A utility to convert markdown to man pages"
+ SRC_URI="https://github.com/cpuguy83/go-md2man/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/cpuguy83/go-md2man"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+# restrict tests because they need network-sandbox disabled
+# bug https://bugs.gentoo.org/715028
+RESTRICT+=" test"
+
+src_compile() {
+ emake BUILD_FLAGS="-mod=vendor" build
+}
+
+src_install() {
+ "${S}"/bin/go-md2man -in go-md2man.1.md -out go-md2man.1 ||
+ die "Unable to create man page"
+ dobin bin/go-md2man
+ doman go-md2man.1
+}
+
+src_test() {
+ emake test
+}