summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-17 20:35:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-17 20:54:48 +0200
commit9cf41eca1393d53a13a6b29570cac99da5c19ae1 (patch)
treeaf5f9c7a3d8f71966e71e4765bf7829b70df958f
parentxfce-base/xfce4-power-manager: Remove old (diff)
downloadgentoo-9cf41eca1393d53a13a6b29570cac99da5c19ae1.tar.gz
gentoo-9cf41eca1393d53a13a6b29570cac99da5c19ae1.tar.bz2
gentoo-9cf41eca1393d53a13a6b29570cac99da5c19ae1.zip
dev-python/click: Bump to 8.1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-8.1.7.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index 45a3b18b3aa3..01a47bb33952 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1 +1,2 @@
DIST click-8.1.6.gh.tar.gz 341538 BLAKE2B 611619665a95be2ae590c2fdad403bc834fd43665df4418ab0fa5e55b4ea90600db8a1710e5c77bda3dc1a77e6b53393a52225730a4fe4bb874076569e4b1d96 SHA512 ae31e4b5666b7ab6638a12fd12088c5b5311a4f6913e3471aefdf2392cf47d4be6e745e09070d6f2e382fa92c4068c196e0109295d86953dd066f7619dfbd4cd
+DIST click-8.1.7.gh.tar.gz 341625 BLAKE2B 11acc52c1138945e2588019811c88c4edf492fe7de44a17e9e5b60f0ca503c22f877ff42b3384b95cf207995d8cd7c8c3c90b47be2bf2b3f4efc0d03ab883405 SHA512 a1cb115b90193d78f94ec2a6af563b089820517e6e0e4b71ea3d6c68304444d16db3597358c62e1757d9d05449996b7168a220eecde6ab4991367fdb6e74096f
diff --git a/dev-python/click/click-8.1.7.ebuild b/dev-python/click/click-8.1.7.ebuild
new file mode 100644
index 000000000000..0cf462f36528
--- /dev/null
+++ b/dev-python/click/click-8.1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://github.com/pallets/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log-cabinet \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}