summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-03-19 23:57:20 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2023-03-19 23:57:35 +0100
commit9d0cf936edc8bdaa4fc781045da056ccf5d97313 (patch)
tree3595b7d198b81be4c923fd5fb4f6bf89f3943f78
parentnet-misc/rclone: drop old. (diff)
downloadgentoo-9d0cf936edc8bdaa4fc781045da056ccf5d97313.tar.gz
gentoo-9d0cf936edc8bdaa4fc781045da056ccf5d97313.tar.bz2
gentoo-9d0cf936edc8bdaa4fc781045da056ccf5d97313.zip
net-misc/rclone: 1.62.0 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
-rw-r--r--net-misc/rclone/Manifest2
-rw-r--r--net-misc/rclone/rclone-1.62.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/rclone/Manifest b/net-misc/rclone/Manifest
index e9e4c4ba9084..5cc731ae1f27 100644
--- a/net-misc/rclone/Manifest
+++ b/net-misc/rclone/Manifest
@@ -1,2 +1,4 @@
DIST rclone-1.61.1-deps.tar.xz 286458984 BLAKE2B 5129b10d67c0b8dbc03d5f3250667fd7836234720e6ef171a46f364cecb9f81c33dbba46077e1d48380b3c04f444495a6482111636efa81134682379e678b4cd SHA512 0502424d66a9c029b95a34a15e60567f06f9cef35a2e9fd6a459b99a4b45a0a55dc7efc6f430dc718888542d532f614e3b3fbc320ea56e4852e75de2434ef21a
DIST rclone-1.61.1.tar.gz 16112718 BLAKE2B cb68fedf03812451d9c8ded88bfc073c8177948b1e932acf99d22b23d3d11b1f52027e2afe88472ba6c88637a8e58e2955b67575ed7356b7b0900d6c7a7bb65c SHA512 739b976a4538586670b797c92f9cbd416c3589444a611926b5edd074e8249dfcff9d95e8053459aa42c4cbe90009a9ba1c3abb9be8e8718db6276fdc39386273
+DIST rclone-1.62.0-deps.tar.xz 294254004 BLAKE2B 8d41d7a784280ea82f86225283a3813db5d78c9982f019522b05d06610dfe8a84ffe282cca99814aad92759b60fde27f8340a2f34c151bdb519e94eeaff894d7 SHA512 ebb9636c2a1fac47b243f00e4b434b231d988d37650eb4add794ab1c2b3d4d66e2524c330f7d184ad45b7a9079a565745bda9c79ad7120ac7d868cc71942acb4
+DIST rclone-1.62.0.tar.gz 16170956 BLAKE2B f067252b1f06531dc969c0073eb299d5ffba4a1c89a99094cc8a3b6eb4c63866d1d28b72bac2c95323f8f644268fa802ccf43256fece46a31aaffb065f3a7a49 SHA512 3ab3bd07f1f83c19b9a9783df496c15273bd7bc192eac309683456589af8d179add8ee1cd334dbecbbae9ce8c9bfd84e905547e23c4d66452c96ca6a6d075755
diff --git a/net-misc/rclone/rclone-1.62.0.ebuild b/net-misc/rclone/rclone-1.62.0.ebuild
new file mode 100644
index 000000000000..649ec2384a36
--- /dev/null
+++ b/net-misc/rclone/rclone-1.62.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+SRC_URI="
+ https://github.com/rclone/rclone/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}-deps.tar.xz
+"
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ go build -mod=readonly . || die "compile failed"
+}
+
+src_test() {
+ # Setting CI skips unreliable tests, see fstest/testy/testy.go
+ # TestAddPlugin and TestRemovePlugin fail
+ RCLONE_CONFIG="/notfound" CI="true" go test -mod=readonly -v -run "!Test.*Plugin" ./... || die "test failed"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}