summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-02-03 14:45:19 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-02-03 14:45:19 +0100
commit9e58e3ec9463ed9636bf73f69742014e6a05941d (patch)
tree6e95cc4160b11dfdc3bd32f292f9d4699f724f4a
parentdev-python/setuptools: Add min ver to jaraco-text dep (diff)
downloadgentoo-9e58e3ec9463ed9636bf73f69742014e6a05941d.tar.gz
gentoo-9e58e3ec9463ed9636bf73f69742014e6a05941d.tar.bz2
gentoo-9e58e3ec9463ed9636bf73f69742014e6a05941d.zip
dev-ada/e3-core: porting to python3.10 and PEP517
Closes: https://bugs.gentoo.org/827054 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ada/e3-core/e3-core-22.1.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ada/e3-core/e3-core-22.1.0.ebuild b/dev-ada/e3-core/e3-core-22.1.0.ebuild
index 80324535319e..b4a08668238c 100644
--- a/dev-ada/e3-core/e3-core-22.1.0.ebuild
+++ b/dev-ada/e3-core/e3-core-22.1.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 toolchain-funcs
DESCRIPTION="Ease the development of portable automated build systems"
@@ -39,7 +40,7 @@ PATCHES=(
"${FILESDIR}"/${P}-test.patch
)
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
src_compile() {
local PLATFORM=x86_64-linux
@@ -47,3 +48,7 @@ src_compile() {
$(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
distutils-r1_src_compile
}
+
+python_test() {
+ epytest -p no:markdown
+}