summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-04 09:23:54 +0000
committerSam James <sam@gentoo.org>2023-12-04 09:23:54 +0000
commit9fcbf448dfe873f89869c2015333b46f0d3f505f (patch)
tree7b23d034b97c2d046f0e1cdb6989f1119b4a749a
parentfixed slot in 4.30 (diff)
downloadgentoo-9fcbf448dfe873f89869c2015333b46f0d3f505f.tar.gz
gentoo-9fcbf448dfe873f89869c2015333b46f0d3f505f.tar.bz2
gentoo-9fcbf448dfe873f89869c2015333b46f0d3f505f.zip
app-text/ghostscript-gpl: add 10.02.1
Closes: https://bugs.gentoo.org/919065 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/ghostscript-gpl/Manifest1
-rw-r--r--app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99.patch22
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-10.02.1.ebuild198
3 files changed, 221 insertions, 0 deletions
diff --git a/app-text/ghostscript-gpl/Manifest b/app-text/ghostscript-gpl/Manifest
index bbe8c0e50eac..e41ab7e7ba16 100644
--- a/app-text/ghostscript-gpl/Manifest
+++ b/app-text/ghostscript-gpl/Manifest
@@ -1,4 +1,5 @@
DIST ghostscript-10.01.1.tar.xz 67567268 BLAKE2B 26f14f11362c7cd6e129044b8e094ad421fc607a702e1f5d10ae03b8ebfb1e76fc094281df739d6ebfa815c6080f1b2223036268474c41d795e2a1e5fc66bab2 SHA512 d944be9e8aef68d1176d64c40db6fa86d55d0c9e30047f2147c02806ab61cfe9ac2cb00d4e5b218ff3c51cc6ed47ceffe1bac4dd9d4cc1760b7974f30c6c2735
DIST ghostscript-10.01.2.tar.xz 67571808 BLAKE2B d5bedfe058a9b982da3a5a9935617add8d963291f135e047369439eeb0b1587e697511fe4a2a9633cfb49594d3a36467d1df7904125f53c70d8161dc9825ff32 SHA512 ee20f0e12f553a3d04578e71a0d45defebc71117ce4dc2c14043985bfe7348ad7f8b2fe98fc9b4f5b935ecb32e50dc340be67d6ef58190542ec6d0f9da1de380
DIST ghostscript-10.02.0.tar.xz 67955320 BLAKE2B 4715385d6d05567d09a34d625d707507b6acd88cf6e91bae9a5867cc59871164186fef8124eaa56a2a13df8b3f18ef3f9277e6a0aea88b0e5c30a5312037a0be SHA512 c49344151063e915add55a0a842c2a645d8362a5cbca663bd07638f4bd3699a08cade37a9efe905ad5a41e014353e5e1b1268b7925e43128ad30d5b031396b71
+DIST ghostscript-10.02.1.tar.xz 68017088 BLAKE2B b491473f0b3d50121e4373e21af3d8cdf55d9ca4390b240c4cb88d0d44e707e32570a7f1f05cb656d1b65443fcd7e37f5eab404d72a20f83d8fd87370a585467 SHA512 ee0f754c1bd8a18428ad14eaa3ead80ff8b96275af5012e7a8384f1f10490da056eec9ae3cc791a7a13a24e16e54df5bccdd109c7d53a14534bbd7360a300b11
DIST ghostscript-gpl-10.0-patches.tar.xz 2980 BLAKE2B e2c20195b153bf45f374e84d91a4df1885a3696f4061340a0a2ac5f586b9723b45eade343ad0e5760e66616624b5f7dad82d62747040493d7ca40c13329b2df2 SHA512 dac26d7f75bbdc2a56891db7d607c2120717fdf8b1cd55c53ed3be09de3e0a62338585f4dac74496d634ce03ecb2212f386187e72b5e6b59debf8d07694e0c83
diff --git a/app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99.patch b/app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99.patch
new file mode 100644
index 000000000000..82677ea5418e
--- /dev/null
+++ b/app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/919065
+https://bugs.ghostscript.com/show_bug.cgi?id=707130
+https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=b7beb19ad06e
+
+From b7beb19ad06e08b889a44694ff813ed5f6c96da4 Mon Sep 17 00:00:00 2001
+From: Chris Liddell <chris.liddell@artifex.com>
+Date: Thu, 14 Sep 2023 09:01:43 +0100
+Subject: [PATCH] Bug 707130: Cast to void ** to avoid compiler warning
+
+--- a/base/fapi_ft.c
++++ b/base/fapi_ft.c
+@@ -1280,7 +1280,7 @@ gs_fapi_ft_get_scaled_font(gs_fapi_server * a_server, gs_fapi_font * a_font,
+
+ if (a_font->retrieve_tt_font != NULL) {
+ unsigned int ms;
+- code = a_font->retrieve_tt_font(a_font, &own_font_data, &ms);
++ code = a_font->retrieve_tt_font(a_font, (void **)&own_font_data, &ms);
+ if (code == 0) {
+ data_owned = false;
+ open_args.memory_base = own_font_data;
+--
+2.34.1
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-10.02.1.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-10.02.1.ebuild
new file mode 100644
index 000000000000..710214d665bd
--- /dev/null
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-10.02.1.ebuild
@@ -0,0 +1,198 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN/-gpl}
+MY_P="${MY_PN}-${PV/_}"
+PVM=$(ver_cut 1-2)
+PVM_S=$(ver_rs 1-2 "")
+
+# Use https://gitweb.gentoo.org/proj/codec/ghostscript-gpl-patches.git/ for patches
+# See 'index' branch for README
+MY_PATCHSET="ghostscript-gpl-10.0-patches.tar.xz"
+
+DESCRIPTION="Interpreter for the PostScript language and PDF"
+HOMEPAGE="https://ghostscript.com/ https://git.ghostscript.com/?p=ghostpdl.git;a=summary"
+SRC_URI="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PVM_S}/${MY_P}.tar.xz"
+if [[ -n "${MY_PATCHSET}" ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${MY_PATCHSET}"
+fi
+
+LICENSE="AGPL-3 CPL-1.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="cups dbus gtk l10n_de static-libs unicode X"
+
+LANGS="ja ko zh-CN zh-TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ app-text/libpaper:=
+ media-libs/fontconfig
+ >=media-libs/freetype-2.4.9:2=
+ >=media-libs/jbig2dec-0.19:=
+ >=media-libs/lcms-2.6:2
+ >=media-libs/libpng-1.6.2:=
+ media-libs/libjpeg-turbo:=
+ >=media-libs/openjpeg-2.1.0:2=
+ >=media-libs/tiff-4.0.1:=
+ >=sys-libs/zlib-1.2.7
+ cups? ( >=net-print/cups-1.3.8 )
+ dbus? ( sys-apps/dbus )
+ gtk? ( x11-libs/gtk+:3 )
+ unicode? ( net-dns/libidn:= )
+ X? ( x11-libs/libXt x11-libs/libXext )
+"
+BDEPEND="virtual/pkgconfig"
+# bug #844115 for newer poppler-data dep
+RDEPEND="
+ ${DEPEND}
+ >=app-text/poppler-data-0.4.11-r2
+ >=media-fonts/urw-fonts-2.4.9
+ l10n_ja? ( media-fonts/kochi-substitute )
+ l10n_ko? ( media-fonts/baekmuk-fonts )
+ l10n_zh-CN? ( media-fonts/arphicfonts )
+ l10n_zh-TW? ( media-fonts/arphicfonts )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-10.02.1-c99.patch
+)
+
+src_prepare() {
+ if [[ -n ${MY_PATCHSET} ]] ; then
+ # apply various patches, many borrowed from Fedora
+ # https://src.fedoraproject.org/rpms/ghostscript
+ # and Debian
+ # https://salsa.debian.org/printing-team/ghostscript/-/tree/debian/latest/debian/patches
+ eapply "${WORKDIR}"/${MY_PATCHSET%%.tar*}
+ fi
+
+ default
+
+ # Remove internal copies of various libraries
+ rm -r cups/libs || die
+ rm -r freetype || die
+ rm -r jbig2dec || die
+ rm -r jpeg || die
+ rm -r lcms2mt || die
+ rm -r libpng || die
+ rm -r tiff || die
+ rm -r zlib || die
+ rm -r openjpeg || die
+ # Remove internal CMaps (CMaps from poppler-data are used instead)
+ rm -r Resource/CMap || die
+
+ if ! use gtk ; then
+ sed -e "s:\$(GSSOX)::" \
+ -e "s:.*\$(GSSOX_XENAME)$::" \
+ -i base/unix-dll.mak || die "sed failed"
+ fi
+
+ # Force the include dirs to a neutral location.
+ sed -e "/^ZLIBDIR=/s:=.*:=${T}:" \
+ -i configure.ac || die
+ # Some files depend on zlib.h directly. Redirect them. #573248
+ # Also make sure to not define OPJ_STATIC to avoid linker errors due to
+ # hidden symbols (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203327#c1)
+ sed -e '/^zlib_h/s:=.*:=:' \
+ -e 's|-DOPJ_STATIC ||' \
+ -i base/lib.mak || die
+
+ # Search path fix
+ # put LDFLAGS after BINDIR, bug #383447
+ sed -e "s:\$\(gsdatadir\)/lib:@datarootdir@/ghostscript/${PV}/$(get_libdir):" \
+ -e "s:exdir=.*:exdir=@datarootdir@/doc/${PF}/examples:" \
+ -e "s:docdir=.*:docdir=@datarootdir@/doc/${PF}/html:" \
+ -e "s:GS_DOCDIR=.*:GS_DOCDIR=@datarootdir@/doc/${PF}/html:" \
+ -e 's:-L$(BINDIR):& $(LDFLAGS):g' \
+ -i Makefile.in base/*.mak || die "sed failed"
+
+ # Remove incorrect symlink, bug 590384
+ rm ijs/ltmain.sh || die
+ eautoreconf
+
+ cd ijs || die
+ eautoreconf
+}
+
+src_configure() {
+ # Unsupported upstream, bug #884841
+ filter-lto
+
+ local FONTPATH
+ for path in \
+ "${EPREFIX}"/usr/share/fonts/urw-fonts \
+ "${EPREFIX}"/usr/share/fonts/Type1 \
+ "${EPREFIX}"/usr/share/fonts
+ do
+ FONTPATH="${FONTPATH}${FONTPATH:+:}${EPREFIX}${path}"
+ done
+
+ # Do not add --enable-dynamic here, it's not supported fully upstream
+ # https://bugs.ghostscript.com/show_bug.cgi?id=705895
+ # bug #884707
+ #
+ # leptonica and tesseract are bundled but modified upstream, like in
+ # mujs/mupdf.
+ PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) econf \
+ --enable-freetype \
+ --enable-fontconfig \
+ --enable-openjpeg \
+ --disable-compile-inits \
+ --with-drivers=ALL \
+ --with-fontpath="${FONTPATH}" \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-libpaper \
+ --with-system-libtiff \
+ $(use_enable cups) \
+ $(use_enable dbus) \
+ $(use_enable gtk) \
+ $(use_with cups pdftoraster) \
+ $(use_with unicode libidn) \
+ $(use_with X x) \
+ DARWIN_LDFLAGS_SO_PREFIX="${EPREFIX}/usr/lib/"
+
+ cd "${S}/ijs" || die
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake so all
+
+ cd ijs || die
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-so install
+
+ # move gsc to gs, bug #343447
+ # gsc collides with gambit, bug #253064
+ mv -f "${ED}"/usr/bin/{gsc,gs} || die
+
+ cd "${S}/ijs" || die
+ emake DESTDIR="${D}" install
+
+ # Sometimes the upstream versioning deviates from the tarball(!)
+ # bug #844115#c32
+ local my_gs_version=$(find "${ED}"/usr/share/ghostscript/ -maxdepth 1 -mindepth 1 -type d || die)
+ my_gs_version=${my_gs_version##*/}
+
+ # Install the CMaps from poppler-data properly, bug #409361
+ dosym -r /usr/share/poppler/cMaps /usr/share/ghostscript/${my_gs_version}/Resource/CMap
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}