summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-11-22 20:51:18 -0600
committerCraig Andrews <candrews@gentoo.org>2019-01-09 14:58:30 -0500
commita0508b6bad045c67be5c8a0ce7fed393bb199c43 (patch)
treeed357bc3c4b29edaf418080f99ad62db719a62e9
parentsys-kernel/gentoo-sources: Linux patch 4.20.1 and addl patch (diff)
downloadgentoo-a0508b6bad045c67be5c8a0ce7fed393bb199c43.tar.gz
gentoo-a0508b6bad045c67be5c8a0ce7fed393bb199c43.tar.bz2
gentoo-a0508b6bad045c67be5c8a0ce7fed393bb199c43.zip
sys-auth/authenticator: 0.2.4 version bump, support Python 3.7
Introduce support for Python 3.7 and bump to the latest available version. Closes: https://bugs.gentoo.org/663162 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Oleksandr Trotsenko <oleksandr.trotsenko@gmail.com> Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--sys-auth/authenticator/Manifest1
-rw-r--r--sys-auth/authenticator/authenticator-0.2.4.ebuild70
-rw-r--r--sys-auth/authenticator/authenticator-9999.ebuild41
-rw-r--r--sys-auth/authenticator/files/authenticator-0.2.4-disable-failing-tests.patch16
-rw-r--r--sys-auth/authenticator/files/authenticator-0.2.4-support-use-of-gdlib-from-system.patch23
-rw-r--r--sys-auth/authenticator/metadata.xml3
6 files changed, 137 insertions, 17 deletions
diff --git a/sys-auth/authenticator/Manifest b/sys-auth/authenticator/Manifest
index 2029d165c909..2009e70cf695 100644
--- a/sys-auth/authenticator/Manifest
+++ b/sys-auth/authenticator/Manifest
@@ -1 +1,2 @@
DIST authenticator-0.2.1.tar.gz 147693 BLAKE2B b9f3a7fd5b3b7867120b9ed17b90cea4c07a271dc4d75a845ad539e15453a606d48e8637d44d12cecf9b91e5fb351d081c1add48c1a4a955444f39addd51b075 SHA512 aebf3ce147d5ccd404de6af52e130e9a85a3d5d86140d73026dac00219853652e7aa1e67db5838f9ac4d147021cd07b3ebfb86a1ab4b413ec3b98360097d1d6e
+DIST authenticator-0.2.4.tar.gz 142444 BLAKE2B 2df1462452d5aaead51af111359120c8a464058730129fd984dd568c709c58f6940a34b996d3b5435b78bd87b433a29735d3fd8e9629b512915720063b49b1a1 SHA512 16b942d24a1136350f78de92a287dcc6b52e9347cd0b73e8310b87c6c24b7075aebe909fe20d80532f7fa1b54d332b8b62fd2fc7d26ce15888fd47bb686520e2
diff --git a/sys-auth/authenticator/authenticator-0.2.4.ebuild b/sys-auth/authenticator/authenticator-0.2.4.ebuild
new file mode 100644
index 000000000000..f3d4d2cdf2b4
--- /dev/null
+++ b/sys-auth/authenticator/authenticator-0.2.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit gnome2-utils meson python-single-r1 virtualx xdg-utils
+
+DESCRIPTION="Two-factor authentication code generator for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/World/Authenticator"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="https://gitlab.gnome.org/World/Authenticator/-/archive/${PV}/Authenticator-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Authenticator-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="test"
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-crypt/libsecret
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/python-gnupg[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ media-libs/gd
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}
+ test? ( x11-apps/xhost )"
+PATCHES=(
+ "${FILESDIR}/${P}-disable-failing-tests.patch"
+ "${FILESDIR}/${P}-support-use-of-gdlib-from-system.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "1s:#!/usr/bin/env python3:#!${PYTHON}:" "authenticator.py.in" || die "Could not fix shebang."
+
+ rm -r "subprojects/libgd" || die "Could not remove the subproject libgd folder."
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/sys-auth/authenticator/authenticator-9999.ebuild b/sys-auth/authenticator/authenticator-9999.ebuild
index f11556202d24..5d876f945946 100644
--- a/sys-auth/authenticator/authenticator-9999.ebuild
+++ b/sys-auth/authenticator/authenticator-9999.ebuild
@@ -1,44 +1,60 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
-inherit gnome2-utils meson python-r1 virtualx xdg-utils
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit gnome2-utils meson python-single-r1 virtualx xdg-utils
DESCRIPTION="Two-factor authentication code generator for GNOME"
-HOMEPAGE="https://github.com/bilelmoussaoui/Authenticator"
+HOMEPAGE="https://gitlab.gnome.org/World/Authenticator"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
SRC_URI=""
EGIT_REPO_URI="${HOMEPAGE}"
else
- SRC_URI="https://github.com/bilelmoussaoui/Authenticator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.gnome.org/World/Authenticator/-/archive/${PV}/Authenticator-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Authenticator-${PV}"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2+"
SLOT="0"
-
-DEPEND="
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="test"
+RDEPEND="
+ ${PYTHON_DEPS}
app-crypt/libsecret
dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/python-gnupg[${PYTHON_USEDEP}]
dev-python/pyzbar[${PYTHON_USEDEP}]
- media-gfx/gnome-screenshot
+ media-libs/gd
x11-libs/gtk+:3
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? ( x11-apps/xhost )"
+
+src_prepare() {
+ default
-PATCHES=( "${FILESDIR}/disable-failing-tests.patch" )
+ sed -i -e "1s:#!/usr/bin/env python3:#!${PYTHON}:" "authenticator.py.in" || die "Could not fix shebang."
+
+ rm -r "subprojects/libgd" || die "Could not remove the subproject libgd folder."
+}
pkg_preinst() {
gnome2_icon_savelist
gnome2_schemas_savelist
}
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}
+
pkg_postinst() {
gnome2_icon_cache_update
gnome2_schemas_update
@@ -48,8 +64,3 @@ pkg_postrm() {
gnome2_icon_cache_update
gnome2_schemas_update
}
-
-src_test() {
- xdg_environment_reset
- virtx meson_src_test
-}
diff --git a/sys-auth/authenticator/files/authenticator-0.2.4-disable-failing-tests.patch b/sys-auth/authenticator/files/authenticator-0.2.4-disable-failing-tests.patch
new file mode 100644
index 000000000000..38b4b95464ad
--- /dev/null
+++ b/sys-auth/authenticator/files/authenticator-0.2.4-disable-failing-tests.patch
@@ -0,0 +1,16 @@
+diff --git a/data/meson.build b/data/meson.build
+index b646c11..884c5d0 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -50,10 +50,3 @@ endif
+
+ appstreamcli = find_program('appstream-util', required:false)
+
+-if appstreamcli.found()
+- test (
+- 'Validate appdata file',
+- appstreamcli,
+- args: ['validate-relax', join_paths(meson.current_build_dir (), meson.project_name() + '.appdata.xml')]
+- )
+-endif
+
diff --git a/sys-auth/authenticator/files/authenticator-0.2.4-support-use-of-gdlib-from-system.patch b/sys-auth/authenticator/files/authenticator-0.2.4-support-use-of-gdlib-from-system.patch
new file mode 100644
index 000000000000..ffbde3cf2f09
--- /dev/null
+++ b/sys-auth/authenticator/files/authenticator-0.2.4-support-use-of-gdlib-from-system.patch
@@ -0,0 +1,23 @@
+diff --git a/meson.build b/meson.build
+index ed9c48e..6b20bf0 100644
+--- a/meson.build
++++ b/meson.build
+@@ -35,16 +35,7 @@ SERVICES_DIR = join_paths(get_option('datadir'), 'dbus-1', 'services')
+ SEARCH_PROVIDER_DIR = join_paths(get_option('datadir'), 'gnome-shell', 'search-providers')
+ LIBEXEC_DIR = join_paths(get_option('prefix'), get_option('libexecdir'))
+
+-subproject('libgd',
+- default_options: [
+- 'with-introspection=true',
+- 'with-notification=true',
+- 'static=false',
+- 'pkgdatadir=' + DATA_DIR,
+- 'pkglibdir=' + LIB_DIR
+- ]
+-)
+-
++libgd_dep = dependency('gdlib', required : true)
+
+
+ # Configuration params
+
diff --git a/sys-auth/authenticator/metadata.xml b/sys-auth/authenticator/metadata.xml
index 3950af1a3351..e1df662ac76a 100644
--- a/sys-auth/authenticator/metadata.xml
+++ b/sys-auth/authenticator/metadata.xml
@@ -10,10 +10,9 @@
<name>Proxy Maintainers</name>
</maintainer>
<upstream>
- <remote-id type="github">bilelmoussaoui/Authenticator</remote-id>
<maintainer>
<name>Bilal Elmoussaoui</name>
</maintainer>
- <bugs-to>https://github.com/bilelmoussaoui/Authenticator/issues</bugs-to>
+ <bugs-to>https://gitlab.gnome.org/World/Authenticator/issues</bugs-to>
</upstream>
</pkgmetadata>