summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-12-06 16:23:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-12-06 16:23:22 +0000
commita1d3777d40e4887d2188b9ee3d5dc209d0774bb0 (patch)
tree61262ca8c519346bcb570891f3bc1a2e1967463d
parentdev-python/redis-py: enable testing with redis-7 (diff)
downloadgentoo-a1d3777d40e4887d2188b9ee3d5dc209d0774bb0.tar.gz
gentoo-a1d3777d40e4887d2188b9ee3d5dc209d0774bb0.tar.bz2
gentoo-a1d3777d40e4887d2188b9ee3d5dc209d0774bb0.zip
games-board/stockfish: add 15.1
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--games-board/stockfish/Manifest2
-rw-r--r--games-board/stockfish/stockfish-15.1.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index 56a3e17f5a6b..46402e3653e0 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -6,4 +6,6 @@ DIST stockfish-14.1-nn-13406b1dcbe0.nnue 47001243 BLAKE2B ef7deeeac9d4fb03e70695
DIST stockfish-14.1.tar.gz 187792 BLAKE2B 84ed9da634a1e52579d0aa1ef356cd31a350ecafc44ebc632080b1c6c2c01d7a2cab8d7ab44065abd140b74e65bdcea8e3cc0a5e5c5daca8060303798df90c6f SHA512 b45ec44ba88a22e528a9ae417135851ace75006d0295eb77ab92dd1dc08f3c445a50047b1f2a4a7ab73773b2ce07bd98b601e40c6f75a63586c565cec5e33039
DIST stockfish-14.tar.gz 183879 BLAKE2B fd2fbcd37f90baf6b81432ebee7aa5b949c05253e04ec361fa502687de597e90aa6c85a90a5fd1baea52da423264d8e14853303564c3bc6f37bc98de890c5d3c SHA512 90025c0559d09f950732c051362711bed7f22e5495daeadf1ac8d7b1be9ede7e9aff80ca8755fccd95bdb48e2b2ea4b4355e02cd9112ac8e5eec457774289f34
DIST stockfish-15-nn-6877cd24400e.nnue 47001499 BLAKE2B 12d9c250e7fc920aa1c575bdfa280ee648419307d7bb30dbda0e52a7a4b92a15063fba9a00e04c4201602d8778e181f8fff73a2f5a2963f197fb30020fdf78a0 SHA512 456961b01c7b7a852ac23eb9de8aca65204d5d0566868c998eb8918abd9c9eef7f7fb08ac08a7750eaede451859f93a15e92e1a14ecc269268dadb9a7b0eb135
+DIST stockfish-15.1-nn-ad9b42354671.nnue 47001499 BLAKE2B ae4caa4c7c68941fe57b03fe6c8df996dad9138e7a53caad6f08e3c8ce924c9445ecfba9f8ff3091380d4d7b0b932cff654ded7758b3abcec934cd322bf73418 SHA512 25114b2ada67cf1dd8a0a5ff78eb3b48e8406fb3e3851753d1293acf2512878856fac6c171e65b9d186e639482fd34e2b80553a1331ed73c7d40f85460a46d42
+DIST stockfish-15.1.tar.gz 193408 BLAKE2B 53f90d1ec35a96e804dc572ccc53f94b7d16686e02fb1c490f22129c313d74f39c3beeadf896016a0e0bdf9fd01bfec2f78efcaa1261869fbb599e45f8549a4b SHA512 86c0e7cdaf84b70078ab1c7db89e710ea20876952cfa726507e50d739aadcdf892bb1545bbc5fe1bf861bfbcd829e6414ee54dd9020763db9fd43617b7431532
DIST stockfish-15.tar.gz 189578 BLAKE2B 49af86be2d926ad51021edc119fee260d54fbb37d22d9e0883c382a60d6d0f742b7eee5df296b1dc85552e24269e97c172df70e0a894b328e5bfa92d0614d608 SHA512 d79f713654d5ff0b7f158394c887dce015ef613242e52ef55575c024255da6f6a6bdfe974ff1037599fc99ddfdc2774e37bbc6b8fc88ed0df59590f820a27ffa
diff --git a/games-board/stockfish/stockfish-15.1.ebuild b/games-board/stockfish/stockfish-15.1.ebuild
new file mode 100644
index 000000000000..41f4912b4c4e
--- /dev/null
+++ b/games-board/stockfish/stockfish-15.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="https://stockfishchess.org/"
+
+NNUE_FILE="nn-ad9b42354671.nnue"
+
+SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.tar.gz -> ${P}.tar.gz
+ https://tests.stockfishchess.org/api/nn/${NNUE_FILE} -> ${P}-${NNUE_FILE}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip app-arch/zip )"
+RDEPEND=""
+
+S="${WORKDIR}/Stockfish-sf_${PV}/src"
+
+src_prepare() {
+ default
+
+ # remove config sanity check that doesn't like our COMPILER settings
+ sed -i -e 's/ config-sanity//g' Makefile || die
+
+ cp "${DISTDIR}"/${P}-${NNUE_FILE} ${NNUE_FILE} || die "copying the nnue file failed"
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
+ || die 'failed to disable stripping in the Makefile'
+}
+
+src_compile() {
+ local my_arch
+
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ # other architectures
+ use cpu_flags_arm_v7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ # There's a nice hack in the Makefile that overrides the value of CXX with
+ # COMPILER to support Travis CI and we abuse it to make sure that we
+ # build with our compiler of choice.
+ emake profile-build ARCH="${my_arch}" \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc ../AUTHORS ../README.md
+}