summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-19 03:25:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-19 03:47:18 -0400
commita216e204f56515a2cccadd49fb8d83d1ce34175f (patch)
tree615cd5911f70bf29ee43d0f735100c9aece96848
parentdev-qt/qtshadertools: drop 6.6.2, 6.6.3 (diff)
downloadgentoo-a216e204f56515a2cccadd49fb8d83d1ce34175f.tar.gz
gentoo-a216e204f56515a2cccadd49fb8d83d1ce34175f.tar.bz2
gentoo-a216e204f56515a2cccadd49fb8d83d1ce34175f.zip
dev-qt/qtspeech: drop 6.6.2, 6.6.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtspeech/Manifest2
-rw-r--r--dev-qt/qtspeech/qtspeech-6.6.2.ebuild47
-rw-r--r--dev-qt/qtspeech/qtspeech-6.6.3.ebuild47
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index 612cec3d0bf3..55bb3673d17f 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -1,5 +1,3 @@
DIST qtspeech-5.15.13-gentoo-kde-1.tar.xz 1048 BLAKE2B 93b16166dd8fd83eb9d7ce84cd3fff2dd330cc4060327e107b12a084aa47b7dc2d237bbf0852d207d2b4fbe9a5688d0236ebc5e7c1e6a42da84fd92fbd912050 SHA512 8eb6b865663b9fb837e88f859c1f407c4fab5d0976630e29bb0c3f2e2d01f225f3a614cba6c20495c56429d37427c75e314194d0c74c69296ab3e5df128290c6
DIST qtspeech-everywhere-opensource-src-5.15.13.tar.xz 104612 BLAKE2B 3c35098f0d4f4b4f804808f3d11abc0c0d189e3883cb1d15ea9b350948e061125299df1207ad44ed7af207c417980b0360ab6b44733efbbe7e5bdac6fe2402b5 SHA512 43b97ddc333d1c4a9715b1c306ced0506eb8faf69f1d22500b74e509d33b5a5cb9d0c166b9211a32a78eaba57925195d8ba0c39c8ae6a15551f841426294c75f
-DIST qtspeech-everywhere-src-6.6.2.tar.xz 262008 BLAKE2B 6d9ae5b42f96fa02a15ac82e9e1c6a378c3b0ceccd278af9ef99346ad79a256e41d1d2ae10cfef75f311bdfad457271357b09fd067ddc902bff3e4ee31eda12e SHA512 e43793931b81bb86cc074a2153ec0160991c86bc255ea1b11e5b4a272b8d067fcfc6788261d4b2f6f7630eadbcab7be23249b980d2792cb9a109137af614601e
-DIST qtspeech-everywhere-src-6.6.3.tar.xz 261976 BLAKE2B 839adf366d268f2872b321d16546fc953d2e3fa6724f76061fb44674d06a0dba949f171d67f528707d071a7b94f0097f4d6e0fa25ca902572477476d3f4872fc SHA512 4a43e1895ae477f6b6890a36ba2da365420e7778dece26535642ead39aab39c0c10d3be1c78a5b823eaddc646bdb60c5bd16bf3ac02f279832bc9724cfedc5d2
DIST qtspeech-everywhere-src-6.7.0.tar.xz 261732 BLAKE2B a7e99c3c9efdaa7aa5d44537b9aaaed87af0607daa6b6ab21d602594081f5bcc5ead4da9eebbee15a7cc735a36e80cfa312452f2cdfa5ce4136bd0c06797eba2 SHA512 10d086633da8cc478619023baa4d2495bb394aa30e7ba7141b0e698ade5a4a723f5643a5df64e9920b90251e89722598b7d5b720d7b8d3a04449e94fd5984f82
diff --git a/dev-qt/qtspeech/qtspeech-6.6.2.ebuild b/dev-qt/qtspeech/qtspeech-6.6.2.ebuild
deleted file mode 100644
index 0a07541315c2..000000000000
--- a/dev-qt/qtspeech/qtspeech-6.6.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Text-to-speech library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm64 ~loong"
-fi
-
-IUSE="flite qml +speechd"
-# can build with neither, but then it is just mock tts and may be confusing
-REQUIRED_USE="|| ( flite speechd )"
-
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6
- ~dev-qt/qtmultimedia-${PV}:6
- flite? ( app-accessibility/flite )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
- speechd? ( app-accessibility/speech-dispatcher )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Qml)
- $(qt_feature flite)
- $(qt_feature speechd)
-
- # flite_alsa was likely to work around old issues in flite, it does
- # nothing but add -lasound (no code change, and is unneeded)
- -DQT_FEATURE_flite_alsa=OFF
- )
-
- qt6-build_src_configure
-}
diff --git a/dev-qt/qtspeech/qtspeech-6.6.3.ebuild b/dev-qt/qtspeech/qtspeech-6.6.3.ebuild
deleted file mode 100644
index 5491997f2898..000000000000
--- a/dev-qt/qtspeech/qtspeech-6.6.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Text-to-speech library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm arm64 ~loong ~riscv ~x86"
-fi
-
-IUSE="flite qml +speechd"
-# can build with neither, but then it is just mock tts and may be confusing
-REQUIRED_USE="|| ( flite speechd )"
-
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6
- ~dev-qt/qtmultimedia-${PV}:6
- flite? ( app-accessibility/flite )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
- speechd? ( app-accessibility/speech-dispatcher )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Qml)
- $(qt_feature flite)
- $(qt_feature speechd)
-
- # flite_alsa was likely to work around old issues in flite, it does
- # nothing but add -lasound (no code change, and is unneeded)
- -DQT_FEATURE_flite_alsa=OFF
- )
-
- qt6-build_src_configure
-}