summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-24 18:03:30 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-24 21:13:37 +0100
commita22e2637b4134b557ca4d74a275011238c046f5a (patch)
tree4af2879b7f056d74176fb4eea8fb42a6ae9adf26
parentdev-ros/hector_nav_msgs: treeclean (diff)
downloadgentoo-a22e2637b4134b557ca4d74a275011238c046f5a.tar.gz
gentoo-a22e2637b4134b557ca4d74a275011238c046f5a.tar.bz2
gentoo-a22e2637b4134b557ca4d74a275011238c046f5a.zip
dev-ros/hector_pose_estimation: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-ros/hector_pose_estimation/Manifest2
-rw-r--r--dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch19
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild30
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.4.0.ebuild29
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild29
-rw-r--r--dev-ros/hector_pose_estimation/metadata.xml11
6 files changed, 0 insertions, 120 deletions
diff --git a/dev-ros/hector_pose_estimation/Manifest b/dev-ros/hector_pose_estimation/Manifest
deleted file mode 100644
index 6730c5b1b0d6..000000000000
--- a/dev-ros/hector_pose_estimation/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST hector_localization-0.3.0.tar.gz 73656 BLAKE2B 8e895c760974f8707eb174b3b385f03f07f93f89b470d88140f1134a3cb9fb8e67e65a86484b702dbaed09e4d614f4c6759f1e08b536385f86ec15dc3db6a644 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df
-DIST hector_localization-0.4.0.tar.gz 75100 BLAKE2B afb6acb1444299c7ca47f25da7d7ad83a2363c98a6b1ed21756cdd5cf63e758b7e4e9d7ea806c7c748dc5e3606bafbe62df612a42597e86ec556696211dc8af9 SHA512 18fc8cb2f51ec978e309a627f12b896aff984fdbe2f2038c47369bd44479b3c739fad586b325c6962bb17c49e46eb7568f8af5af085fbc87749ddb2616ad34c3
diff --git a/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch b/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
deleted file mode 100644
index 59349bbfe02f..000000000000
--- a/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-From 6743fbe859981c2b52a2ab413175d7d2eaf33b47 Mon Sep 17 00:00:00 2001
-From: Mikael Arguedas <mikael@osrfoundation.org>
-Date: Fri, 27 Oct 2017 15:08:45 -0700
-Subject: [PATCH] update to use non deprecated pluginlib macro
-
----
- hector_pose_estimation/src/pose_estimation_nodelet.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/hector_pose_estimation/src/pose_estimation_nodelet.cpp b/hector_pose_estimation/src/pose_estimation_nodelet.cpp
-index 7da3ca6..97ba5b0 100644
---- hector_pose_estimation/src/pose_estimation_nodelet.cpp
-+++ hector_pose_estimation/src/pose_estimation_nodelet.cpp
-@@ -55,4 +55,4 @@ class PoseEstimationNodelet : public PoseEstimationNode, public nodelet::Nodelet
- } // namespace hector_pose_estimation
-
- #include <pluginlib/class_list_macros.h>
--PLUGINLIB_DECLARE_CLASS(hector_pose_estimation, PoseEstimation, hector_pose_estimation::PoseEstimationNodelet, nodelet::Nodelet)
-+PLUGINLIB_EXPORT_CLASS(hector_pose_estimation::PoseEstimationNodelet, nodelet::Nodelet)
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
deleted file mode 100644
index 783aaeb2225c..000000000000
--- a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/hector_pose_estimation_core
- dev-ros/nodelet
- dev-ros/tf
- dev-ros/message_filters
- dev-libs/boost:=
- dev-libs/console_bridge:=
-"
-# dev-ros/hector_timing
-DEPEND="${RDEPEND}
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-"
-PATCHES=( "${FILESDIR}"/${PN}-0.3.0-pluginlib.patch )
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.4.0.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.4.0.ebuild
deleted file mode 100644
index 3b54213a6b1a..000000000000
--- a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.4.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/hector_pose_estimation_core
- dev-ros/nodelet
- dev-ros/tf
- dev-ros/message_filters
- dev-libs/boost:=
- dev-libs/console_bridge:=
-"
-# dev-ros/hector_timing
-DEPEND="${RDEPEND}
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-"
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
deleted file mode 100644
index 8bfff8077200..000000000000
--- a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/hector_pose_estimation_core
- dev-ros/nodelet
- dev-ros/tf
- dev-ros/message_filters
- dev-libs/boost:=
- dev-libs/console_bridge:=
-"
-# dev-ros/hector_timing
-DEPEND="${RDEPEND}
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-"
diff --git a/dev-ros/hector_pose_estimation/metadata.xml b/dev-ros/hector_pose_estimation/metadata.xml
deleted file mode 100644
index b2ed6142a736..000000000000
--- a/dev-ros/hector_pose_estimation/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">tu-darmstadt-ros-pkg/hector_localization</remote-id>
- </upstream>
-</pkgmetadata>