summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-06-25 15:57:26 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-06-25 15:57:26 +0900
commita22e8ab3634910ede624d34ffde45294b8db0b8f (patch)
treee0dd200b429b09abb99f993148159a16f1f86661
parentapp-i18n/dbskkd-cdb: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-a22e8ab3634910ede624d34ffde45294b8db0b8f.tar.gz
gentoo-a22e8ab3634910ede624d34ffde45294b8db0b8f.tar.bz2
gentoo-a22e8ab3634910ede624d34ffde45294b8db0b8f.zip
app-i18n/dbskkd-cdb: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-i18n/dbskkd-cdb/dbskkd-cdb-2.00.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/app-i18n/dbskkd-cdb/dbskkd-cdb-2.00.ebuild b/app-i18n/dbskkd-cdb/dbskkd-cdb-2.00.ebuild
index 7b52b2b42279..49e7598db5f7 100644
--- a/app-i18n/dbskkd-cdb/dbskkd-cdb-2.00.ebuild
+++ b/app-i18n/dbskkd-cdb/dbskkd-cdb-2.00.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-inherit eutils multilib toolchain-funcs user
+EAPI="6"
-DESCRIPTION="Yet another Dictionary server for the SKK Japanese-input software"
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="SKK dictionary server based on cdb"
HOMEPAGE="https://github.com/jj1bdx/dbskkd-cdb"
SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
@@ -13,16 +14,24 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="|| ( dev-db/cdb dev-db/tinycdb )"
-RDEPEND=">=app-i18n/skk-jisyo-200705[cdb]
+DEPEND="|| (
+ dev-db/tinycdb
+ dev-db/cdb
+ )"
+RDEPEND="app-i18n/skk-jisyo[cdb]
sys-apps/xinetd"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+)
+DOCS="CHANGES README* *.txt"
+
pkg_setup() {
enewuser dbskkd -1 -1 -1
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-gentoo.patch
+ default
local cdblib=()
if has_version dev-db/cdb; then
@@ -41,16 +50,14 @@ src_prepare() {
src_compile() {
emake \
CC="$(tc-getCC)" \
- COMPAT="-DJISYO_FILE=\\\"${EPREFIX}/usr/share/skk/SKK-JISYO.L.cdb\\\"" \
- || die
+ COMPAT="-DJISYO_FILE=\\\"${EPREFIX}/usr/share/skk/SKK-JISYO.L.cdb\\\""
}
src_install() {
exeinto /usr/libexec
doexe ${PN}
+ einstalldocs
insinto /etc/xinetd.d
- newins "${FILESDIR}/${PN}.xinetd" ${PN} || die
-
- dodoc CHANGES README* *.txt
+ newins "${FILESDIR}"/${PN}.xinetd ${PN}
}