summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-17 16:51:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-17 18:11:41 +0100
commita27da484bf49bfbcdf9e91cfd7653a7b2cb1a10f (patch)
treedeacaa8510e1279060570852d22ee15f3f79a1f2
parentapp-i18n/fcitx-rime: Fix dependency on librime (diff)
downloadgentoo-a27da484bf49bfbcdf9e91cfd7653a7b2cb1a10f.tar.gz
gentoo-a27da484bf49bfbcdf9e91cfd7653a7b2cb1a10f.tar.bz2
gentoo-a27da484bf49bfbcdf9e91cfd7653a7b2cb1a10f.zip
dev-python/pip: Use PYTEST_XDIST
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip/pip-23.3.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pip/pip-23.3.2.ebuild b/dev-python/pip/pip-23.3.2.ebuild
index 0b448915d1fb..69e2e40cefb0 100644
--- a/dev-python/pip/pip-23.3.2.ebuild
+++ b/dev-python/pip/pip-23.3.2.ebuild
@@ -10,7 +10,7 @@ PYTHON_TESTED=( python3_{10..11} )
PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_12 pypy3 )
PYTHON_REQ_USE="ssl(+),threads(+)"
-inherit bash-completion-r1 distutils-r1 multiprocessing
+inherit bash-completion-r1 distutils-r1
DESCRIPTION="The PyPA recommended tool for installing Python packages"
HOMEPAGE="
@@ -117,7 +117,8 @@ python_test() {
local -x SETUPTOOLS_USE_DISTUTILS=stdlib
local -x PIP_DISABLE_PIP_VERSION_CHECK=1
- epytest -m "not network" -n "$(makeopts_jobs)"
+ local EPYTEST_XDIST=1
+ epytest -m "not network"
}
python_install_all() {