summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-02-07 04:49:13 +0300
committerPatrice Clement <monsieurp@gentoo.org>2019-03-13 15:57:19 +0100
commita4215f047254e25ac869e325e8128092dd15280a (patch)
tree173ef86488a901f431ab1da6d1b521bdfcfe2a0b
parentdev-libs/mxml: fix slot version. (diff)
downloadgentoo-a4215f047254e25ac869e325e8128092dd15280a.tar.gz
gentoo-a4215f047254e25ac869e325e8128092dd15280a.tar.bz2
gentoo-a4215f047254e25ac869e325e8128092dd15280a.zip
net-analyzer/openvas: version bump to 9.0.0.
Bump to 9.0.0. Bump to EAPI 7. This also brings new improvements and introduces the new USE flags: 'extras' 'cli' 'gsa' 'ospd' 'ldap' 'radius'. Acked-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Reported-by: NP-Hardass <np-hardass@gentoo.org> Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10994 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--net-analyzer/openvas/metadata.xml20
-rw-r--r--net-analyzer/openvas/openvas-9.0.0.ebuild47
2 files changed, 63 insertions, 4 deletions
diff --git a/net-analyzer/openvas/metadata.xml b/net-analyzer/openvas/metadata.xml
index 38b8343826ee..a2806dd34dca 100644
--- a/net-analyzer/openvas/metadata.xml
+++ b/net-analyzer/openvas/metadata.xml
@@ -1,8 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
- <use>
- <flag name="pdf">Enable pdf report creation</flag>
- </use>
+ <maintainer type="person">
+ <email>hasan.calisir@psauxit.com</email>
+ <name>Hasan ÇALIŞIR</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="extras">Extra fonts, pdf results and html docs support</flag>
+ <flag name="cli">Command Line Interface for OpenVAS Scanner throught <pkg>net-analyzer/gvm-tools</pkg></flag>
+ <flag name="gsa">Greenbone Security Assistant (WebUI) through <pkg>net-analyzer/greenbone-security-assistant</pkg></flag>
+ <flag name="ospd">Enable support for scanner wrappers through <pkg>net-analyzer/ospd</pkg></flag>
+ <flag name="ldap">Enable support for ldap through <pkg>net-nds/openldap</pkg></flag>
+ <flag name="radius">Enable support for radius through <pkg>net-dialup/freeradius-client</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/net-analyzer/openvas/openvas-9.0.0.ebuild b/net-analyzer/openvas/openvas-9.0.0.ebuild
new file mode 100644
index 000000000000..f7bf53cc8a19
--- /dev/null
+++ b/net-analyzer/openvas/openvas-9.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cli +extras +gsa ldap +ospd radius"
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-9.0.3
+ >=net-analyzer/openvas-manager-7.0.3
+ >=net-analyzer/openvas-scanner-5.1.3
+ cli? ( >=net-analyzer/gvm-tools-1.4.1 )
+ extras? (
+ >=net-analyzer/openvas-libraries-9.0.3[extras]
+ >=net-analyzer/openvas-manager-7.0.3[extras]
+ >=net-analyzer/openvas-scanner-5.1.3[extras]
+ )
+ gsa? ( >=net-analyzer/greenbone-security-assistant-7.0.3
+ extras? ( >=net-analyzer/greenbone-security-assistant-7.0.3[extras] )
+ )
+ ldap? ( >=net-analyzer/openvas-libraries-9.0.3[ldap] )
+ ospd? ( >=net-analyzer/ospd-1.3.2
+ extras? ( >=net-analyzer/ospd-1.3.2[extras] )
+ )
+ radius? ( >=net-analyzer/openvas-libraries-9.0.3[radius] )"
+
+pkg_postinst() {
+ elog "----------------------------IMPORTANT----------------------------"
+ elog " Please read important notes > /usr/share/openvas/OPENVAS.gentoo "
+ elog "-----------------------------------------------------------------"
+ elog "Additional support for extra checks can be get from"
+ optfeature "Web server scanning and testing tool" net-analyzer/nikto
+ optfeature "Portscanner" net-analyzer/nmap
+ optfeature "IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "Application protocol detection tool" net-analyzer/amap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "Web application attack and audit framework" net-analyzer/w3af
+}