summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-16 02:41:22 +0100
committerSam James <sam@gentoo.org>2021-09-16 02:41:22 +0100
commita580532de52c209b8dc15a164a9bcba141fc69d1 (patch)
treeaf6d2a5d6210bc0925f75924987d04605a53ddf4
parentsci-libs/libsigrokdecode: Pick the right python3-embed version (diff)
downloadgentoo-a580532de52c209b8dc15a164a9bcba141fc69d1.tar.gz
gentoo-a580532de52c209b8dc15a164a9bcba141fc69d1.tar.bz2
gentoo-a580532de52c209b8dc15a164a9bcba141fc69d1.zip
sci-libs/fftw: add 3.3.10, sync live
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/fftw/Manifest1
-rw-r--r--sci-libs/fftw/fftw-3.3.10.ebuild163
-rw-r--r--sci-libs/fftw/fftw-3.3.9.ebuild4
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild31
4 files changed, 183 insertions, 16 deletions
diff --git a/sci-libs/fftw/Manifest b/sci-libs/fftw/Manifest
index a43277669038..77f9c12fde3a 100644
--- a/sci-libs/fftw/Manifest
+++ b/sci-libs/fftw/Manifest
@@ -1 +1,2 @@
+DIST fftw-3.3.10.tar.gz 4144100 BLAKE2B 3663872bd95a01d2c79af185f53918e1d1a9c91c620082402772c07f25b9b77d4920a78dc686fac6b51aa961b8d62b7e2cef3f3031e096bed40ced80b59b29d5 SHA512 2d34b5ccac7b08740dbdacc6ebe451d8a34cf9d9bfec85a5e776e87adf94abfd803c222412d8e10fbaa4ed46f504aa87180396af1b108666cde4314a55610b40
DIST fftw-3.3.9.tar.gz 4146999 BLAKE2B 6ea6966f3c5056102e6c3e4628b072c7e9832e3250b292808ed934b3a82515fd77658cbaff50d7b1268fb8c9444b10e39b22d100b7c31ea2452f3cee59c9f280 SHA512 52ebc2a33063a41fd478f6ea2acbf3b511867f736591d273dd57f9dfca5d3e0b0c73157921b3a36f1a7cfd741a8a6bde0fd80de578040ae730ea168b5ba466cf
diff --git a/sci-libs/fftw/fftw-3.3.10.ebuild b/sci-libs/fftw/fftw-3.3.10.ebuild
new file mode 100644
index 000000000000..c8a32cdc88e8
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.3.10.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit flag-o-matic fortran-2 multibuild multilib-minimal toolchain-funcs
+
+DESCRIPTION="Fast C library for the Discrete Fourier Transform"
+HOMEPAGE="https://www.fftw.org/"
+
+MY_P=${PN}-${PV/_p/-pl}
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
+else
+ SRC_URI="https://www.fftw.org/${PN}-${PV/_p/-pl}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="3.0/3"
+IUSE="cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi openmp test threads zbus"
+RESTRICT="!test? ( test )"
+
+RDEPEND="mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-lang/perl )"
+
+HTML_DOCS=( doc/html/. )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ FORTRAN_NEED_OPENMP=1
+ fi
+
+ fortran-2_pkg_setup
+ MULTIBUILD_VARIANTS=( single double longdouble )
+}
+
+src_prepare() {
+ default
+
+ # fix info file for category directory
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
+ $(use_enable fortran)
+ $(use_enable zbus mips-zbus-timer)
+ $(use_enable threads)
+ $(use_enable openmp)
+ )
+
+ [[ ${PV} == *9999 ]] && myconf+=( --enable-maintainer-mode )
+
+ # --enable-quad-precision is a brittle feature that requires
+ # __float128 support from the toolchain, which is lacking on
+ # most niche architectures. Bug #770346
+ case "${MULTIBUILD_ID}" in
+ single-*)
+ # altivec, sse, single-paired only work for single
+ myconf+=(
+ --enable-single
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_avx2 avx2)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable cpu_flags_arm_neon neon)
+ $(use_enable mpi)
+ )
+ ;;
+
+ double-*)
+ myconf+=(
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_avx2 avx2)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable mpi)
+ )
+ ;;
+
+ longdouble-*)
+ myconf+=(
+ --enable-long-double
+ $(use_enable mpi)
+ )
+ ;;
+
+ *)
+ die "${MULTIBUILD_ID%-*} precision not implemented in this ebuild"
+ ;;
+ esac
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC)"
+}
+
+src_configure() {
+ # upstream does not append proper -m flags
+ # https://bugs.gentoo.org/698572
+ use cpu_flags_x86_avx2 && append-flags -mavx2
+
+ multibuild_foreach_variant multilib-minimal_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant multilib-minimal_src_compile
+}
+
+multilib_src_test() {
+ emake -C tests smallcheck
+}
+
+src_test() {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ # local testbase="perl check.pl --nthreads=1 --estimate"
+ # ${testbase} -${p}d || die "Failure: $n"
+
+ multibuild_foreach_variant multilib-minimal_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant multilib-minimal_src_install
+ dodoc CONVENTIONS
+
+ if use doc; then
+ dodoc doc/*.pdf
+ docinto faq
+ dodoc -r doc/FAQ/fftw-faq.html/.
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/html || die
+ fi
+
+ augment_pc_files() {
+ local x
+ for x in "${ED}"/usr/$(get_libdir)/pkgconfig/*.pc; do
+ local u
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_${u} &|" "${x}" > "${x%.pc}_${u}.pc" || die
+ done
+ done
+ }
+ multilib_foreach_abi augment_pc_files
+
+ # fftw uses pkg-config to record its private dependencies
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/fftw/fftw-3.3.9.ebuild b/sci-libs/fftw/fftw-3.3.9.ebuild
index cbd8e2451a7e..e377ed60541c 100644
--- a/sci-libs/fftw/fftw-3.3.9.ebuild
+++ b/sci-libs/fftw/fftw-3.3.9.ebuild
@@ -8,7 +8,7 @@ FORTRAN_NEEDED=fortran
inherit flag-o-matic fortran-2 multibuild multilib-minimal toolchain-funcs
DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
+HOMEPAGE="https://www.fftw.org/"
MY_P=${PN}-${PV/_p/-pl}
@@ -16,7 +16,7 @@ if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
else
- SRC_URI="http://www.fftw.org/${PN}-${PV/_p/-pl}.tar.gz"
+ SRC_URI="https://www.fftw.org/${PN}-${PV/_p/-pl}.tar.gz"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index 23c52fd7f3d2..c8a32cdc88e8 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -8,7 +8,7 @@ FORTRAN_NEEDED=fortran
inherit flag-o-matic fortran-2 multibuild multilib-minimal toolchain-funcs
DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
+HOMEPAGE="https://www.fftw.org/"
MY_P=${PN}-${PV/_p/-pl}
@@ -16,22 +16,21 @@ if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
else
- SRC_URI="http://www.fftw.org/${PN}-${PV/_p/-pl}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ SRC_URI="https://www.fftw.org/${PN}-${PV/_p/-pl}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
+S="${WORKDIR}/${MY_P}"
+
LICENSE="GPL-2+"
SLOT="3.0/3"
IUSE="cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi openmp test threads zbus"
RESTRICT="!test? ( test )"
-RDEPEND="
- mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP}] )"
+RDEPEND="mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
-BDEPEND="
- test? ( dev-lang/perl )"
+BDEPEND="test? ( dev-lang/perl )"
-S="${WORKDIR}/${MY_P}"
HTML_DOCS=( doc/html/. )
pkg_pretend() {
@@ -65,6 +64,7 @@ multilib_src_configure() {
$(use_enable threads)
$(use_enable openmp)
)
+
[[ ${PV} == *9999 ]] && myconf+=( --enable-maintainer-mode )
# --enable-quad-precision is a brittle feature that requires
@@ -147,13 +147,16 @@ src_install() {
rm -r "${ED}"/usr/share/doc/${PF}/html || die
fi
- local x
- for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
- local u
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_${u} &|" "$x" > "${x%.pc}_${u}.pc" || die
+ augment_pc_files() {
+ local x
+ for x in "${ED}"/usr/$(get_libdir)/pkgconfig/*.pc; do
+ local u
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_${u} &|" "${x}" > "${x%.pc}_${u}.pc" || die
+ done
done
- done
+ }
+ multilib_foreach_abi augment_pc_files
# fftw uses pkg-config to record its private dependencies
find "${ED}" -name '*.la' -delete || die