summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:17:39 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2024-04-20 09:18:57 -0500
commita5be226664388de75a0bc65d1012f71b66f0dc8f (patch)
tree7246b3812deeceecadce2816cbde3e0cab1ca325
parentapp-admin/puppetserver: add 8.6.0 (diff)
downloadgentoo-a5be226664388de75a0bc65d1012f71b66f0dc8f.tar.gz
gentoo-a5be226664388de75a0bc65d1012f71b66f0dc8f.tar.bz2
gentoo-a5be226664388de75a0bc65d1012f71b66f0dc8f.zip
app-admin/puppet-agent: add 8.6.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-8.6.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index a3659f8feffb..a695258bc7d4 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -6,3 +6,5 @@ DIST puppet-agent_8.5.0-1focal_amd64.deb 35945720 BLAKE2B 485fa3e93006c63265df27
DIST puppet-agent_8.5.0-1focal_arm64.deb 35436786 BLAKE2B 712f893f05f9f75bf7af0cf40556f0746a81fabbd8e588ad598f59856bfe4948c53eb92e2eaa7a621507183c572d17ecb2b426b13a91bbd0b98cc2463070a60e SHA512 ce1752d13b2d4b9442ef11006e8bc0edf98e855df051491efd2760b6919c41f0dda2030910e5794658ae99d3b8341e9bf64aa57c65069f9d83a3f328f1d2dd41
DIST puppet-agent_8.5.1-1focal_amd64.deb 35945834 BLAKE2B 8c839eabf8abbc6cf87ab8a1c942b97be7fc08b9053695d07a7fc4bbf69886192063553c43f81e73521327cf8b89af18fe43d41ef3f71229d218fe123426f50c SHA512 324ea532d005a1bbb0f25fdd411f3f68a1c18371cb494f8934d73d87c19e3bbf46c653a9afbe767ed2ab6e788115f31ccef4bd084351ee6f73e4e656aab5d65a
DIST puppet-agent_8.5.1-1focal_arm64.deb 35436770 BLAKE2B 16ead6317dab6f8b65b8ea5269eec5593697f4da6d1ec0323e074f4eab3c8518dab10af48853e591aecc62c63a5ff4e135cf02bb1d7f7d565c5200bfae98ff86 SHA512 f3acc097563d9a56cb677df72250ee25ab0e1e361eb40a2cd36b3d694854edc3850f08099b916aefbc16580f78a194e9f3bf33b1cb585836d55c6e8dcf03a379
+DIST puppet-agent_8.6.0-1focal_amd64.deb 35966100 BLAKE2B a27e5fd32c73dd798612cc78a2e4abc150b425215592e9c7a88c7d3b54a2f6dcaffd557575e7c6f64116228fdd50e15a503f8b4c8c496c0f970ee772d5a88e6c SHA512 10a89f73219da6b59e63e8d2aba63968ef2236e773077c54ef6001b010b20b3e384676880cc10b8be4fc16336bb123783de88b0fd1d5c5d91c2455f410458363
+DIST puppet-agent_8.6.0-1focal_arm64.deb 35459524 BLAKE2B 5c9bc90eb3b2857176988acb41ebf0eed173077adabe74a6570ada92f9c2c829a57b949ea0c1cb1cae2e7b562b52882da58fab1552934e18bd676163c10e1924 SHA512 f91d82dcb66667891c6155e171739f34a174529a09c376fc7e1a829cd6862e52d26dc39ab3b0d273e32b56e52c62193c8d574d5164f3152bab6e50b4872c5e52
diff --git a/app-admin/puppet-agent/puppet-agent-8.6.0.ebuild b/app-admin/puppet-agent/puppet-agent-8.6.0.ebuild
new file mode 100644
index 000000000000..32089749d68e
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-8.6.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="amd64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb )
+arm64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_arm64.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}