summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2023-05-18 11:49:11 +0200
committerSam James <sam@gentoo.org>2023-05-20 07:27:54 +0100
commita5e1cb60d4c98b2b955fef198da6b513a571518e (patch)
treeb38f66c3bb945fbbe64553706288c250a8c34e7b
parentdev-cpp/doctest: drop 2.4.9, 2.4.10 (diff)
downloadgentoo-a5e1cb60d4c98b2b955fef198da6b513a571518e.tar.gz
gentoo-a5e1cb60d4c98b2b955fef198da6b513a571518e.tar.bz2
gentoo-a5e1cb60d4c98b2b955fef198da6b513a571518e.zip
sys-cluster/hpx: add 1.9.0
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/hpx-1.9.0.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index ab1db7886afc..53574bf4e9f4 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1,2 +1,3 @@
DIST hpx-1.8.0.tar.gz 5209106 BLAKE2B aab9d3743cc2d73c2d3a6a2f2323e35dbe38cf506618475ea627d9c0d92855632f646404f5b257e2260eabe6bb22e8090bc3db2aafd9f4f71a0eeb62d7286247 SHA512 80afc93d517144d5c11164f82d7f0dd6fd71c079fb65930532c4fd96b6a5497cdf972bee8a6251035548a3662579a3bee5c04802569f47bc3c042ca868716cb7
DIST hpx-1.8.1.tar.gz 5242024 BLAKE2B 0a08c004573cf2bebff4042f859fa457bd821bd55b58aa0e0e56dfc8b80378469c24daa94789196d9486a3321598031a0930306e2e76c311b6fd8179e9bc61a1 SHA512 af2471a04dd0a3c414907ed06661ab1c6f6a49cc09d1ed3ae5d5587ca365270797a1d2ce9d0320dc7d7f9ff2c6d29037c7fbb84fa6d9c0033628ba7036f12986
+DIST hpx-1.9.0.tar.gz 5648944 BLAKE2B 642fa16e97954973715bbd87b242b1f7ed13c64dfcffb00f50d7826dd114b3908a350b87508b9b6fde66df8fd772ae1b501f209bc200e3331312c0cc4ab88e80 SHA512 a9b55999e0d9f79433a44f0f7f21340e947fa0ba354ecb007340664a0f4820be1f7723075d18775a395a455648bbb4bff85061e6f7ad4b551b93943e845d4443
diff --git a/sys-cluster/hpx/hpx-1.9.0.ebuild b/sys-cluster/hpx/hpx-1.9.0.ebuild
new file mode 100644
index 000000000000..e3f75c15ac02
--- /dev/null
+++ b/sys-cluster/hpx/hpx-1.9.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+else
+ SRC_URI="https://github.com/STEllAR-GROUP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit check-reqs cmake multiprocessing python-single-r1
+
+DESCRIPTION="C++ runtime system for parallel and distributed applications"
+HOMEPAGE="https://hpx.stellar-group.org/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="examples jemalloc mpi papi +perftools tbb zlib"
+# tests fail to compile
+RESTRICT="test"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ?? ( jemalloc perftools tbb )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-cpp/asio-1.12.0
+ dev-libs/boost:=
+ sys-apps/hwloc:=
+ jemalloc? ( dev-libs/jemalloc:= )
+ mpi? ( virtual/mpi )
+ papi? ( dev-libs/papi )
+ perftools? ( dev-util/google-perftools:= )
+ tbb? ( dev-cpp/tbb:= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.0-python.patch"
+)
+
+hpx_memory_requirement() {
+ # HPX needs enough main memory for compiling
+ # rule of thumb: 1G per job
+ if [[ -z ${MAKEOPTS} ]] ; then
+ echo "2G"
+ else
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+ echo "${jobs}G"
+ fi
+}
+
+pkg_pretend() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+}
+
+pkg_setup() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHPX_WITH_EXAMPLES=OFF
+ -DHPX_WITH_DOCUMENTATION=OFF
+ -DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
+ -DHPX_WITH_PAPI=$(usex papi)
+ -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
+ -DHPX_WITH_COMPRESSION_ZLIB=$(usex zlib)
+ -DHPX_WITH_TESTS=OFF
+ )
+ if use jemalloc; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
+ elif use perftools; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
+ elif use tbb; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
+ else
+ mycmakeargs+=( -DHPX_WITH_MALLOC=system )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+ use examples && dodoc -r examples/
+ python_fix_shebang "${ED}"
+}