summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-11-27 11:05:51 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-27 11:28:24 -0500
commita692f52ca05cb9dbdd2212dfd63e55dfd2a14671 (patch)
treee3170a0076f60a600bc436e5e03723adcc8c3074
parentnet-misc/arpsponge: drop old EAPI (diff)
downloadgentoo-a692f52ca05cb9dbdd2212dfd63e55dfd2a14671.tar.gz
gentoo-a692f52ca05cb9dbdd2212dfd63e55dfd2a14671.tar.bz2
gentoo-a692f52ca05cb9dbdd2212dfd63e55dfd2a14671.zip
net-misc/csync: drop old EAPI
Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--net-misc/csync/csync-0.50.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/net-misc/csync/csync-0.50.0.ebuild b/net-misc/csync/csync-0.50.0.ebuild
deleted file mode 100644
index 188fcabcab5f..000000000000
--- a/net-misc/csync/csync-0.50.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="lightweight file synchronizer utility"
-HOMEPAGE="https://www.csync.org/"
-SRC_URI="https://open.cryptomilk.org/attachments/download/27/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc iconv samba +sftp test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-db/sqlite-3.4:3
- net-libs/neon[ssl]
- iconv? ( virtual/libiconv )
- samba? ( >=net-fs/samba-3.5 )
- sftp? ( >=net-libs/libssh-0.5 )
- !net-misc/ocsync"
-DEPEND="${RDEPEND}
- app-text/asciidoc
- doc? ( app-doc/doxygen )
- test? ( dev-util/cmocka )"
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -e "s/__FUNCTION__/__func__/" -i \
- src/csync_log.h tests/csync_tests/check_csync_log.c || die
- # proper docdir
- sed -e "s:/doc/${PN}:/doc/${PF}:" \
- -i doc/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
- $(cmake-utils_use_with iconv ICONV)
- $(cmake-utils_use test UNIT_TESTING)
- $(cmake-utils_use_find_package doc Doxygen)
- $(cmake-utils_use_find_package samba Libsmbclient)
- $(cmake-utils_use_find_package sftp LibSSH)
- )
- cmake-utils_src_configure
-}