summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 05:32:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 05:44:12 +0100
commita74bcf9f7a007d6a2a6f2c9d6dd9296cdfc6e991 (patch)
tree65cafb584eb154569d9e2e7e5ff6cb369369673e
parentdev-python/pygal: Bump to 3.0.3 (diff)
downloadgentoo-a74bcf9f7a007d6a2a6f2c9d6dd9296cdfc6e991.tar.gz
gentoo-a74bcf9f7a007d6a2a6f2c9d6dd9296cdfc6e991.tar.bz2
gentoo-a74bcf9f7a007d6a2a6f2c9d6dd9296cdfc6e991.zip
dev-python/pyasn1: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyasn1/Manifest1
-rw-r--r--dev-python/pyasn1/pyasn1-0.5.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyasn1/Manifest b/dev-python/pyasn1/Manifest
index 57a8e949c090..1c1c94004c59 100644
--- a/dev-python/pyasn1/Manifest
+++ b/dev-python/pyasn1/Manifest
@@ -1 +1,2 @@
DIST pyasn1-0.5.0.tar.gz 145117 BLAKE2B dbbec0bebcfe11b8de983716fedf1bf28e6bcf7d5f89e3dcba929884347cc7cd3a8ef8b5ec44bbc799a7bae3de39c90cf5e48111384de571dc2034a79c3bb52b SHA512 763690184ce891555564d76902042791865815e59e1325100fca692140110e5e182ef3da84ffdf96b1876edeb2757bbb09c06d26e752a8110760dafbf9e3ca00
+DIST pyasn1-0.5.1.tar.gz 147134 BLAKE2B 3f209b845af307cf17d701ff6c6a1674978ed6a14b5132cfe1171d2560f0932c7f940364b247e5e2162b27bb807c44720a08af1b490d2ff665cea86fdfb66b6b SHA512 19478d810d000fb4435f6a1776f290b1618a693539ff8ffad8c41f9ac316938f1c0ae988db8571a838443407d312b5566887e20284a779ccf427888739f13833
diff --git a/dev-python/pyasn1/pyasn1-0.5.1.ebuild b/dev-python/pyasn1/pyasn1-0.5.1.ebuild
new file mode 100644
index 000000000000..21d0e2d6abd9
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="
+ https://pypi.org/project/pyasn1/
+ https://github.com/etingof/pyasn1/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx "docs/source"