summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 14:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 14:04:57 +0200
commita761062ce1fa9ace3f53b845d17192a9e1a1f416 (patch)
tree47a6fb16ccecee1ccb799d2dfdce1472e509912e
parentdev-python/pyopengl_accelerate: Remove old (diff)
downloadgentoo-a761062ce1fa9ace3f53b845d17192a9e1a1f416.tar.gz
gentoo-a761062ce1fa9ace3f53b845d17192a9e1a1f416.tar.bz2
gentoo-a761062ce1fa9ace3f53b845d17192a9e1a1f416.zip
dev-python/python-lsp-black: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-lsp-black/Manifest1
-rw-r--r--dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch94
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild42
3 files changed, 0 insertions, 137 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index 76bec82b40e6..3407923c9a61 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1,2 +1 @@
-DIST python-lsp-black-1.2.1.gh.tar.gz 9355 BLAKE2B f9c70ff07d9dfa31e3af919143deb8a49f43269469e8c64525f514624f4db67636da8254dae5274685ba2d883c8ddfd6dd9cb99981a337d7837d4007f15af11c SHA512 289b8f3642ed806409671d25e32997fb473720d0abd642c58c07d8c894831fa00f56dbc39e7d0fc8d98cad7de9f95ebdb6a0f637b8b4bbcc2a0716690feb647e
DIST python-lsp-black-1.3.0.gh.tar.gz 9781 BLAKE2B d079d7a95dff682b86df23825796d2fa6e89d1aa3e66da1452e576fd1e96a4c298da181f53840fe5fcdcbbc8a0ca55aa53cbc4885a0178b6402365ef41a239be SHA512 9e3d081ac022854626c120128949ab5e58c44f9e76ddd566e3b80a697fbc02a96f62994f43195b02f899e770768d55d223984267133eedd6f642b70560d46c09
diff --git a/dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch b/dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch
deleted file mode 100644
index 8ecef0287f40..000000000000
--- a/dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 80d34ca4f35baa654e5f1fee7860214950f1ae37 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 26 Jan 2023 12:07:11 +0100
-Subject: [PATCH] Replace the obsolete toml package with tomllib/tomli
-
-Use the modern `tomllib` module (in Python 3.11+) or its drop-in
-replacement `tomli` (for older Python versions) instead of the obsolete
-`toml` module. The latter is unmaintained and does not support TOML
-1.0.
----
- .pre-commit-config.yaml | 2 +-
- pylsp_black/plugin.py | 12 +++++++++---
- setup.cfg | 7 +++++--
- 3 files changed, 15 insertions(+), 6 deletions(-)
-
-diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
-index 304770e..d5bd147 100644
---- a/.pre-commit-config.yaml
-+++ b/.pre-commit-config.yaml
-@@ -17,7 +17,7 @@ repos:
- rev: v0.942
- hooks:
- - id: mypy
-- additional_dependencies: [black, types-pkg_resources, types-setuptools, types-toml]
-+ additional_dependencies: [black, types-pkg_resources, types-setuptools]
- - repo: https://github.com/pre-commit/pre-commit-hooks
- rev: v4.1.0
- hooks:
-diff --git a/pylsp_black/plugin.py b/pylsp_black/plugin.py
-index f013171..090b1b0 100644
---- a/pylsp_black/plugin.py
-+++ b/pylsp_black/plugin.py
-@@ -1,15 +1,20 @@
- import logging
- import os
-+import sys
- from functools import lru_cache
- from pathlib import Path
- from typing import Dict, Optional
-
- import black
--import toml
- from pylsp import hookimpl
- from pylsp._utils import get_eol_chars
- from pylsp.config.config import Config
-
-+if sys.version_info >= (3, 11):
-+ import tomllib
-+else:
-+ import tomli as tomllib
-+
- logger = logging.getLogger(__name__)
-
-
-@@ -154,8 +159,9 @@ def _load_config(filename: str, client_config: Config) -> Dict:
- return defaults
-
- try:
-- pyproject_toml = toml.load(str(pyproject_filename))
-- except (toml.TomlDecodeError, OSError):
-+ with open(pyproject_filename, "rb") as f:
-+ pyproject_toml = tomllib.load(f)
-+ except (tomllib.TOMLDecodeError, OSError):
- logger.warning(
- "Error decoding pyproject.toml, using defaults: %r",
- defaults,
-diff --git a/setup.cfg b/setup.cfg
-index 47510d5..257add6 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -18,7 +18,10 @@ classifiers =
-
- [options]
- packages = find:
--install_requires = python-lsp-server>=1.4.0; black>=22.3.0; toml
-+install_requires =
-+ python-lsp-server>=1.4.0
-+ black>=22.3.0
-+ tomli; python_version<'3.11'
- python_requires = >= 3.7
-
- [options.entry_points]
-@@ -26,7 +29,7 @@ pylsp = pylsp_black = pylsp_black.plugin
-
- [options.extras_require]
- # add any types-* packages to .pre-commit-config.yaml mypy additional_dependencies
--dev = isort>=5.0; flake8; pre-commit; pytest; mypy; pytest; types-pkg_resources; types-setuptools; types-toml
-+dev = isort>=5.0; flake8; pre-commit; pytest; mypy; pytest; types-pkg_resources; types-setuptools
-
- [flake8]
- max-line-length = 88
---
-2.39.1
-
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
deleted file mode 100644
index 8f0d2139bf47..000000000000
--- a/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Black plugin for the Python LSP Server"
-HOMEPAGE="
- https://github.com/python-lsp/python-lsp-black/
- https://pypi.org/project/python-lsp-black/
-"
-SRC_URI="
- https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-RDEPEND="
- >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/black-22.3.0[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-tomli.patch
-)