summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-27 00:54:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:06 +0100
commita7eccdebaf2e1ef2ff6ff708c70c7ee65ca3fdcf (patch)
tree3b8584a06a187725a1b3f47bc45ed4188b3194d9
parentgames-arcade/tuxanci: EAPI-7 bump, switch to cmake.eclass, DESCRIPTION (diff)
downloadgentoo-a7eccdebaf2e1ef2ff6ff708c70c7ee65ca3fdcf.tar.gz
gentoo-a7eccdebaf2e1ef2ff6ff708c70c7ee65ca3fdcf.tar.bz2
gentoo-a7eccdebaf2e1ef2ff6ff708c70c7ee65ca3fdcf.zip
games-arcade/tuxanci: Fix cmake to search for glu instead of gl
Closes: https://bugs.gentoo.org/715132 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--games-arcade/tuxanci/files/tuxanci-20110429-glu.patch11
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429-r1.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/games-arcade/tuxanci/files/tuxanci-20110429-glu.patch b/games-arcade/tuxanci/files/tuxanci-20110429-glu.patch
new file mode 100644
index 000000000000..4273114e41cc
--- /dev/null
+++ b/games-arcade/tuxanci/files/tuxanci-20110429-glu.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2011-04-29 00:29:40.000000000 +0200
++++ b/CMakeLists.txt 2021-02-27 00:48:05.172582259 +0100
+@@ -187,7 +187,7 @@
+ pkg_check_modules(FONTCONFIG REQUIRED fontconfig)
+ INCLUDE_DIRECTORIES ( ${FONTCONFIG_INCLUDE_DIRS} )
+ IF ( WITH_OPENGL )
+- pkg_check_modules(OPENGL REQUIRED gl>=7.5)
++ pkg_check_modules(OPENGL REQUIRED glu>=7.5)
+ INCLUDE_DIRECTORIES ( ${OPENGL_INCLUDE_DIRS} )
+ ENDIF ( WITH_OPENGL )
+ pkg_check_modules(SDL REQUIRED sdl)
diff --git a/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild b/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
index 96497f83db3f..583e5c193a07 100644
--- a/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
+++ b/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
@@ -38,6 +38,8 @@ BDEPEND="
nls? ( sys-devel/gettext )
"
+PATCHES=( "${FILESDIR}/${P}-glu.patch" ) # bug 715132
+
src_configure() {
local mycmakeargs=(
-DWITH_AUDIO=$(usex sound)