summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 04:48:22 +0000
committerSam James <sam@gentoo.org>2024-02-02 04:48:22 +0000
commita80347b49ec3ee5d4dad043ce919042d896ad611 (patch)
treed743dd76f6645839f09a095a003bd11622fb23c5
parentsys-apps/fakeroot: drop 1.31, 1.32.1 (diff)
downloadgentoo-a80347b49ec3ee5d4dad043ce919042d896ad611.tar.gz
gentoo-a80347b49ec3ee5d4dad043ce919042d896ad611.tar.bz2
gentoo-a80347b49ec3ee5d4dad043ce919042d896ad611.zip
sys-apps/fakeroot: add 1.33
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/fakeroot/Manifest1
-rw-r--r--sys-apps/fakeroot/fakeroot-1.33.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/Manifest b/sys-apps/fakeroot/Manifest
index fe95e2ae4340..5ba25406ed52 100644
--- a/sys-apps/fakeroot/Manifest
+++ b/sys-apps/fakeroot/Manifest
@@ -1 +1,2 @@
DIST fakeroot_1.32.2.orig.tar.gz 571345 BLAKE2B 796ad9a43fb6390ff9a286940517c84c0c4c304cdb9316bcb65da4e7a763e3911a3524cb47b797a48bec55e9f0ce587bd571ed11097ef4c4d4b6979609e4b4e4 SHA512 62fd597f8fb7e2d977892851a5dc579d431fc9a25fd0ce02e3997ac6be3d22edd9cf03ede68cf961096de86659962f9f04e0e747074ea3c79931c0413c32612a
+DIST fakeroot_1.33.orig.tar.gz 571364 BLAKE2B bdc961939c63d9fd2d9a6700a17ea36aba806b640aadc471053d4a947c1635783bd28e57237818036922c437e7d7624138192e7a3e0f6ee48073c6a1442f9052 SHA512 f87b85531fc5af4ff24a6e27a5b7a25f7d220672fb0b0b925554b0138f3cff7ff7920ce96ed77313a7fb55656a313dc07b58c2935be262091405e509fdcbec03
diff --git a/sys-apps/fakeroot/fakeroot-1.33.ebuild b/sys-apps/fakeroot/fakeroot-1.33.ebuild
new file mode 100644
index 000000000000..fd6feaf0de3f
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.33.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="de es fr nl pt ro sv"
+inherit autotools flag-o-matic plocale
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug nls test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )
+"
+BDEPEND="nls? ( app-text/po4a )"
+
+DOCS=( AUTHORS BUGS DEBUG README doc/README.saving )
+
+src_prepare() {
+ default
+
+ disable_locale() {
+ local locale=${1}
+
+ sed -i -e "s: ${locale}::" doc/po4a/po4a.cfg doc/Makefile.am || die
+ }
+
+ plocale_find_changes doc/po4a/po '' '.po'
+ plocale_for_each_disabled_locale disable_locale
+
+ # We could make this conditional and disable the autodependency in
+ # autotools.eclass but it'd make it too easy for NLS builds to be broken
+ # and us not realise.
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+ use acl || export ac_cv_search_acl_get_fd=no # bug 759568
+ use debug && append-cppflags -DLIBFAKEROOT_DEBUGGING
+
+ # https://bugs.gentoo.org/834445
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
+ filter-flags -fno-semantic-interposition
+
+ econf --disable-static
+}
+
+src_compile() {
+ local enabled_locales=$(plocale_get_locales)
+
+ if use nls && [[ -n ${enabled_locales} ]] ; then
+ # Create translated man pages
+ pushd doc >/dev/null || die
+ po4a -v -k 0 --variable "srcdir=${S}/doc/" po4a/po4a.cfg || die
+ popd >/dev/null || die
+ fi
+
+ default
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}