summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-23 00:18:55 +0000
committerSam James <sam@gentoo.org>2021-12-23 00:19:07 +0000
commita8fe0f469f72fede9769365e1553f2706f9fb3eb (patch)
tree3ac918e835b063d5d8c7d2ee3de47bfb56d17d9e
parentdev-embedded/arduino-ctags: update EAPI 6 -> 8, fix build (diff)
downloadgentoo-a8fe0f469f72fede9769365e1553f2706f9fb3eb.tar.gz
gentoo-a8fe0f469f72fede9769365e1553f2706f9fb3eb.tar.bz2
gentoo-a8fe0f469f72fede9769365e1553f2706f9fb3eb.zip
app-emulation/aqemu: fix crash on startup
Closes: https://bugs.gentoo.org/738020 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/aqemu/aqemu-0.9.2-r2.ebuild43
-rw-r--r--app-emulation/aqemu/files/aqemu-0.9.2-crash-fix.patch116
2 files changed, 159 insertions, 0 deletions
diff --git a/app-emulation/aqemu/aqemu-0.9.2-r2.ebuild b/app-emulation/aqemu/aqemu-0.9.2-r2.ebuild
new file mode 100644
index 000000000000..30c5865b473a
--- /dev/null
+++ b/app-emulation/aqemu/aqemu-0.9.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Graphical interface for QEMU and KVM emulators, using Qt5"
+HOMEPAGE="https://sourceforge.net/projects/aqemu"
+SRC_URI="https://github.com/tobimensch/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vnc"
+
+RDEPEND="
+ app-emulation/qemu
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ vnc? ( net-libs/libvncserver )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS CHANGELOG README TODO )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.2-qtbindir.patch"
+ "${FILESDIR}/${PN}-0.9.2-include.patch"
+ "${FILESDIR}/${PN}-0.9.2-docs.patch"
+ "${FILESDIR}/${PN}-0.9.2-crash-fix.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAN_PAGE_COMPRESSOR=OFF
+ -DWITHOUT_EMBEDDED_DISPLAY=$(usex vnc OFF ON)
+ )
+
+ cmake_src_configure
+}
diff --git a/app-emulation/aqemu/files/aqemu-0.9.2-crash-fix.patch b/app-emulation/aqemu/files/aqemu-0.9.2-crash-fix.patch
new file mode 100644
index 000000000000..ef4c1a146461
--- /dev/null
+++ b/app-emulation/aqemu/files/aqemu-0.9.2-crash-fix.patch
@@ -0,0 +1,116 @@
+https://github.com/tobimensch/aqemu/pull/116
+https://bugs.gentoo.org/738020
+
+From dc19121a923c71eed248cd6310b9b06ec0af6abe Mon Sep 17 00:00:00 2001
+From: Moskaliou Nikita <44800696+nikitamos@users.noreply.github.com>
+Date: Sun, 5 Dec 2021 19:36:44 +0300
+Subject: [PATCH] Change widgets names
+
+Several widgets in the src/Main_Window.ui file had the same name ("widget"), for several users AQEMU crashed with SEGFAULT. So, the names were changed and now everything works fine
+--- a/src/Main_Window.ui
++++ b/src/Main_Window.ui
+@@ -226,7 +226,7 @@
+ </widget>
+ </item>
+ <item>
+- <widget class="QWidget" name="widget" native="true">
++ <widget class="QWidget" name="general_Machine_Sets" native="true">
+ <layout class="QGridLayout" name="gridLayout_12">
+ <property name="leftMargin">
+ <number>24</number>
+@@ -275,9 +275,6 @@
+ <property name="maxCount">
+ <number>64</number>
+ </property>
+- <property name="sizeAdjustPolicy">
+- <enum>QComboBox::AdjustToMinimumContentsLength</enum>
+- </property>
+ </widget>
+ </item>
+ <item row="3" column="1">
+@@ -294,9 +291,6 @@
+ <property name="maxCount">
+ <number>16</number>
+ </property>
+- <property name="sizeAdjustPolicy">
+- <enum>QComboBox::AdjustToMinimumContentsLength</enum>
+- </property>
+ <item>
+ <property name="text">
+ <string>1</string>
+@@ -395,9 +389,6 @@
+ <verstretch>0</verstretch>
+ </sizepolicy>
+ </property>
+- <property name="sizeAdjustPolicy">
+- <enum>QComboBox::AdjustToMinimumContentsLength</enum>
+- </property>
+ </widget>
+ </item>
+ <item row="2" column="2">
+@@ -526,9 +517,6 @@
+ <property name="maxCount">
+ <number>8</number>
+ </property>
+- <property name="sizeAdjustPolicy">
+- <enum>QComboBox::AdjustToMinimumContentsLength</enum>
+- </property>
+ <item>
+ <property name="text">
+ <string>Floppy</string>
+@@ -586,9 +574,6 @@
+ <property name="maxCount">
+ <number>8</number>
+ </property>
+- <property name="sizeAdjustPolicy">
+- <enum>QComboBox::AdjustToMinimumContentsLength</enum>
+- </property>
+ </widget>
+ </item>
+ <item row="3" column="0">
+@@ -618,9 +603,6 @@
+ <property name="maxCount">
+ <number>128</number>
+ </property>
+- <property name="sizeAdjustPolicy">
+- <enum>QComboBox::AdjustToMinimumContentsLength</enum>
+- </property>
+ <item>
+ <property name="text">
+ <string>en-us (default)</string>
+@@ -1333,7 +1315,7 @@
+ </widget>
+ </item>
+ </layout>
+- <zorder>widget</zorder>
++ <zorder>general_Machine_Sets</zorder>
+ <zorder>GB_Options</zorder>
+ <zorder>GB_Audio</zorder>
+ <zorder>GB_Memory</zorder>
+@@ -2457,7 +2439,7 @@
+ </layout>
+ </item>
+ <item row="1" column="0" colspan="2">
+- <widget class="QWidget" name="widget" native="true">
++ <widget class="QWidget" name="protocol_Sets" native="true">
+ <layout class="QHBoxLayout" name="Widget_Redirection_Protocol">
+ <property name="spacing">
+ <number>6</number>
+@@ -2515,7 +2497,7 @@
+ </widget>
+ </item>
+ <item row="2" column="0" colspan="2">
+- <widget class="QWidget" name="widget" native="true">
++ <widget class="QWidget" name="ip_Sets" native="true">
+ <layout class="QHBoxLayout" name="Widget_Redirection_Net">
+ <property name="spacing">
+ <number>6</number>
+@@ -3018,7 +3000,7 @@
+ <x>0</x>
+ <y>0</y>
+ <width>982</width>
+- <height>32</height>
++ <height>22</height>
+ </rect>
+ </property>
+ <widget class="QMenu" name="menuVM">