summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-26 08:10:10 +0100
committerSam James <sam@gentoo.org>2023-03-26 08:10:10 +0100
commitab88a2b6c2f57c904d2e2a63963824babe99b8b3 (patch)
tree03f16b9d18e9c414f377dd8a9368f94e03fdccc9
parentapp-emacs/emacs-ccls: add 0_pre20230311 (diff)
downloadgentoo-ab88a2b6c2f57c904d2e2a63963824babe99b8b3.tar.gz
gentoo-ab88a2b6c2f57c904d2e2a63963824babe99b8b3.tar.bz2
gentoo-ab88a2b6c2f57c904d2e2a63963824babe99b8b3.zip
app-emacs/company-mode: add 0.9.13_p20230306
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emacs/company-mode/Manifest1
-rw-r--r--app-emacs/company-mode/company-mode-0.9.13_p20230306.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/company-mode/Manifest b/app-emacs/company-mode/Manifest
index e06bef2fc62f..660b309d6cab 100644
--- a/app-emacs/company-mode/Manifest
+++ b/app-emacs/company-mode/Manifest
@@ -1,3 +1,4 @@
DIST company-mode-0.9.10.tar.gz 85982 BLAKE2B 393e8ff31f4a88d1c156418bd0c827572ec078b833e78bd1007779961e9fb852737f12a5c1aeba154ebba53d81058bdc2871f7d88880aaa7dd8cb9692461c8fb SHA512 b6571c55bcf68a5e83e7c92c8b53e0ac6b4e84bce1246331a7da4495f4ee5c3ab38035310fd2eb7a87748db1c034996d99c7ead8aa831d552800642b31cf9fe0
DIST company-mode-0.9.13.tar.gz 88074 BLAKE2B 8704d45d0dec15d7fbe39edcdaa3e348263eef4e78a9c55160b4c83df892b73241659dec685e31d7eab5fceaf34a956a7d81d0ec7d3ce134ffda0415a44a7c8c SHA512 d253504e38515335b9a7186c5664e2700ae171e215e8eef1fca28c267d610882dd29c03701efb9d71eac9ec855807aa956411de08a3bd42508f0b0aba38d4dd9
DIST company-mode-0.9.13_p20220720.tar.gz 2198598 BLAKE2B 0dad09689e11b613397149fd0f6c16aa0e01a8d79bd7fc79b66b2ad32a48544ba1a1a6488c316477c793218432383b6ba784c171ada15ac6fe90cce07920ba9d SHA512 fea6d572fee0ecbd91fb41427d7e1eec462fd92da426af1011d1f5c590c2b6c793064c5d25aad49728a9fbbd25a010ee2e17a495115e7bd3587092f3cb4b9f8a
+DIST company-mode-0.9.13_p20230306.tar.gz 2199879 BLAKE2B 01001537447849ea6a83bc90096945deef76e8b68d2d9d576e4de0742b84ceb4043db5556d548fe3e9d1b187c2dad577fa7364007958e848f52af7f105226348 SHA512 38abeab8a107b36a8ff69c981099d970eb4a9c9004d95414e65510200b9e6ec034b2ed1dc91e2a3cdac620db605297ae090fe75af152be725bc610e582c76e06
diff --git a/app-emacs/company-mode/company-mode-0.9.13_p20230306.ebuild b/app-emacs/company-mode/company-mode-0.9.13_p20230306.ebuild
new file mode 100644
index 000000000000..75d1d79097c9
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.9.13_p20230306.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=b3b9fa37ef9fd02471779130a0b53d87fa726ac1
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="https://company-mode.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+PATCHES=( "${FILESDIR}"/${PN}-company-icons-root.patch )
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( CONTRIBUTING.md README.md NEWS.md )
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i company.el || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ emake -C doc company.info
+}
+
+src_test() {
+ emake test-batch
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto ${SITEETC}/${PN}
+ doins -r icons
+
+ doinfo doc/company.info
+}