summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2024-02-03 21:06:53 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-07 16:53:21 +0200
commitaf5873a8b85b041b0d8afce935566361e6e963d1 (patch)
tree47964b01ddb4c138f0ee16009114a7459c5d8aad
parentx11-wm/marco: add 1.27.1 (diff)
downloadgentoo-af5873a8b85b041b0d8afce935566361e6e963d1.tar.gz
gentoo-af5873a8b85b041b0d8afce935566361e6e963d1.tar.bz2
gentoo-af5873a8b85b041b0d8afce935566361e6e963d1.zip
mate-base/mate-desktop: add 1.27.4
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--mate-base/mate-desktop/Manifest1
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.27.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/Manifest b/mate-base/mate-desktop/Manifest
index 48f4b943c979..722d4e4f2b8c 100644
--- a/mate-base/mate-desktop/Manifest
+++ b/mate-base/mate-desktop/Manifest
@@ -1,2 +1,3 @@
DIST mate-desktop-1.26.2.tar.xz 1203480 BLAKE2B a77df2562e70cae78f4ee6693d2a2f66e1fccb5c118ba9f51a96b68bd0dc0fe1166c458636bf940b70058ade79bfc51d260aa829b0400814c6e50c297d697c98 SHA512 0e7d0dfdc58a5a6f1e5a8d1204a1a1d78f868eddb32cc36b54b77d7aee4f999e570dc66e0f16751e78bdb162ceb4858976fa3d7db52785cbded0b53e5cf069e3
DIST mate-desktop-1.27.3.tar.xz 1214764 BLAKE2B 853545b85741940dafd53c04a693f26405fda903378efc71b14cf19103db9a69b1881f01124e50269dd840b90021372ee9735af188ca4f68589317f180801f9b SHA512 49c4d56653bf352c15d73714be9ef2c55f08c5529f846170d47c38d4943d8be1b20eea02374e7c361341c49b70f75c6b004d93c13fdaef1492f93db6c8c05719
+DIST mate-desktop-1.27.4.tar.xz 1140668 BLAKE2B 10332e8cca247cbd2ec2753feef85447c50314a881dacf1ec7ba8796fa90eb89ba494dd60a76845d00da809e34f7c4aa0f8fb7470cc74eb691c4e2a6635a2f31 SHA512 6e67ba3349266d62832fd8c15884dbb0cfd34754f0d2678c02c57b5fe1eecbe34238e73ca9a911e0c1ebfeaa44156bf48f55f6edb7ded39c129a7c6d82cc3be8
diff --git a/mate-base/mate-desktop/mate-desktop-1.27.4.ebuild b/mate-base/mate-desktop/mate-desktop-1.27.4.ebuild
new file mode 100644
index 000000000000..ea391a41c927
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.27.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="FDL-1.1 GPL-2+ LGPL-2+ MIT-with-advertising"
+SLOT="0"
+
+IUSE="X debug +introspection startup-notification"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/dconf-0.13.4
+ x11-libs/cairo
+ x11-libs/libX11
+ >=x11-libs/libXrandr-1.3
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/iso-codes
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=x11-libs/gdk-pixbuf-2.36.5
+ virtual/pkgconfig
+"
+
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}