summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-20 18:59:09 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-20 20:30:53 +0100
commitaf6502c5956a20d2d329ec0c815aa4073d2667ef (patch)
treeb71ca6812c055ec7724a75b442211eb3035c99e8
parentdev-lang/dafny-bin: drop old 4.3.0 (diff)
downloadgentoo-af6502c5956a20d2d329ec0c815aa4073d2667ef.tar.gz
gentoo-af6502c5956a20d2d329ec0c815aa4073d2667ef.tar.bz2
gentoo-af6502c5956a20d2d329ec0c815aa4073d2667ef.zip
dev-lang/dafny-bin: bump to 4.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/dafny-bin/Manifest1
-rw-r--r--dev-lang/dafny-bin/dafny-bin-4.5.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index ee5052787c8e..1f100bb83c00 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1 +1,2 @@
DIST dafny-4.4.0-x64-ubuntu-20.04.zip 62873378 BLAKE2B ee471dfc0be515949bc3ec18cd46705ce35c7a0b43b8ffc35e7754cef57a3e9351b7e937b6735319d6255407b6cb46b4c0c69eab5a573fdf7671055efe3988b8 SHA512 acfd643bdf3dba7377fde8d36f3c7bfff27b575fbc212d02974958ad38fe433870128525ff22f9a76d4b1602d5253794409ce834b67c52571d395a737fc24471
+DIST dafny-4.5.0-x64-ubuntu-20.04.zip 63259963 BLAKE2B 2fd6bce2a4244b68ca2de6453e070ef05e67000667f946730608ea0806d4ee768bb612a83603b442071a4135e5a030edee38a70f0171cb1b7abd29e53cef5cbe SHA512 38c7c30ef764309eb26f9b54a2d15bac8953215915cc9a291524276609814cd76037480302f4e235710509a5cbe0e56a85bb8414be04ba8b9f63095a168543af
diff --git a/dev-lang/dafny-bin/dafny-bin-4.5.0.ebuild b/dev-lang/dafny-bin/dafny-bin-4.5.0.ebuild
new file mode 100644
index 000000000000..e1a433bf10e8
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-4.5.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/
+ https://github.com/dafny-lang/dafny/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-20.04.zip"
+S="${WORKDIR}/dafny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ !dev-lang/dafny
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust:0/2.12
+ sci-mathematics/z3
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym -r /${dest}/DafnyServer /usr/bin/dafny-server
+}