summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 18:47:07 +0000
committerSam James <sam@gentoo.org>2021-03-16 19:22:40 +0000
commitafc6c4232c063afd94cd94f0f241313befd52734 (patch)
tree83a9f9b3a5643ab6198bf468a4a5073a3d592f67
parentdev-libs/softhsm: drop 2.5.0 (diff)
downloadgentoo-afc6c4232c063afd94cd94f0f241313befd52734.tar.gz
gentoo-afc6c4232c063afd94cd94f0f241313befd52734.tar.bz2
gentoo-afc6c4232c063afd94cd94f0f241313befd52734.zip
dev-libs/opencryptoki: drop 3.4.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/opencryptoki/Manifest1
-rw-r--r--dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/dev-libs/opencryptoki/Manifest b/dev-libs/opencryptoki/Manifest
index 9d6774ceda6f..fadade59bcd6 100644
--- a/dev-libs/opencryptoki/Manifest
+++ b/dev-libs/opencryptoki/Manifest
@@ -1,2 +1 @@
DIST opencryptoki-3.6.1.tgz 1068197 BLAKE2B 0e7d867bd21863f56471ac2c8664148e5a6988ffc30e71feaf960245a1908d676c1791f2b751de4bdd694096bf7360af3a8f79df895eef1b8f61391aba09aaad SHA512 1874fabba6d3da49596622c7f8142a37329df95f129cb08319bb3900a944dde1ae5ce9d845d400726f4bda4579c730012b9bfd6c69c6d5a16b1f75b28a0ba4af
-DIST opencryptoki-v3.4.1.tgz 1014416 BLAKE2B f95f9c4923fb7ce283f2031c21221ec2dacf1afca50a5fcdb4e2e173c952bbc4402fda56664428087a2c5b33af8a94aba9fa361ef5c0e4f0b865391cbc304250 SHA512 98643463102f70226255f17a7c49cc454cce377404155b9624e77e36c9f03fb30c216d1769177666489a539e0886b071103a089c565f8fbf120c2a53239a2dd6
diff --git a/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild b/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild
deleted file mode 100644
index 99428ccb4f77..000000000000
--- a/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib flag-o-matic user
-
-DESCRIPTION="PKCS#11 provider cryptographic hardware"
-HOMEPAGE="https://sourceforge.net/projects/opencryptoki"
-SRC_URI="mirror://sourceforge/opencryptoki/${PV}/${PN}-v${PV}.tgz"
-
-# Upstream is looking into relicensing it into CPL-1.0 entirely; the CCA
-# token sources are under CPL-1.0 already.
-LICENSE="CPL-0.5"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~s390 ~x86"
-IUSE="debug libressl +tpm"
-
-RDEPEND="tpm? ( app-crypt/trousers )
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )"
-DEPEND="${RDEPEND}"
-
-DOCS=(
- README AUTHORS FAQ TODO
- doc/openCryptoki-HOWTO.pdf
-)
-
-# tests right now basically don't exist; the only available thing would
-# test against an installed copy and would kill a running pcscd, all
-# things that we're not interested to.
-RESTRICT=test
-
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- enewgroup pkcs11
-}
-
-src_prepare() {
- default
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- # package uses ${localstatedir}/lib as the default path, so if we
- # leave it to econf, it'll create /var/lib/lib.
-
- # Since upstream by default seem to enable any possible token, even
- # when they don't seem to be used, we limit ourselves to the
- # software emulation token (swtok) and if the user enabled the tpm
- # USE flag, tpmtok. The rest of the tokens seem to be hardware- or
- # software-dependent even when they build fine without their
- # requirements, but until somebody asks for those, I'd rather not
- # enable them.
-
- # We don't use --enable-debug because that tinkers with the CFLAGS
- # and we don't want that. Instead we append -DDEBUG which enables
- # debug information.
- use debug && append-flags -DDEBUG
-
- econf \
- --localstatedir=/var \
- --enable-fast-install \
- --disable-debug \
- --enable-daemon \
- --enable-library \
- --disable-icatok \
- --enable-swtok \
- $(use_enable tpm tpmtok) \
- --disable-ccatok
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-
- # Install libopencryptoki in the standard directory for libraries.
- mv "${ED}"/usr/$(get_libdir)/opencryptoki/libopencryptoki.so* "${ED}"/usr/$(get_libdir) || die
- rm "${ED}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so
- dosym ../libopencryptoki.so /usr/$(get_libdir)/pkcs11/libopencryptoki.so
-
- # Remove compatibility symlinks as we _never_ required those and
- # they seem unused even upstream.
- find "${ED}" -name 'PKCS11_*' -delete
-
- # We replace their ld.so and init files (mostly designed for RedHat
- # as far as I can tell) with our own replacements.
- rm -rf "${ED}"/etc/ld.so.conf.d "${ED}"/etc/rc.d
-
- # make sure that we don't modify the init script if the USE flags
- # are enabled for the needed services.
- cp "${FILESDIR}"/pkcsslotd.init.2 "${T}"/pkcsslotd.init
- use tpm || sed -i -e '/use tcsd/d' "${T}"/pkcsslotd.init
- newinitd "${T}/pkcsslotd.init" pkcsslotd
-
- # We create /var dirs at runtime as needed, so don't bother installing
- # our own.
- rm -r "${ED}"/var/{lib,lock} || die
-}