summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-23 20:08:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-24 01:26:54 +0200
commitb3e349ba4e523b5c7fdf3ac2171c0f3101a9185c (patch)
tree01a4f13b0f56f2a6584105903001c267632f6ebc
parentdev-games/openscenegraph-qt: Drop 3.5.7 (r0) (diff)
downloadgentoo-b3e349ba4e523b5c7fdf3ac2171c0f3101a9185c.tar.gz
gentoo-b3e349ba4e523b5c7fdf3ac2171c0f3101a9185c.tar.bz2
gentoo-b3e349ba4e523b5c7fdf3ac2171c0f3101a9185c.zip
app-text/cb2bib: Drop IUSE=webkit
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/cb2bib/cb2bib-2.0.0-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/app-text/cb2bib/cb2bib-2.0.0-r1.ebuild b/app-text/cb2bib/cb2bib-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..746edabdcd52
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-2.0.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="https://www.molspaces.com/cb2bib/"
+SRC_URI="https://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+lzo"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ lzo? ( dev-libs/lzo:2 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS CHANGELOG COPYRIGHT )
+
+src_prepare() {
+ default
+
+ sed -e "s|../AUTHORS ../COPYRIGHT ../LICENSE ../CHANGELOG||" \
+ -i src/src.pro || die
+
+ sed -i -e "s/qtHaveModule(webkitwidgets)/false/g" src/src.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ $(use !lzo && echo -config disable_lzo)
+}
+
+src_compile() {
+ # bug #709940
+ emake -j1
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler[utils] - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}