summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-11 01:04:55 +0000
committerSam James <sam@gentoo.org>2023-05-15 06:53:10 +0100
commitb4a4e1c5ea363b43e05b0d3ccd35473120bf3b12 (patch)
treee72185b46fdef9ab634a34ce0223f5329eeb4022
parentprofiles/desc: add tls for apache2_modules (diff)
downloadgentoo-b4a4e1c5ea363b43e05b0d3ccd35473120bf3b12.tar.gz
gentoo-b4a4e1c5ea363b43e05b0d3ccd35473120bf3b12.tar.bz2
gentoo-b4a4e1c5ea363b43e05b0d3ccd35473120bf3b12.zip
apache-2.eclass: add rustls support
Bug: https://bugs.gentoo.org/885099 Closes: https://bugs.gentoo.org/903746 Closes: https://github.com/gentoo/gentoo/pull/28634 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--eclass/apache-2.eclass1
-rw-r--r--profiles/arch/amd64/package.use.mask4
-rw-r--r--profiles/arch/amd64/package.use.stable.mask4
-rw-r--r--profiles/arch/base/package.use.mask4
-rw-r--r--profiles/features/wd40/package.use.mask1
-rw-r--r--www-servers/apache/apache-2.4.54-r8.ebuild2
-rw-r--r--www-servers/apache/apache-2.4.55-r1.ebuild2
-rw-r--r--www-servers/apache/apache-2.4.56.ebuild2
-rw-r--r--www-servers/apache/apache-2.4.57.ebuild2
9 files changed, 18 insertions, 4 deletions
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index f5816087826d..3dc3b3e56db0 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -162,6 +162,7 @@ RDEPEND="
apache2_modules_session_crypto? (
dev-libs/apr-util[openssl]
)
+ apache2_modules_tls? ( net-libs/rustls-ffi:= )
gdbm? ( sys-libs/gdbm:= )
ldap? ( net-nds/openldap:= )
selinux? ( sec-policy/selinux-apache )
diff --git a/profiles/arch/amd64/package.use.mask b/profiles/arch/amd64/package.use.mask
index 0e1ae1ff55f7..9a0ced87db7f 100644
--- a/profiles/arch/amd64/package.use.mask
+++ b/profiles/arch/amd64/package.use.mask
@@ -17,6 +17,10 @@
#--- END OF EXAMPLES ---
+# Sam James <sam@gentoo.org> (2023-05-15)
+# net-libs/rustls-ffi is keyworded here
+www-servers/apache -apache2_modules_tls
+
# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (2023-04-22)
# snap only works on amd64
kde-plasma/discover -snap
diff --git a/profiles/arch/amd64/package.use.stable.mask b/profiles/arch/amd64/package.use.stable.mask
index 5bb8f28a0550..133b37c5b56e 100644
--- a/profiles/arch/amd64/package.use.stable.mask
+++ b/profiles/arch/amd64/package.use.stable.mask
@@ -17,6 +17,10 @@
#--- END OF EXAMPLES ---
+# Sam James <sam@gentoo.org> (2023-05-15)
+# net-libs/rustls-ffi is not marked stable
+www-servers/apache apache2_modules_tls
+
# Michał Górny <mgorny@gentoo.org> (2023-04-22)
# pandoc is stable here.
dev-python/nbclassic -doc
diff --git a/profiles/arch/base/package.use.mask b/profiles/arch/base/package.use.mask
index 0ada1d4734f4..28b10b38c544 100644
--- a/profiles/arch/base/package.use.mask
+++ b/profiles/arch/base/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2023-05-15)
+# Unkeyworded dependencies
+www-servers/apache apache2_modules_tls
+
# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (2023-04-22)
# snap only works on amd64
kde-plasma/discover snap
diff --git a/profiles/features/wd40/package.use.mask b/profiles/features/wd40/package.use.mask
index 6f804cffb525..59fffef97364 100644
--- a/profiles/features/wd40/package.use.mask
+++ b/profiles/features/wd40/package.use.mask
@@ -21,6 +21,7 @@ dev-util/gef doc
# Sam James <sam@gentoo.org> (2022-12-11)
# net-libs/rustls-ffi needs Rust.
net-misc/curl rustls curl_ssl_rustls
+www-servers/apache apache2_modules_tls
# matoro <matoro_gentoo@matoro.tk> (2022-12-01)
# tree-sitter-grammar.eclass adds dev-util/tree-sitter-cli as test dep
diff --git a/www-servers/apache/apache-2.4.54-r8.ebuild b/www-servers/apache/apache-2.4.54-r8.ebuild
index 22298cd5637a..20956f07123d 100644
--- a/www-servers/apache/apache-2.4.54-r8.ebuild
+++ b/www-servers/apache/apache-2.4.54-r8.ebuild
@@ -40,7 +40,7 @@ lbmethod_heartbeat log_config log_forensic logio lua macro md mime mime_magic ne
proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_hcheck proxy_html proxy_http proxy_scgi
proxy_http2 proxy_fcgi proxy_uwsgi proxy_wstunnel rewrite ratelimit remoteip reqtimeout
session session_cookie session_crypto session_dbd setenvif slotmem_shm socache_memcache
-socache_shmcb speling status substitute systemd unique_id userdir usertrack
+socache_shmcb speling status substitute systemd tls unique_id userdir usertrack
unixd version vhost_alias watchdog xml2enc"
# The following are also in the source as of this version, but are not available
# for user selection:
diff --git a/www-servers/apache/apache-2.4.55-r1.ebuild b/www-servers/apache/apache-2.4.55-r1.ebuild
index 22298cd5637a..20956f07123d 100644
--- a/www-servers/apache/apache-2.4.55-r1.ebuild
+++ b/www-servers/apache/apache-2.4.55-r1.ebuild
@@ -40,7 +40,7 @@ lbmethod_heartbeat log_config log_forensic logio lua macro md mime mime_magic ne
proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_hcheck proxy_html proxy_http proxy_scgi
proxy_http2 proxy_fcgi proxy_uwsgi proxy_wstunnel rewrite ratelimit remoteip reqtimeout
session session_cookie session_crypto session_dbd setenvif slotmem_shm socache_memcache
-socache_shmcb speling status substitute systemd unique_id userdir usertrack
+socache_shmcb speling status substitute systemd tls unique_id userdir usertrack
unixd version vhost_alias watchdog xml2enc"
# The following are also in the source as of this version, but are not available
# for user selection:
diff --git a/www-servers/apache/apache-2.4.56.ebuild b/www-servers/apache/apache-2.4.56.ebuild
index 7520ff61b95e..ef1bcdbb9c31 100644
--- a/www-servers/apache/apache-2.4.56.ebuild
+++ b/www-servers/apache/apache-2.4.56.ebuild
@@ -40,7 +40,7 @@ lbmethod_heartbeat log_config log_forensic logio lua macro md mime mime_magic ne
proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_hcheck proxy_html proxy_http proxy_scgi
proxy_http2 proxy_fcgi proxy_uwsgi proxy_wstunnel rewrite ratelimit remoteip reqtimeout
session session_cookie session_crypto session_dbd setenvif slotmem_shm socache_memcache
-socache_shmcb speling status substitute systemd unique_id userdir usertrack
+socache_shmcb speling status substitute systemd tls unique_id userdir usertrack
unixd version vhost_alias watchdog xml2enc"
# The following are also in the source as of this version, but are not available
# for user selection:
diff --git a/www-servers/apache/apache-2.4.57.ebuild b/www-servers/apache/apache-2.4.57.ebuild
index 632d6506f31f..570f4964d14a 100644
--- a/www-servers/apache/apache-2.4.57.ebuild
+++ b/www-servers/apache/apache-2.4.57.ebuild
@@ -40,7 +40,7 @@ lbmethod_heartbeat log_config log_forensic logio lua macro md mime mime_magic ne
proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_hcheck proxy_html proxy_http proxy_scgi
proxy_http2 proxy_fcgi proxy_uwsgi proxy_wstunnel rewrite ratelimit remoteip reqtimeout
session session_cookie session_crypto session_dbd setenvif slotmem_shm socache_memcache
-socache_shmcb speling status substitute systemd unique_id userdir usertrack
+socache_shmcb speling status substitute systemd tls unique_id userdir usertrack
unixd version vhost_alias watchdog xml2enc"
# The following are also in the source as of this version, but are not available
# for user selection: